aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/xarchiver/Makefile21
-rw-r--r--archivers/xarchiver/pkg-plist15
2 files changed, 19 insertions, 17 deletions
diff --git a/archivers/xarchiver/Makefile b/archivers/xarchiver/Makefile
index 3bae2e2328d6..3310cc87aea5 100644
--- a/archivers/xarchiver/Makefile
+++ b/archivers/xarchiver/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xarchiver
PORTVERSION= 0.5.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= archivers
MASTER_SITES= SF
@@ -18,13 +18,13 @@ RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= glib20 gtk20 intltool pkgconfig
+USE_GNOME= glib20 gtk20 intltool pkgconfig desktopfileutils
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if !empty(PORT_OPTIONS:MNLS)
USE_GETTEXT= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -34,11 +34,16 @@ PLIST_SUB+= NLS="@comment "
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|;multipart/x-zip||' \
+ ${WRKSRC}/xarchiver.desktop.in
.if defined(NOPORTDOCS)
- ${REINPLACE_CMD} -e 's|doc||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|doc||g' ${WRKSRC}/Makefile.in
.endif
-.if defined(WITHOUT_NLS)
- ${REINPLACE_CMD} -e 's| po | |g' ${WRKSRC}/Makefile.in
+.if empty(PORT_OPTIONS:MNLS)
+ @${REINPLACE_CMD} -e 's| po | |g' ${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.post.mk>
+post-install:
+ @-update-desktop-database
+
+.include <bsd.port.mk>
diff --git a/archivers/xarchiver/pkg-plist b/archivers/xarchiver/pkg-plist
index c066a6439cfd..e659cdc70d1e 100644
--- a/archivers/xarchiver/pkg-plist
+++ b/archivers/xarchiver/pkg-plist
@@ -39,10 +39,10 @@ share/applications/xarchiver.desktop
%%PORTDOCS%%%%DOCSDIR%%/html/images/pref_dialog.png
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/xarchiver.css
-%%NLS%%share/icons/hicolor/16x16/apps/xarchiver.png
-%%NLS%%share/icons/hicolor/24x24/apps/xarchiver.png
-%%NLS%%share/icons/hicolor/48x48/apps/xarchiver.png
-%%NLS%%share/icons/hicolor/scalable/apps/xarchiver.svg
+share/icons/hicolor/16x16/apps/xarchiver.png
+share/icons/hicolor/24x24/apps/xarchiver.png
+share/icons/hicolor/48x48/apps/xarchiver.png
+share/icons/hicolor/scalable/apps/xarchiver.svg
%%NLS%%share/locale/bg/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/ca/LC_MESSAGES/xarchiver.mo
%%NLS%%share/locale/cs/LC_MESSAGES/xarchiver.mo
@@ -73,12 +73,9 @@ share/pixmaps/xarchiver/xarchiver-html.png
%%NLS%%@dirrm share/locale/nb_NO/LC_MESSAGES
%%NLS%%@dirrm share/locale/nb_NO
@dirrm share/pixmaps/xarchiver
-@dirrmtry share/icons/hicolor/scalable/apps
-@dirrmtry share/pixmaps/hicolor/48x48/apps
-@dirrmtry share/pixmaps/hicolor/24x24/apps
-@dirrmtry share/pixmaps/hicolor/16x16/apps
@dirrmtry libexec/thunar-archive-plugin
-@dirrmtry share/applications
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/images
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true