aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/GeoIP/Makefile7
-rw-r--r--net/GeoIP/files/patch-man__Makefile.in14
2 files changed, 18 insertions, 3 deletions
diff --git a/net/GeoIP/Makefile b/net/GeoIP/Makefile
index 3c32fb82c53b..658ca002c036 100644
--- a/net/GeoIP/Makefile
+++ b/net/GeoIP/Makefile
@@ -3,7 +3,7 @@
PORTNAME= GeoIP
PORTVERSION= 1.4.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net geography
MASTER_SITES= http://geolite.maxmind.com/download/geoip/api/c/
@@ -11,9 +11,10 @@ MAINTAINER= dhn@FreeBSD.org
COMMENT= Find the country that any IP address or hostname originates from
CONFIGURE_ARGS= CC="${CC}" PATH="${PATH}" \
- CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+ CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+USES= libtool:oldver
USE_LDCONFIG= yes
SUB_FILES= geoipupdate.sh
diff --git a/net/GeoIP/files/patch-man__Makefile.in b/net/GeoIP/files/patch-man__Makefile.in
new file mode 100644
index 000000000000..7604f41c24ff
--- /dev/null
+++ b/net/GeoIP/files/patch-man__Makefile.in
@@ -0,0 +1,14 @@
+--- man/Makefile.in.orig 2014-06-05 17:06:15.791427000 +0400
++++ man/Makefile.in 2014-06-05 17:09:15.000000000 +0400
+@@ -446,9 +446,11 @@
+ geoiplookup6.1: geoiplookup6.1.in
+
+ install-data-hook:
++ chmod u+w $(DESTDIR)$(mandir)/man1/*.1
+ cat geoipupdate.1 | sed s,DATADIR,$(pkgdatadir), | sed s,CONF_DIR,$(sysconfdir), > $(DESTDIR)$(UPDATE_MAN)
+ cat geoiplookup.1 | sed s,DATADIR,$(pkgdatadir), > $(DESTDIR)$(LOOKUP_MAN)
+ cat geoiplookup6.1 | sed s,DATADIR,$(pkgdatadir), > $(DESTDIR)$(LOOKUP6_MAN)
++ chmod u-w $(DESTDIR)$(mandir)/man1/*.1
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.