aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/p5-Sys-Hostname-Long/Makefile22
-rw-r--r--sysutils/p5-Sys-Hostname-Long/distinfo2
-rw-r--r--sysutils/p5-Sys-Hostname-Long/pkg-descr8
-rw-r--r--sysutils/p5-Sys-Hostname-Long/pkg-plist2
5 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 45bb61821fdc..7a8eaebedafe 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -244,6 +244,7 @@
SUBDIR += p5-Schedule-Match
SUBDIR += p5-Stat-lsMode
SUBDIR += p5-Sys-CpuLoad
+ SUBDIR += p5-Sys-Hostname-Long
SUBDIR += p5-SyslogScan
SUBDIR += p5-Tie-Syslog
SUBDIR += p5-UPS-Nut
diff --git a/sysutils/p5-Sys-Hostname-Long/Makefile b/sysutils/p5-Sys-Hostname-Long/Makefile
new file mode 100644
index 000000000000..b04f1fd8f83e
--- /dev/null
+++ b/sysutils/p5-Sys-Hostname-Long/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Sys-Hostname-Long
+# Date created: March 6th, 2004
+# Whom: Tim Bishop <tim@bishnet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sys-Hostname-Long
+PORTVERSION= 1.0
+CATEGORIES= sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sys
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tim@bishnet.net
+COMMENT= Try every conceivable way to get full hostname
+
+PERL_CONFIGURE= yes
+
+MAN3= Sys::Hostname::Long.3
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-Sys-Hostname-Long/distinfo b/sysutils/p5-Sys-Hostname-Long/distinfo
new file mode 100644
index 000000000000..9a787c25e605
--- /dev/null
+++ b/sysutils/p5-Sys-Hostname-Long/distinfo
@@ -0,0 +1,2 @@
+MD5 (Sys-Hostname-Long-1.0.tar.gz) = 7d045eb6992aee27df12be696252a94e
+SIZE (Sys-Hostname-Long-1.0.tar.gz) = 2286
diff --git a/sysutils/p5-Sys-Hostname-Long/pkg-descr b/sysutils/p5-Sys-Hostname-Long/pkg-descr
new file mode 100644
index 000000000000..35b09e72448b
--- /dev/null
+++ b/sysutils/p5-Sys-Hostname-Long/pkg-descr
@@ -0,0 +1,8 @@
+How to get the host full name in perl on multiple operating systems
+(mac, windows, unix* etc)
+
+Attempt via many methods to get the systems full name. The Sys::Hostname
+class is the best and standard way to get the system hostname.
+However it is missing the long hostname.
+
+WWW: http://search.cpan.org/dist/Sys-Hostname-Long/
diff --git a/sysutils/p5-Sys-Hostname-Long/pkg-plist b/sysutils/p5-Sys-Hostname-Long/pkg-plist
new file mode 100644
index 000000000000..8d7f15c0eb5b
--- /dev/null
+++ b/sysutils/p5-Sys-Hostname-Long/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Sys/Hostname/Long.pm
+@dirrm %%SITE_PERL%%/Sys/Hostname