aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/php56-odbc/files/patch-config.m439
-rw-r--r--lang/php56/Makefile2
-rw-r--r--lang/php56/distinfo4
3 files changed, 25 insertions, 20 deletions
diff --git a/databases/php56-odbc/files/patch-config.m4 b/databases/php56-odbc/files/patch-config.m4
index d8e2798d4c36..6d3d81b34ade 100644
--- a/databases/php56-odbc/files/patch-config.m4
+++ b/databases/php56-odbc/files/patch-config.m4
@@ -1,12 +1,17 @@
---- config.m4.orig 2014-08-27 13:31:35.000000000 +0000
-+++ config.m4 2014-09-04 12:44:43.855274203 +0000
-@@ -99,9 +99,12 @@
- dnl
+--- config.m4.orig 2015-03-19 00:19:30.000000000 +0000
++++ config.m4 2015-04-01 08:21:21.242902661 +0000
+@@ -100,13 +100,17 @@
dnl configure options
dnl
+
+PHP_ARG_ENABLE(odbc,,
-+[ --enable-odbc Enable ODBC support with selected driver])
++[ --enable-odbc Enable ODBC support with selected driver])
+
++
+ PHP_ARG_WITH(odbcver,,
+ [ --with-odbcver[=HEX] Force support for the passed ODBC version. A hex number is expected, default 0x0300.
+ Use the special value of 0 to prevent an explicit ODBCVER to be defined. ], 0x0300)
+
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(adabas,,
-[ --with-adabas[=DIR] Include Adabas D support [/usr/local]])
@@ -14,7 +19,7 @@
if test "$PHP_ADABAS" != "no"; then
AC_MSG_CHECKING([for Adabas support])
-@@ -128,7 +131,7 @@
+@@ -133,7 +137,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(sapdb,,
@@ -23,7 +28,7 @@
if test "$PHP_SAPDB" != "no"; then
AC_MSG_CHECKING([for SAP DB support])
-@@ -146,7 +149,7 @@
+@@ -151,7 +155,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(solid,,
@@ -32,7 +37,7 @@
if test "$PHP_SOLID" != "no"; then
AC_MSG_CHECKING(for Solid support)
-@@ -171,7 +174,7 @@
+@@ -176,7 +180,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(ibm-db2,,
@@ -41,7 +46,7 @@
if test "$PHP_IBM_DB2" != "no"; then
AC_MSG_CHECKING(for IBM DB2 support)
-@@ -208,7 +211,7 @@
+@@ -213,7 +217,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(ODBCRouter,,
@@ -50,7 +55,7 @@
if test "$PHP_ODBCROUTER" != "no"; then
AC_MSG_CHECKING(for ODBCRouter.com support)
-@@ -229,7 +232,7 @@
+@@ -234,7 +238,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(empress,,
[ --with-empress[=DIR] Include Empress support [\$EMPRESSPATH]
@@ -59,7 +64,7 @@
if test "$PHP_EMPRESS" != "no"; then
AC_MSG_CHECKING(for Empress support)
-@@ -253,7 +256,7 @@
+@@ -258,7 +262,7 @@
PHP_ARG_WITH(empress-bcs,,
[ --with-empress-bcs[=DIR]
Include Empress Local Access support [\$EMPRESSPATH]
@@ -68,7 +73,7 @@
if test "$PHP_EMPRESS_BCS" != "no"; then
AC_MSG_CHECKING(for Empress local access support)
-@@ -291,7 +294,7 @@
+@@ -296,7 +300,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(birdstep,,
@@ -77,7 +82,7 @@
if test "$PHP_BIRDSTEP" != "no"; then
AC_MSG_CHECKING(for Birdstep support)
-@@ -345,7 +348,7 @@
+@@ -350,7 +354,7 @@
running this configure script:
CPPFLAGS=\"-DODBC_QNX -DSQLANY_BUG\"
LDFLAGS=-lunix
@@ -86,7 +91,7 @@
if test "$PHP_CUSTOM_ODBC" != "no"; then
AC_MSG_CHECKING(for a custom ODBC support)
-@@ -365,7 +368,7 @@
+@@ -370,7 +374,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(iodbc,,
@@ -95,7 +100,7 @@
if test "$PHP_IODBC" != "no"; then
AC_MSG_CHECKING(for iODBC support)
-@@ -401,7 +404,7 @@
+@@ -406,7 +410,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(esoob,,
@@ -104,7 +109,7 @@
if test "$PHP_ESOOB" != "no"; then
AC_MSG_CHECKING(for Easysoft ODBC-ODBC Bridge support)
-@@ -421,7 +424,7 @@
+@@ -426,7 +430,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(unixODBC,,
@@ -113,7 +118,7 @@
if test "$PHP_UNIXODBC" != "no"; then
AC_MSG_CHECKING(for unixODBC support)
-@@ -442,7 +445,7 @@
+@@ -447,7 +451,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(dbmaker,,
diff --git a/lang/php56/Makefile b/lang/php56/Makefile
index db34d826d0f8..bdac80a082f3 100644
--- a/lang/php56/Makefile
+++ b/lang/php56/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= php56
-PORTVERSION= 5.6.6
+PORTVERSION= 5.6.7
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
diff --git a/lang/php56/distinfo b/lang/php56/distinfo
index dd1b5109f9f5..91870dfe2cc3 100644
--- a/lang/php56/distinfo
+++ b/lang/php56/distinfo
@@ -1,4 +1,4 @@
-SHA256 (php-5.6.6.tar.bz2) = 09625c9b65e0c8198dc76995a35f0feec0e13ea4489526e64a00954b12adbb4c
-SIZE (php-5.6.6.tar.bz2) = 13687928
+SHA256 (php-5.6.7.tar.bz2) = 02954fb74c61a7879d48ebdcd4ecb78aa0056f4215ca9b096232de28eb8f17bc
+SIZE (php-5.6.7.tar.bz2) = 13697400
SHA256 (php-5.5.x-mail-header.patch) = b0b5a7c961b2052eb14d9528e76155cbeaa881fb9b4a49f452f9dab07b6fb1c4
SIZE (php-5.5.x-mail-header.patch) = 3379