aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/thrift-c_glib/Makefile3
-rw-r--r--devel/thrift-c_glib/pkg-plist3
-rw-r--r--devel/thrift-cpp/Makefile10
-rw-r--r--devel/thrift-cpp/files/patch-lib__cpp__src__thrift__protocol__TBinaryProtocol.tcc16
-rw-r--r--devel/thrift-cpp/files/patch-lib__cpp__src__thrift__server__TNonblockingServer.h20
-rw-r--r--devel/thrift-cpp/pkg-plist12
-rw-r--r--devel/thrift/Makefile3
-rw-r--r--devel/thrift/bsd.thrift.mk2
-rw-r--r--devel/thrift/distinfo4
9 files changed, 41 insertions, 32 deletions
diff --git a/devel/thrift-c_glib/Makefile b/devel/thrift-c_glib/Makefile
index 539a5732d148..cb27c79d97cc 100644
--- a/devel/thrift-c_glib/Makefile
+++ b/devel/thrift-c_glib/Makefile
@@ -40,7 +40,8 @@ CONFIGURE_ARGS+= \
--without-php \
--without-php_extension \
--without-python \
- --without-ruby
+ --without-ruby \
+ --without-go
post-patch:
@${REINPLACE_CMD} 's,^pkgconfigdir = .*,pkgconfigdir=$${prefix}/libdata/pkgconfig,' ${WRKSRC}/lib/c_glib/Makefile.am
diff --git a/devel/thrift-c_glib/pkg-plist b/devel/thrift-c_glib/pkg-plist
index 4f6d81cdd788..93c7b48e765c 100644
--- a/devel/thrift-c_glib/pkg-plist
+++ b/devel/thrift-c_glib/pkg-plist
@@ -1,5 +1,6 @@
@comment bin/thrift
include/thrift/c_glib/config.h
+include/thrift/c_glib/processor/thrift_dispatch_processor.h
include/thrift/c_glib/processor/thrift_processor.h
include/thrift/c_glib/protocol/thrift_binary_protocol.h
include/thrift/c_glib/protocol/thrift_binary_protocol_factory.h
@@ -11,7 +12,9 @@ include/thrift/c_glib/thrift.h
include/thrift/c_glib/thrift_application_exception.h
include/thrift/c_glib/thrift_struct.h
include/thrift/c_glib/transport/thrift_buffered_transport.h
+include/thrift/c_glib/transport/thrift_buffered_transport_factory.h
include/thrift/c_glib/transport/thrift_framed_transport.h
+include/thrift/c_glib/transport/thrift_framed_transport_factory.h
include/thrift/c_glib/transport/thrift_memory_buffer.h
include/thrift/c_glib/transport/thrift_server_socket.h
include/thrift/c_glib/transport/thrift_server_transport.h
diff --git a/devel/thrift-cpp/Makefile b/devel/thrift-cpp/Makefile
index 1660b816872b..9696be4c4895 100644
--- a/devel/thrift-cpp/Makefile
+++ b/devel/thrift-cpp/Makefile
@@ -23,8 +23,6 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
PLIST_SUB= PORTVERSION="${THRIFT_PORTVERSION}"
-BUILD_WRKSRC= ${WRKSRC}/lib/cpp
-INSTALL_WRKSRC= ${WRKSRC}/lib/cpp
OPTIONS_DEFINE= QT4
QT4_CONFIGURE_WITH= qt4
@@ -43,7 +41,8 @@ CONFIGURE_ARGS+= \
--without-php \
--without-php_extension \
--without-python \
- --without-ruby
+ --without-ruby \
+ --without-go
.include <bsd.port.pre.mk>
@@ -55,12 +54,13 @@ post-patch:
@${REINPLACE_CMD} 's,^pkgconfigdir = .*,pkgconfigdir=$${prefix}/libdata/pkgconfig,' ${WRKSRC}/lib/cpp/Makefile.am
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib*.so
${LN} -sf libthrift-${PORTVERSION}.so ${STAGEDIR}${PREFIX}/lib/libthrift.so.0
${LN} -sf libthriftnb-${PORTVERSION}.so ${STAGEDIR}${PREFIX}/lib/libthriftnb.so.0
${LN} -sf libthriftz-${PORTVERSION}.so ${STAGEDIR}${PREFIX}/lib/libthriftz.so.0
-.if ${PORT_OPTIONS:MQT4}
+
+post-install-QT4-on:
${LN} -sf libthriftqt-${PORTVERSION}.so ${STAGEDIR}${PREFIX}/lib/libthriftqt.so.0
-.endif
.include "../thrift/bsd.thrift.mk"
.include <bsd.port.post.mk>
diff --git a/devel/thrift-cpp/files/patch-lib__cpp__src__thrift__protocol__TBinaryProtocol.tcc b/devel/thrift-cpp/files/patch-lib__cpp__src__thrift__protocol__TBinaryProtocol.tcc
index c7018f46a218..6a7ae619f3d4 100644
--- a/devel/thrift-cpp/files/patch-lib__cpp__src__thrift__protocol__TBinaryProtocol.tcc
+++ b/devel/thrift-cpp/files/patch-lib__cpp__src__thrift__protocol__TBinaryProtocol.tcc
@@ -1,11 +1,11 @@
---- ./lib/cpp/src/thrift/protocol/TBinaryProtocol.tcc.orig 2013-08-15 18:04:29.000000000 +0400
-+++ ./lib/cpp/src/thrift/protocol/TBinaryProtocol.tcc 2013-10-16 01:15:53.000000000 +0400
-@@ -23,7 +23,7 @@
- #include <thrift/protocol/TBinaryProtocol.h>
+--- lib/cpp/src/thrift/protocol/TBinaryProtocol.tcc.orig 2015-10-13 19:19:23 UTC
++++ lib/cpp/src/thrift/protocol/TBinaryProtocol.tcc
+@@ -24,6 +24,8 @@
#include <limits>
--
-+#include <netinet/in.h>
-
- namespace apache { namespace thrift { namespace protocol {
++#include <netinet/in.h>
++
+ namespace apache {
+ namespace thrift {
+ namespace protocol {
diff --git a/devel/thrift-cpp/files/patch-lib__cpp__src__thrift__server__TNonblockingServer.h b/devel/thrift-cpp/files/patch-lib__cpp__src__thrift__server__TNonblockingServer.h
index 3cbf789bfbed..4992ed461088 100644
--- a/devel/thrift-cpp/files/patch-lib__cpp__src__thrift__server__TNonblockingServer.h
+++ b/devel/thrift-cpp/files/patch-lib__cpp__src__thrift__server__TNonblockingServer.h
@@ -1,12 +1,12 @@
---- ./lib/cpp/src/thrift/server/TNonblockingServer.h.orig 2013-08-15 18:04:29.000000000 +0400
-+++ ./lib/cpp/src/thrift/server/TNonblockingServer.h 2013-10-16 01:15:53.000000000 +0400
-@@ -38,7 +38,8 @@
- #include <unistd.h>
- #endif
- #include <event.h>
--
+--- lib/cpp/src/thrift/server/TNonblockingServer.h.orig 2015-10-13 19:19:36 UTC
++++ lib/cpp/src/thrift/server/TNonblockingServer.h
+@@ -41,6 +41,9 @@
+ #include <event2/event_compat.h>
+ #include <event2/event_struct.h>
+
+#include <sys/types.h>
+#include <sys/socket.h>
-
-
- namespace apache { namespace thrift { namespace server {
++
+ namespace apache {
+ namespace thrift {
+ namespace server {
diff --git a/devel/thrift-cpp/pkg-plist b/devel/thrift-cpp/pkg-plist
index 75afa1711aa2..de476b13bcc8 100644
--- a/devel/thrift-cpp/pkg-plist
+++ b/devel/thrift-cpp/pkg-plist
@@ -1,14 +1,17 @@
+@comment bin/thrift
include/thrift/TApplicationException.h
include/thrift/TDispatchProcessor.h
include/thrift/TLogging.h
+include/thrift/TOutput.h
include/thrift/TProcessor.h
-include/thrift/TReflectionLocal.h
+include/thrift/TToString.h
include/thrift/Thrift.h
include/thrift/async/TAsyncBufferProcessor.h
include/thrift/async/TAsyncChannel.h
include/thrift/async/TAsyncDispatchProcessor.h
include/thrift/async/TAsyncProcessor.h
include/thrift/async/TAsyncProtocolProcessor.h
+include/thrift/async/TConcurrentClientSyncInfo.h
include/thrift/async/TEvhttpClientChannel.h
include/thrift/async/TEvhttpServer.h
include/thrift/concurrency/BoostThreadFactory.h
@@ -37,7 +40,6 @@ include/thrift/protocol/TBinaryProtocol.tcc
include/thrift/protocol/TCompactProtocol.h
include/thrift/protocol/TCompactProtocol.tcc
include/thrift/protocol/TDebugProtocol.h
-include/thrift/protocol/TDenseProtocol.h
include/thrift/protocol/TJSONProtocol.h
include/thrift/protocol/TMultiplexedProtocol.h
include/thrift/protocol/TProtocol.h
@@ -47,8 +49,10 @@ include/thrift/protocol/TProtocolTap.h
include/thrift/protocol/TVirtualProtocol.h
include/thrift/qt/TQIODeviceTransport.h
include/thrift/qt/TQTcpServer.h
+include/thrift/server/TConnectedClient.h
include/thrift/server/TNonblockingServer.h
include/thrift/server/TServer.h
+include/thrift/server/TServerFramework.h
include/thrift/server/TSimpleServer.h
include/thrift/server/TThreadPoolServer.h
include/thrift/server/TThreadedServer.h
@@ -75,7 +79,7 @@ include/thrift/transport/TTransportException.h
include/thrift/transport/TTransportUtils.h
include/thrift/transport/TVirtualTransport.h
include/thrift/transport/TZlibTransport.h
-lib/libthrift-0.9.1.so
+lib/libthrift-0.9.3.so
lib/libthrift.a
lib/libthrift.so
lib/libthrift.so.0
@@ -87,7 +91,7 @@ lib/libthriftnb.so.0
%%QT4%%lib/libthriftqt.a
%%QT4%%lib/libthriftqt.so
%%QT4%%lib/libthriftqt.so.0
-lib/libthriftz-0.9.1.so
+lib/libthriftz-0.9.3.so
lib/libthriftz.a
lib/libthriftz.so
lib/libthriftz.so.0
diff --git a/devel/thrift/Makefile b/devel/thrift/Makefile
index 4ef5a883a76f..c8d6f8e9d043 100644
--- a/devel/thrift/Makefile
+++ b/devel/thrift/Makefile
@@ -43,7 +43,8 @@ CONFIGURE_ARGS+= \
--without-php \
--without-php_extension \
--without-python \
- --without-ruby
+ --without-ruby \
+ --without-go
PLIST_FILES= bin/thrift
diff --git a/devel/thrift/bsd.thrift.mk b/devel/thrift/bsd.thrift.mk
index 50700842c885..18dc3abddcb1 100644
--- a/devel/thrift/bsd.thrift.mk
+++ b/devel/thrift/bsd.thrift.mk
@@ -5,7 +5,7 @@
# in your makefile, set:
# PORTVERSION= ${THRIFT_PORTVERSION}
# see $PORTSDIR/devel/thrift for examples
-THRIFT_PORTVERSION= 0.9.1
+THRIFT_PORTVERSION= 0.9.3
THRIFT_PORTREVISION= 1
CONFIGURE_ARGS+= \
diff --git a/devel/thrift/distinfo b/devel/thrift/distinfo
index 79547cf7b134..b585e941565a 100644
--- a/devel/thrift/distinfo
+++ b/devel/thrift/distinfo
@@ -1,2 +1,2 @@
-SHA256 (thrift-0.9.1.tar.gz) = ac175080c8cac567b0331e394f23ac306472c071628396db2850cb00c41b0017
-SIZE (thrift-0.9.1.tar.gz) = 3402353
+SHA256 (thrift-0.9.3.tar.gz) = b0740a070ac09adde04d43e852ce4c320564a292f26521c46b78e0641564969e
+SIZE (thrift-0.9.3.tar.gz) = 8897936