aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/ocaml-camomile/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/ocaml-camomile/Makefile b/devel/ocaml-camomile/Makefile
index 3ccab9713553..c953ce3fcbf3 100644
--- a/devel/ocaml-camomile/Makefile
+++ b/devel/ocaml-camomile/Makefile
@@ -25,6 +25,12 @@ USE_GMAKE= yes
PKGDEINSTALL= ${PKGINSTALL}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Coredump during build on amd64"
+.endif
+
post-install:
@${FIND} ${PREFIX}/lib/ocaml/site-lib/${PORTNAME} -type f | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
@@ -35,4 +41,4 @@ post-install:
@${FIND} ${DATADIR} -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>