aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile27
-rw-r--r--finance/p5-Business-OnlinePayment-BankOfAmerica/distinfo1
-rw-r--r--finance/p5-Business-OnlinePayment-BankOfAmerica/pkg-comment1
-rw-r--r--finance/p5-Business-OnlinePayment-BankOfAmerica/pkg-descr4
-rw-r--r--finance/p5-Business-OnlinePayment-BankOfAmerica/pkg-plist5
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Business-OnlinePayment-BankOfAmerica/Makefile27
-rw-r--r--misc/p5-Business-OnlinePayment-BankOfAmerica/distinfo1
-rw-r--r--misc/p5-Business-OnlinePayment-BankOfAmerica/pkg-comment1
-rw-r--r--misc/p5-Business-OnlinePayment-BankOfAmerica/pkg-descr4
-rw-r--r--misc/p5-Business-OnlinePayment-BankOfAmerica/pkg-plist5
11 files changed, 77 insertions, 0 deletions
diff --git a/finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile b/finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile
new file mode 100644
index 000000000000..0ef53bb255d9
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-BankOfAmerica/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Business::OnlinePayment::BankOfAmerica
+# Date created: 24 October 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-OnlinePayment-BankOfAmerica
+PORTVERSION= 1.01
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Business
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/misc/p5-Business-CreditCard \
+ ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/misc/p5-Business-OnlinePayment
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Business::OnlinePayment::BankOfAmerica.3
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Business-OnlinePayment-BankOfAmerica/distinfo b/finance/p5-Business-OnlinePayment-BankOfAmerica/distinfo
new file mode 100644
index 000000000000..c65fbd6e9d80
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-BankOfAmerica/distinfo
@@ -0,0 +1 @@
+MD5 (Business-OnlinePayment-BankOfAmerica-1.01.tar.gz) = efa9878b6a19ba9bc8288e7398d796e5
diff --git a/finance/p5-Business-OnlinePayment-BankOfAmerica/pkg-comment b/finance/p5-Business-OnlinePayment-BankOfAmerica/pkg-comment
new file mode 100644
index 000000000000..b2334629b178
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-BankOfAmerica/pkg-comment
@@ -0,0 +1 @@
+A Business::OnlinePayment backend module for Bank of America eStores
diff --git a/finance/p5-Business-OnlinePayment-BankOfAmerica/pkg-descr b/finance/p5-Business-OnlinePayment-BankOfAmerica/pkg-descr
new file mode 100644
index 000000000000..347e209c76c7
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-BankOfAmerica/pkg-descr
@@ -0,0 +1,4 @@
+This is Business::OnlinePayment::BankOfAmerica, a Business::OnlinePayment
+backend module for Bank of America eStores. It is only useful if you
+have a merchant account with Bank of America eStores:
+http://www.bofa.com/merchantservices/index.cfm?template=merch_ic_estores_ov.cfm
diff --git a/finance/p5-Business-OnlinePayment-BankOfAmerica/pkg-plist b/finance/p5-Business-OnlinePayment-BankOfAmerica/pkg-plist
new file mode 100644
index 000000000000..5cc14aff3114
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-BankOfAmerica/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Business/OnlinePayment/BankOfAmerica.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Business/OnlinePayment/BankOfAmerica/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Business/OnlinePayment/BankOfAmerica/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Business/OnlinePayment/BankOfAmerica
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Business/OnlinePayment/BankOfAmerica
diff --git a/misc/Makefile b/misc/Makefile
index 92744bb5e059..48f502d87e84 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -214,6 +214,7 @@
SUBDIR += p5-Business-OnlinePayment
SUBDIR += p5-Business-OnlinePayment-2CheckOut
SUBDIR += p5-Business-OnlinePayment-AuthorizeNet
+ SUBDIR += p5-Business-OnlinePayment-BankOfAmerica
SUBDIR += p5-Business-OnlinePayment-TCLink
SUBDIR += p5-Business-OnlinePayment-VirtualNet
SUBDIR += p5-Business-OnlinePayment-WorldPay-Junior
diff --git a/misc/p5-Business-OnlinePayment-BankOfAmerica/Makefile b/misc/p5-Business-OnlinePayment-BankOfAmerica/Makefile
new file mode 100644
index 000000000000..0ef53bb255d9
--- /dev/null
+++ b/misc/p5-Business-OnlinePayment-BankOfAmerica/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Business::OnlinePayment::BankOfAmerica
+# Date created: 24 October 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-OnlinePayment-BankOfAmerica
+PORTVERSION= 1.01
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Business
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/misc/p5-Business-CreditCard \
+ ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/misc/p5-Business-OnlinePayment
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Business::OnlinePayment::BankOfAmerica.3
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Business-OnlinePayment-BankOfAmerica/distinfo b/misc/p5-Business-OnlinePayment-BankOfAmerica/distinfo
new file mode 100644
index 000000000000..c65fbd6e9d80
--- /dev/null
+++ b/misc/p5-Business-OnlinePayment-BankOfAmerica/distinfo
@@ -0,0 +1 @@
+MD5 (Business-OnlinePayment-BankOfAmerica-1.01.tar.gz) = efa9878b6a19ba9bc8288e7398d796e5
diff --git a/misc/p5-Business-OnlinePayment-BankOfAmerica/pkg-comment b/misc/p5-Business-OnlinePayment-BankOfAmerica/pkg-comment
new file mode 100644
index 000000000000..b2334629b178
--- /dev/null
+++ b/misc/p5-Business-OnlinePayment-BankOfAmerica/pkg-comment
@@ -0,0 +1 @@
+A Business::OnlinePayment backend module for Bank of America eStores
diff --git a/misc/p5-Business-OnlinePayment-BankOfAmerica/pkg-descr b/misc/p5-Business-OnlinePayment-BankOfAmerica/pkg-descr
new file mode 100644
index 000000000000..347e209c76c7
--- /dev/null
+++ b/misc/p5-Business-OnlinePayment-BankOfAmerica/pkg-descr
@@ -0,0 +1,4 @@
+This is Business::OnlinePayment::BankOfAmerica, a Business::OnlinePayment
+backend module for Bank of America eStores. It is only useful if you
+have a merchant account with Bank of America eStores:
+http://www.bofa.com/merchantservices/index.cfm?template=merch_ic_estores_ov.cfm
diff --git a/misc/p5-Business-OnlinePayment-BankOfAmerica/pkg-plist b/misc/p5-Business-OnlinePayment-BankOfAmerica/pkg-plist
new file mode 100644
index 000000000000..5cc14aff3114
--- /dev/null
+++ b/misc/p5-Business-OnlinePayment-BankOfAmerica/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Business/OnlinePayment/BankOfAmerica.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Business/OnlinePayment/BankOfAmerica/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Business/OnlinePayment/BankOfAmerica/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Business/OnlinePayment/BankOfAmerica
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Business/OnlinePayment/BankOfAmerica
title='2004-06-01 16:48:22 +0800'>2004-06-013-4/+13 * Borrow two patches from the gnome port to make these hacks compile on -currentdougb2004-06-012-0/+26 * This patch is no longer needed for 4.16dougb2004-06-011-20/+0 * Fix fetching of Wraphelp2.gz, and use MASTER_SITE_XORG.anholt2004-06-011-3/+6 * Remove the xcursor.pc (XFree86-4-libraries) from the BUILD_DEPENDS and let themezz2004-06-011-1/+0 * Add missing dependencies.anholt2004-05-311-3/+5 * Register CONFLICTS on xorg-clients.anholt2004-05-311-0/+2 * Sigh, can I botch things a few more times today?anholt2004-05-311-6/+0 * Add port: xorg-clients, a port of the client programs and related files fromanholt2004-05-3115-0/+1136 * x11/fbsd-icons installs files with invalid uid and gidedwin2004-05-311-1/+2 * Remove these ports added into the wrong category.anholt2004-05-3131-4660/+0 * Add xorg-fonts-truetype, a port of the X.Org TrueType fonts (bitstream-veraanholt2004-05-317-0/+91 * Add xorg-fonts-miscbitmaps, a port of the X.Org "misc" bitmap fonts.anholt2004-05-316-0/+461 * Add xorg-fonts-cyrillic, a port of the X.Org Cyrillic bitmap fonts.anholt2004-05-316-0/+133 * Add xorg-fonts-75dpi, a port of the X.Org 75 dpi bitmap fonts.anholt2004-05-316-0/+1945 * Add xorg-fonts-100dpi, a port of the X.Org 100 dpi bitmap fonts.anholt2004-05-316-0/+1945 * Add xorg-fonts-encodings, a port of the X.Org font encoding files.anholt2004-05-316-0/+91 * Register CONFLICTS on new xorg ports.anholt2004-05-312-1/+3 * Remove explicit dependency on X11.6, which is already done by USE_X_PREFIX'sanholt2004-05-301-2/+0 * Add xorg-manpages, a port of X.Org release 6.7.0's manpages, modeled afteranholt2004-05-308-0/+1588 * Add xorg-libraries, a port of X.Org release 6.7.0's libraries and things,anholt2004-05-3013-0/+858 * Link programs that link against Xfont against freetype. This will be requiredanholt2004-05-302-1/+2 * Fix dependency line (xext.pc corresponds to libXext, not libX11).anholt2004-05-301-1/+1 * Remove the non-MASTER_SITE_LOCAL server addedadamw2004-05-271-1/+0 * Host the distfile on MASTER_SITE_LOCAL temporarily dueadamw2004-05-271-1/+3 * Put the conftarget hack into kdelibs as well, as it also doesn't uselofi2004-05-262-2/+6 * - Fix CATEGORIESpav2004-05-261-1/+1 * Add xfce4-trigger-launcher, a XFce4 panel plugin that provides a toggle button,pav2004-05-265-0/+47 * - Update MASTER_SITESkrion2004-05-241-2/+2 * Fix typo in pkg-plist.anholt2004-05-241-1/+1 * - Update to version 0.9.2krion2004-05-244-21/+19 * Add xtrlock, a minimal transparent X lock. Transparent means that all windowspav2004-05-236-0/+84 * Add another MASTER_SITE. We'll see how this one fares.adamw2004-05-231-1/+2 * Remove more cruft from Makefile.kdelofi2004-05-232-64/+0 * Move another helpful bit from Makefile.kde to bsd.kde.mk:lofi2004-05-222-10/+0 * - Update MASTER_SITESkrion2004-05-224-11/+13 * - Update MASTER_SITESpav2004-05-222-2/+2 * Move a CONFIGURE_ENV tweak from Makefile.kde to bsd.kde.mk so all portslofi2004-05-222-4/+0 * Add gnomesystemtools, and re-add jamboree, which now builds fine.adamw2004-05-221-3/+4 * - Fix MASTER_SITESkrion2004-05-212-5/+3 * - Update to version 0.1krion2004-05-216-12/+12 * - Update MASTER_SITESkrion2004-05-212-2/+2 * - Fix MASTER_SITESkrion2004-05-201-2/+1 * - Fix MASTER_SITESkrion2004-05-201-3/+1 * Update to 4.16. The list of new hacks, features, and bug fixes can be foundmarcus2004-05-206-19/+43 * - Update MASTER_SITESclement2004-05-191-1/+1 * Update to 2.5 and fix dependency on graphics/jpeg.nork2004-05-193-19/+6 * Bump PORTREVISION.lofi2004-05-187-0/+7 * Fix a fat fingered commit I made two weeks ago:lofi2004-05-187-7/+7 * Move editor tabstop definition up top.linimon2004-05-181-2/+1 * - Update to version 0.96krion2004-05-183-9/+6 * Drop maintainership on most of my ports. Feel free to grab 'em if youadamw2004-05-172-2/+2 * Change BROKEN to IGNORE when no X session is present. Will only affectlinimon2004-05-171-1/+1 * Change BROKEN to IGNORE when no X session is present. Will only affectlinimon2004-05-171-1/+1 * Update x11/gtstarter to 0.4.6:vs2004-05-154-8/+12 * Update to GNOME 2.6.1. All of the changes and the official announcement canmarcus2004-05-154-6/+4 * Bugfixorama: Add patches for KDE Bugs 80209, 80821, 80955 and twolofi2004-05-148-2/+166 * Update to 2.6.1.marcus2004-05-148-70/+404 * Requires libXext, which includes the rest of these dependencies.anholt2004-05-131-4/+2 * Move port to better category:vs2004-05-122-1/+2 * One of these days I'll get it right.anholt2004-05-121-1/+2 * Correct dependencies (libXext is required).anholt2004-05-111-3/+2 * Update to 2.2.2.anholt2004-05-112-4/+3 * Update to 3.5.1.anholt2004-05-113-33/+3 * Update to 1.0.2anholt2004-05-112-9/+5 * Update to 6.4.3.anholt2004-05-112-4/+3 * Update to 6.0.3anholt2004-05-112-4/+3 * Update to 6.3.3.anholt2004-05-112-4/+3 * Fix libGLU dependency.anholt2004-05-111-1/+1 * Register CONFLICTS for new xlibs ports.anholt2004-05-101-4/+6 * New port: xlibs 1.0.1: metaport of core X libraries.anholt2004-05-104-0/+62 * New port: libGL taken from X.Org release 6.7.0.anholt2004-05-108-0/+101 * New port: libXxf86 taken from X.org release 6.7.0 at freedesktop.org:anholt2004-05-109-0/+169 * Oops, remove StudlyCaps on these two new ports, matching others.anholt2004-05-102-2/+2 * New port: xf86ext taken from X.org release 6.7.0 at freedesktop.org:anholt2004-05-105-0/+54 * Correct dependencies so xextensions always comes with the package.anholt2004-05-101-5/+4 * Update to 0.1.3 release, fix dependencies.anholt2004-05-102-5/+6 * Fix libX11's dependencies, especially the missing libXdmcp dep.anholt2004-05-101-3/+3 * These headers are useless without the xproto headers as well, so add aanholt2004-05-101-1/+3 * Allow users other than root to shutdown and restart the computer from logout.marcus2004-05-104-0/+78 * Drop maintainership. Maintainer is not using FreeBSD aserwin2004-05-092-2/+2 * Use INSTALL_DATA instead of INSTALL to install the headers.anholt2004-05-091-2/+4 * Add port of libxkbfile from X.Org release 6.7.0.anholt2004-05-096-0/+87 * Turn off USE_X_PREFIX but set PREFIX to X11BASE to avoid XFree86-4-librariesanholt2004-05-091-0/+2 * Add more MASTER_SITE.ale2004-05-091-1/+4 * libICE doesn't link to libX11 directly, but one of its utility headersanholt2004-05-082-9/+2 * Add missing libXext dependencyanholt2004-05-081-1/+3 * Add missing MTREE_FILEs.anholt2004-05-082-0/+2 * Oops, fix distfile locations.anholt2004-05-082-2/+2 * Use gnomehack to replace patch.anholt2004-05-082-16/+8 * Use gnomehack to replace patch, and register xtrans as a RUN_DEPENDS as well.anholt2004-05-082-16/+8 * New port: libXp taken from X.org release 6.7.0:anholt2004-05-085-0/+43 * New port: libXinerama 1.1 freedesktop.org.anholt2004-05-085-0/+48 * New port: panoramixext 1.1 freedesktop.org:anholt2004-05-085-0/+36 * New port: printerext taken from X.org release 6.7.0 at freedesktop.org:anholt2004-05-085-0/+37 * Update to 6.6.2, which includes Xalloca.hanholt2004-05-084-156/+3 * Update to 2.6.0.2bland2004-05-073-4/+4 * Update to 1.4.2, fixing a buffer overflow in dirfile.c.anholt2004-05-076-40/+5 * Make portlint happy by replacing space to tabmaho2004-05-071-1/+1 * Chase vte shlib version.bland2004-05-064-0/+4 * Change my email to mezz@FreeBSD.org.mezz2004-05-034-4/+4 * Put the pkg-message template back into PKGDIR.lofi2004-05-0314-7/+7 * Process the pkg-message template earlier than post-install solofi2004-05-0214-21/+49 * x11-toolkits/ruby-gtkglext:mezz2004-05-021-2/+7 * Improve .orig file removal in post-patch.olgeni2004-05-021-3/+1 * - Update to 5.12pav2004-04-302-6/+4 * Update to 2.6.2.marcus2004-04-302-4/+3 * Update to 0.4.4arved2004-04-302-4/+4 * Speed up pre-configure step by caching the pkg_info output instead ofmarcus2004-04-291-1/+6 * Update to 2.6.1.marcus2004-04-293-3/+5 * Update to 2.6.1.1.marcus2004-04-293-14/+3 * Add a patch which fixes a khtml crashbuglofi2004-04-294-2/+46 * Add a fix for kdesu.lofi2004-04-214-0/+28 * Fix package build on !i386.marcus2004-04-212-4/+4 * Link against PTHREAD_LIBS so that the file selection dialog works correctlymarcus2004-04-211-2/+3 * Update to 2.6.1.marcus2004-04-214-17/+10 * Create the ${PREFIX}/etc/dm/Sessions directory.marcus2004-04-212-1/+4 * Update to 2.6.0.marcus2004-04-212-6/+6 * Update to 0.4arved2004-04-202-3/+3 * Update to KDE 3.2.2lofi2004-04-2056-305/+265 * Update to 2.6.1.marcus2004-04-204-15/+18 * Update to 2.6.1.marcus2004-04-206-6/+94 * Update to 2.6.1.marcus2004-04-206-6/+12 * Update to 2.6.1.marcus2004-04-206-6/+10 * Use the right MTREE_FILEarved2004-04-1924-0/+24 * Update to 2.6.1.marcus2004-04-196-6/+10 * update to 4.0.5oliver2004-04-195-12/+12 * Add missing directorykris2004-04-181-0/+1 * Fix some packaging permission issues on GDM internal directories.marcus2004-04-183-2/+21 * - Correct plistkrion2004-04-171-0/+1 * Update to 0.2 which shows the profile icons (if configured) instead ofmarcus2004-04-172-3/+3 * Update to 2.6.0.1.marcus2004-04-173-4/+8 * IGNORE when XFREE86_VERSION > 3, since dgs is included in XFree86kris2004-04-171-1/+7 * Install a shared version of libXau and libXRes.arved2004-04-164-2/+29 * Update from prerelease to the real releasearved2004-04-166-18/+12 * Add a missing xpm.h to the plist, and bring in some patches from Freedesktopmarcus2004-04-163-2/+32 * Add gtstarter, a port that allows one to start gnome-terminal from a listmarcus2004-04-165-0/+52 * Update to 1.02.marcus2004-04-142-3/+3 * Update to 1.01.marcus2004-04-142-3/+3 * Fix gdm themes installation. Our chown(8) doesn't likes . asbland2004-04-122-1/+12 * Fix typo.bland2004-04-121-1/+1 * BROKEN on sparc64: Does not compilekris2004-04-121-0/+4 * The new IPv6 code in GDM causes IPv4 support to be disabled. Therefore,marcus2004-04-111-1/+9 * Fix quick-lounge-applet dependency.marcus2004-04-111-1/+1 * Tidy up whitespace.trevor2004-04-115-10/+10 * Cram into 80 columns by 24 rows.trevor2004-04-111-2/+1 * Trim leading or trailing blank lines.trevor2004-04-111-1/+0 * Trim whitespace.trevor2004-04-113-3/+1 * - Update the Ruby/GNOME2 suite to 0.9.1.knu2004-04-096-26/+14 * Fix build issues with GNOME 2.6.marcus2004-04-092-5/+7 * Update to 0.05.marcus2004-04-094-30/+16 * - Update to version 0.7krion2004-04-062-4/+3 * Fix a crash with GNOME 2.6.marcus2004-04-062-3/+12 * Whoops, something got fubar'd. Put these versions back to 2.6.0.marcus2004-04-053-4/+3 * Fix some known compatibility problems with GNOME 2.6.marcus2004-04-053-4/+5 * Add libgnome-java, Java wrappers around libgnome-2.6.marcus2004-04-057-0/+113 * Remove gswitchit now that it has been integrated into gnomecontrolcenter2.marcus2004-04-057-317/+0 * Chase the glib20 update, and bump all affected ports' PORTREVISIONs.marcus2004-04-0527-25/+27 * Presenting GNOME 2.6.0. The FreeBSD GNOME Team feels this our best releasemarcus2004-04-05109-1370/+2134 * - Respect CCkrion2004-04-042-2/+3 * Fix MASTER_SITES.thierry2004-04-041-2/+2 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-022-1/+2 * SIZEify (maintainer timeout)trevor2004-03-3179-0/+90 * - Use USE_ICONV knobkrion2004-03-312-3/+3 * Repocopy x11-wm/Makefile to x11/Makefilepav2004-03-30