aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--converters/p5-Encode-Punycode/Makefile4
-rw-r--r--converters/p5-Net-IDN-Nameprep/Makefile4
-rw-r--r--converters/p5-WAP-wbxml/Makefile6
-rw-r--r--databases/p5-Relations-Query/Makefile2
-rw-r--r--devel/p5-Test-MockTime/Makefile4
-rw-r--r--textproc/p5-Net-IDN-Encode/Makefile4
6 files changed, 12 insertions, 12 deletions
diff --git a/converters/p5-Encode-Punycode/Makefile b/converters/p5-Encode-Punycode/Makefile
index b6ddfbdf4760..4f8f23b01b83 100644
--- a/converters/p5-Encode-Punycode/Makefile
+++ b/converters/p5-Encode-Punycode/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= timur@FreeBSD.org
COMMENT= Encode plugin for Punycode
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/IDN/Encode.pm:${PORTSDIR}/textproc/p5-Net-IDN-Encode
+RUN_DEPENDS= p5-Net-IDN-Encode>=0:${PORTSDIR}/textproc/p5-Net-IDN-Encode
BUILD_DEPENDS:= ${RUN_DEPENDS} \
- ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings
+ p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
PERL_MODBUILD= yes
diff --git a/converters/p5-Net-IDN-Nameprep/Makefile b/converters/p5-Net-IDN-Nameprep/Makefile
index 291b6c75bf20..51b9bf5a9a2f 100644
--- a/converters/p5-Net-IDN-Nameprep/Makefile
+++ b/converters/p5-Net-IDN-Nameprep/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= timur@FreeBSD.org
COMMENT= normalization of domain names (Nameprep, RFC 3491)
-RUN_DEPENDS= ${SITE_PERL}/Unicode/Stringprep.pm:${PORTSDIR}/converters/p5-Unicode-Stringprep
+RUN_DEPENDS= p5-Unicode-Stringprep>=0:${PORTSDIR}/converters/p5-Unicode-Stringprep
BUILD_DEPENDS:= ${RUN_DEPENDS} \
- ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings
+ p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
PERL_MODBUILD= yes
diff --git a/converters/p5-WAP-wbxml/Makefile b/converters/p5-WAP-wbxml/Makefile
index a567e0395936..10d30dfcfa1a 100644
--- a/converters/p5-WAP-wbxml/Makefile
+++ b/converters/p5-WAP-wbxml/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= timur@FreeBSD.org
COMMENT= Binarization of XML file
-BUILD_DEPENDS= ${SITE_PERL}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM \
- ${SITE_PERL}/I18N/Charset.pm:${PORTSDIR}/misc/p5-I18N-Charset \
- ${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper
+BUILD_DEPENDS= p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM \
+ p5-I18N-Charset>=0:${PORTSDIR}/misc/p5-I18N-Charset \
+ p5-Data-Dumper>=0:${PORTSDIR}/devel/p5-Data-Dumper
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_DOS2UNIX= yes
diff --git a/databases/p5-Relations-Query/Makefile b/databases/p5-Relations-Query/Makefile
index 2fd3b953bd77..5b8306c9a6c5 100644
--- a/databases/p5-Relations-Query/Makefile
+++ b/databases/p5-Relations-Query/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= timur@FreeBSD.org
COMMENT= Object for building queries with DBI/DBD::mysql
-BUILD_DEPENDS= ${SITE_PERL}/Relations.pm:${PORTSDIR}/databases/p5-Relations
+BUILD_DEPENDS= p5-Relations>=0:${PORTSDIR}/databases/p5-Relations
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Test-MockTime/Makefile b/devel/p5-Test-MockTime/Makefile
index 93775e7be715..55333064e279 100644
--- a/devel/p5-Test-MockTime/Makefile
+++ b/devel/p5-Test-MockTime/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= timur@FreeBSD.org
COMMENT= Replaces actual time with simulated time
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece
+BUILD_DEPENDS= p5-Time-Piece>=0:${PORTSDIR}/devel/p5-Time-Piece
+RUN_DEPENDS= p5-Time-Piece>=0:${PORTSDIR}/devel/p5-Time-Piece
PERL_CONFIGURE= yes
diff --git a/textproc/p5-Net-IDN-Encode/Makefile b/textproc/p5-Net-IDN-Encode/Makefile
index 4de84306d748..164ee3d55f0f 100644
--- a/textproc/p5-Net-IDN-Encode/Makefile
+++ b/textproc/p5-Net-IDN-Encode/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= timur@FreeBSD.org
COMMENT= Internationalizing Domain Names in Applications (RFC 3490)
-RUN_DEPENDS= ${SITE_PERL}/Net/IDN/Nameprep.pm:${PORTSDIR}/converters/p5-Net-IDN-Nameprep
+RUN_DEPENDS= p5-Net-IDN-Nameprep>=0:${PORTSDIR}/converters/p5-Net-IDN-Nameprep
BUILD_DEPENDS:= ${RUN_DEPENDS} \
- ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings
+ p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
PERL_MODBUILD= yes