aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/mod_perl2/Makefile14
-rw-r--r--www/mod_perl2/pkg-plist3
2 files changed, 15 insertions, 2 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index bee9c30df376..a52a3431bbc1 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_perl
PORTVERSION= 2.0.7
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= www perl5
MASTER_SITES= APACHE/perl
@@ -19,8 +20,6 @@ COMMENT= Embeds a Perl interpreter in the Apache2 server
BUILD_DEPENDS= p5-BSD-Resource>=0:${PORTSDIR}/devel/p5-BSD-Resource
RUN_DEPENDS:= ${BUILD_DEPENDS}
-CONFLICTS= p5-Apache-Reload-0.*
-
MAKE_JOBS_SAFE= yes
SUB_FILES= pkg-message
@@ -28,6 +27,7 @@ SUB_LIST= APACHEMODDIR=${APACHEMODDIR}
USE_APACHE= 20+
PERL_CONFIGURE= yes
GMAKE= yes
+USE_CSTD= gnu89
# Using apxs in this way is problematic if apache2 is installed under a
# different PREFIX than mod_perl2, because the mod_perl2 installation will
@@ -92,6 +92,14 @@ PLIST_SUB+= THREADMUTEX="@comment "
PLIST_SUB+= THREADRWLOCK="@comment "
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's/APR_INLINE//g' \
+ ${PATCH_WRKSRC}/src/modules/perl/modperl_common_util.h
+
+post-configure:
+ ${REINPLACE_CMD} -e 's/-pthread -Wl,-E//g' \
+ ${PATCH_WRKSRC}/xs/APR/APR/Makefile
+
post-install:
${MKDIR} ${PREFIX}/${APACHEINCLUDEDIR}/modules/perl
${INSTALL_DATA} ${WRKSRC}/src/modules/perl/*.h \
@@ -101,6 +109,8 @@ post-install:
${MKDIR} ${PREFIX}/${APACHEMODDIR}
${INSTALL_PROGRAM} ${WRKSRC}/src/modules/perl/mod_perl.so \
${PREFIX}/${APACHEMODDIR}/mod_perl.so
+
+ ${APXS} -e -A -n perl ${PREFIX}/${APACHEMODDIR}/mod_perl.so
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/mod_perl2/pkg-plist b/www/mod_perl2/pkg-plist
index 85c49ed67dfc..a8e31cd43ac8 100644
--- a/www/mod_perl2/pkg-plist
+++ b/www/mod_perl2/pkg-plist
@@ -283,6 +283,7 @@ bin/mp2bug
%%SITE_PERL%%/%%PERL_ARCH%%/auto/mod_perl2/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/mod_perl2.pm
%%APACHEMODDIR%%/mod_perl.so
+@exec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/mod_perl2
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/ModPerl/Util
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/ModPerl/Global
@@ -349,3 +350,5 @@ bin/mp2bug
@dirrm %%APACHEINCLUDEDIR%%/modules/perl
@dirrmtry %%APACHEINCLUDEDIR%%/modules
@dirrmtry %%APACHEINCLUDEDIR%%
+@unexec sed -i '' -E '/LoadModule[[:blank:]]+%%AP_NAME%%_module/d' %D/%%APACHEETCDIR%%/httpd.conf
+@unexec echo "Don't forget to remove all mod_perl2-related directives in your httpd.conf"