aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/lush/Makefile8
-rw-r--r--multimedia/openquicktime/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/lang/lush/Makefile b/lang/lush/Makefile
index c8357e5a052c..1a93eecc5614 100644
--- a/lang/lush/Makefile
+++ b/lang/lush/Makefile
@@ -28,6 +28,12 @@ CONFIGURE_ARGS= --without-bfd
MAN1= lush.1
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not build on sparc64"
+.endif
+
post-patch:
@${REINPLACE_CMD} -E -e \
's|opt=.+$$||; \
@@ -42,4 +48,4 @@ post-patch:
's|SDL/SDL|SDL11/SDL|; \
s|"libSDL"|\"libSDL-1.1.so.5\"|'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/openquicktime/Makefile b/multimedia/openquicktime/Makefile
index 86913cbddae7..3af92309ad46 100644
--- a/multimedia/openquicktime/Makefile
+++ b/multimedia/openquicktime/Makefile
@@ -27,6 +27,12 @@ USE_SIZE= yes
INSTALL_SHLIBS= yes
PKGDEINSTALL= ${PKGINSTALL}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not build on sparc64"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s/xCC/xc/" ${WRKSRC}/configure
@@ -34,4 +40,4 @@ post-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>