aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/flowdesigner/Makefile4
-rw-r--r--games/criticalmass/Makefile8
2 files changed, 11 insertions, 1 deletions
diff --git a/devel/flowdesigner/Makefile b/devel/flowdesigner/Makefile
index 9171284683ad..62053e0f393b 100644
--- a/devel/flowdesigner/Makefile
+++ b/devel/flowdesigner/Makefile
@@ -30,6 +30,10 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
.if ${OSVERSION} < 500035
CFLAGS+= -O0
.endif
diff --git a/games/criticalmass/Makefile b/games/criticalmass/Makefile
index fba7b56c4b11..164762994003 100644
--- a/games/criticalmass/Makefile
+++ b/games/criticalmass/Makefile
@@ -33,6 +33,12 @@ PLIST_FILES= bin/Packer \
share/Critical_Mass/resource.dat
PLIST_DIRS= share/Critical_Mass
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG:T}|g ; \
s|^CXXFLAGS|#CXXFLAGS|g ; \
@@ -40,4 +46,4 @@ post-patch:
@${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|SDL/SDL|SDL|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>