aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/easygit/Makefile31
-rw-r--r--devel/easygit/distinfo3
-rw-r--r--devel/easygit/pkg-descr4
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2f45bb9b6cd7..718c18993a0b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -285,6 +285,7 @@
SUBDIR += e00compr
SUBDIR += e4graph
SUBDIR += e_dbus
+ SUBDIR += easygit
SUBDIR += ebnf2yacc
SUBDIR += eboxy
SUBDIR += ecb
diff --git a/devel/easygit/Makefile b/devel/easygit/Makefile
new file mode 100644
index 000000000000..d657bc964e01
--- /dev/null
+++ b/devel/easygit/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/easygit
+# Date created: 11 March 2009
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= easygit
+PORTVERSION= 0.98
+CATEGORIES= devel
+MASTER_SITES= http://www.gnome.org/~newren/eg/download/${PORTVERSION}/
+DISTNAME= eg
+EXTRACT_SUFX= # none
+EXTRACT_ONLY= # none
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Easy wrapper for git
+
+RUN_DEPENDS= git:${PORTSDIR}/devel/git
+
+DIST_SUBDIR= eg/${PORTVERSION}_${PORTREVISION}
+USE_PERL5_RUN= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+PLIST_FILES= bin/eg bin/easygit
+
+do-install:
+ ${INSTALL_SCRIPT} ${_DISTDIR}/eg ${PREFIX}/bin/
+ ${LN} -s ${PREFIX}/bin/eg ${PREFIX}/bin/easygit
+
+.include <bsd.port.mk>
diff --git a/devel/easygit/distinfo b/devel/easygit/distinfo
new file mode 100644
index 000000000000..929e9fa0a6af
--- /dev/null
+++ b/devel/easygit/distinfo
@@ -0,0 +1,3 @@
+MD5 (eg/0.98_0/eg) = 8aa532804268376a74adbac0b99b115c
+SHA256 (eg/0.98_0/eg) = 18cf11c0af2fe23cebbdd2f7c93184bd33b55c668b3f009c5b6537762a7620a4
+SIZE (eg/0.98_0/eg) = 239400
diff --git a/devel/easygit/pkg-descr b/devel/easygit/pkg-descr
new file mode 100644
index 000000000000..bc96da0f9ea6
--- /dev/null
+++ b/devel/easygit/pkg-descr
@@ -0,0 +1,4 @@
+Easy GIT is a single-file wrapper script for git, designed to make
+git easy to learn and use.
+
+WWW: http://www.gnome.org/~newren/eg/