aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/postgresql73-server/Makefile4
-rw-r--r--databases/postgresql73/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/databases/postgresql73-server/Makefile b/databases/postgresql73-server/Makefile
index d0801f6586cf..733ffe973f03 100644
--- a/databases/postgresql73-server/Makefile
+++ b/databases/postgresql73-server/Makefile
@@ -42,7 +42,7 @@ CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
USE_GETOPT_LONG=yes
.endif
-.if !defined(WITHOUT_GETTEXT)
+.if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
USE_GETTEXT= yes
@@ -143,7 +143,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
- @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " WITHOUT_NLS Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
@${ECHO} " only install binaries, headers and libs"
diff --git a/databases/postgresql73/Makefile b/databases/postgresql73/Makefile
index d0801f6586cf..733ffe973f03 100644
--- a/databases/postgresql73/Makefile
+++ b/databases/postgresql73/Makefile
@@ -42,7 +42,7 @@ CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
USE_GETOPT_LONG=yes
.endif
-.if !defined(WITHOUT_GETTEXT)
+.if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
USE_GETTEXT= yes
@@ -143,7 +143,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
- @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " WITHOUT_NLS Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
@${ECHO} " only install binaries, headers and libs"