aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.autotools.mk18
-rw-r--r--databases/vsqlite/Makefile14
-rw-r--r--databases/vsqlite/pkg-plist1
3 files changed, 14 insertions, 19 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index 5fc74c7e1e0c..1c40c70f1ca6 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -308,6 +308,8 @@ LIBTOOLFILES?= aclocal.m4
LIBTOOLFILES?= ${CONFIGURE_SCRIPT}
. endif
+LIBTOOLIZE_ARGS?= -i -c -f
+
LIBTOOL_DEPENDS= libtool>=2.4:${PORTSDIR}/${LIBTOOL_PORT}
BUILD_DEPENDS+= ${LIBTOOL_DEPENDS}
.endif
@@ -329,15 +331,13 @@ ${var:tu}_ENV+= ${AUTOTOOLS_VARS}
#---------------------------------------------------------------------------
.if !target(run-autotools)
-.ORDER: run-autotools run-autotools-aclocal \
- patch-autotools-libtool run-autotools-autoheader \
- run-autotools-libtoolize run-autotools-autoconf \
- run-autotools-automake
-
-run-autotools:: run-autotools-aclocal \
- patch-autotools-libtool run-autotools-autoheader \
- run-autotools-libtoolize run-autotools-autoconf \
- run-autotools-automake
+.ORDER: run-autotools run-autotools-libtoolize run-autotools-aclocal \
+ patch-autotools-libtool run-autotools-autoconf \
+ run-autotools-autoheader run-autotools-automake
+
+run-autotools:: run-autotools-libtoolize run-autotools-aclocal \
+ patch-autotools-libtool run-autotools-autoconf \
+ run-autotools-autoheader run-autotools-automake
.endif
.if !target(run-autotools-aclocal)
diff --git a/databases/vsqlite/Makefile b/databases/vsqlite/Makefile
index cfcce6078b89..0a8379f8ab94 100644
--- a/databases/vsqlite/Makefile
+++ b/databases/vsqlite/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vsqlite
PORTVERSION= 0.3.12
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases
MAINTAINER= kwm@FreeBSD.org
@@ -19,17 +19,13 @@ GH_PROJECT= vsqlite--
GH_TAGNAME= 3fa8d32
GH_COMMIT= 3fa8d32
-USE_AUTOTOOLS= libtoolize autoconf automake
-USES= compiler:c++0x libtool:keepla
+USES= compiler:c++0x libtool
+USE_AUTOTOOLS= libtoolize aclocal autoconf automake
+AUTOMAKE_ARGS= -a -c -f
USE_SQLITE= 3
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-pre-configure:
- @cd ${WRKSRC} && ${SH} autogen.sh
-
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libvsqlitepp.so.3
-
.include <bsd.port.mk>
diff --git a/databases/vsqlite/pkg-plist b/databases/vsqlite/pkg-plist
index 30577b1d65ca..6a1b74705d40 100644
--- a/databases/vsqlite/pkg-plist
+++ b/databases/vsqlite/pkg-plist
@@ -8,7 +8,6 @@ include/sqlite/result.hpp
include/sqlite/transaction.hpp
include/sqlite/view.hpp
lib/libvsqlitepp.a
-lib/libvsqlitepp.la
lib/libvsqlitepp.so
lib/libvsqlitepp.so.3
lib/libvsqlitepp.so.3.0.0