aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--Mk/bsd.gstreamer.mk14
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gstreamer-plugins-faac/Makefile2
-rw-r--r--audio/gstreamer-plugins-flite/Makefile17
-rw-r--r--audio/gstreamer-plugins-musepack/Makefile2
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gstreamer-plugins-opencv/Makefile17
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/gstreamer-plugins-bad/files/patch-sys_dvb_gstdvbsrc.c10
-rw-r--r--multimedia/gstreamer-plugins-bad/pkg-plist14
-rw-r--r--multimedia/gstreamer-plugins-good/files/patch-configure9
-rw-r--r--multimedia/gstreamer-plugins-vdpau/Makefile (renamed from x11/gstreamer-plugins-vdpau/Makefile)2
-rw-r--r--multimedia/gstreamer-plugins-x264/Makefile2
-rw-r--r--multimedia/gstreamer-plugins/Makefile18
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common11
-rw-r--r--multimedia/gstreamer-plugins/distinfo18
-rw-r--r--multimedia/gstreamer-plugins/files/patch-configure11
-rw-r--r--multimedia/gstreamer-plugins/pkg-plist4
-rw-r--r--www/gstreamer-plugins-neon/Makefile2
-rw-r--r--x11/Makefile1
21 files changed, 89 insertions, 69 deletions
diff --git a/MOVED b/MOVED
index 89772dda7d88..c61cc042c91b 100644
--- a/MOVED
+++ b/MOVED
@@ -1550,3 +1550,4 @@ textproc/py-expat||2011-02-25|Removed, part of python since python25
devel/py-ctypes||2011-02-25|Removed, part of python since python25
security/py-hashlib||2011-02-25|Removed, part of python since python25
www/py-hashlib||2011-02-25|Removed, part of python since python25
+x11/gstreamer-plugins-vdpau|multimedia/gstreamer-plugins-vdpau|2011-02-25|Move to the multimedia category
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index 01476937f19f..6df3f9a25b84 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -55,10 +55,10 @@ GST_SHLIB_VERSION= 1
#
_USE_GSTREAMER10_ALL= a52dec aalib amrnb amrwbdec annodex bz2 cairo \
cdaudio cdparanoia dts dv dvd esound faac faad \
- ffmpeg flac gconf gio gl gme gnomevfs gnonlin \
+ ffmpeg flac flite gconf gio gl gme gnomevfs gnonlin \
gsm hal jack jpeg ladspa lame libcaca libmms \
libpng libvisual mm mp3 mpeg2enc mpeg2dec musepack \
- nas neon ogg pango pulse python resindvd schroedinger \
+ nas neon ogg opencv pango pulse python resindvd schroedinger \
sdl shout2 sidplay sndfile spc soundtouch soup \
speex taglib theora twolame v4l2 vorbis vdpau \
vp8 wavpack x264 xvid
@@ -101,6 +101,8 @@ faad_DEPENDS= audio/gstreamer-plugins-faad
flac_DEPENDS= audio/gstreamer-plugins-flac
+flite_DEPENDS= audio/gstreamer-plugins-flite
+
fluendo-mp3_DEPENDS= audio/gstreamer-plugins-fluendo-mp3
gme_DEPENDS= audio/gstreamer-plugins-gme
@@ -196,6 +198,8 @@ libpng_DEPENDS= graphics/gstreamer-plugins-libpng
libvisual_DEPENDS= graphics/gstreamer-plugins-libvisual
+opencv_DEPENDS= graphics/gstreamer-plugins-opencv
+
# Multimedia Plugins Section
bad_DEPENDS= multimedia/gstreamer-plugins-bad
@@ -249,6 +253,8 @@ theora_DEPENDS= multimedia/gstreamer-plugins-theora
ugly_DEPENDS= multimedia/gstreamer-plugins-ugly
+vdpau_DEPENDS= multimedia/gstreamer-plugins-vdpau
+
x264_DEPENDS= multimedia/gstreamer-plugins-x264
xvid_DEPENDS= multimedia/gstreamer-plugins-xvid
@@ -257,10 +263,6 @@ xvid_DEPENDS= multimedia/gstreamer-plugins-xvid
libmms_DEPENDS= net/gstreamer-plugins-libmms
-# X11 Plugin Section
-
-vdpau_DEPENDS= x11/gstreamer-plugins-vdpau
-
# X11-Toolkits Plugins Section
pango_DEPENDS= x11-toolkits/gstreamer-plugins-pango
diff --git a/audio/Makefile b/audio/Makefile
index 81d19d3cf2bb..ef7ea25dd00d 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -270,6 +270,7 @@
SUBDIR += gstreamer-plugins-faac
SUBDIR += gstreamer-plugins-faad
SUBDIR += gstreamer-plugins-flac
+ SUBDIR += gstreamer-plugins-flite
SUBDIR += gstreamer-plugins-fluendo-mp3
SUBDIR += gstreamer-plugins-gme
SUBDIR += gstreamer-plugins-gsm
diff --git a/audio/gstreamer-plugins-faac/Makefile b/audio/gstreamer-plugins-faac/Makefile
index a88297937d72..d6fadeb58f31 100644
--- a/audio/gstreamer-plugins-faac/Makefile
+++ b/audio/gstreamer-plugins-faac/Makefile
@@ -6,7 +6,7 @@
# $MCom: ports/audio/gstreamer-plugins-faac/Makefile,v 1.5 2008/03/19 14:05:28 ahze Exp $
#
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= audio
COMMENT= Gstreamer MPEG-2 and MPEG-4 AAC encoder plugin
diff --git a/audio/gstreamer-plugins-flite/Makefile b/audio/gstreamer-plugins-flite/Makefile
new file mode 100644
index 000000000000..913dafb5c07b
--- /dev/null
+++ b/audio/gstreamer-plugins-flite/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: gstreamer-plugins-flite
+# Date created: 27 Jan 2011
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= audio
+
+COMMENT= Gstreamer flite run-time speech synthesis engine plugin
+
+GST_PLUGIN= flite
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/audio/gstreamer-plugins-musepack/Makefile b/audio/gstreamer-plugins-musepack/Makefile
index cb351b710a80..a031d81f76c7 100644
--- a/audio/gstreamer-plugins-musepack/Makefile
+++ b/audio/gstreamer-plugins-musepack/Makefile
@@ -6,7 +6,7 @@
# $MCom: ports/audio/gstreamer-plugins-musepack/Makefile,v 1.5 2008/03/19 14:05:30 ahze Exp $
#
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= audio
COMMENT= Gstreamer musepack mpc encoder/decoder plugin
diff --git a/graphics/Makefile b/graphics/Makefile
index 4c99cd7d2362..d31a3b91b4b5 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -319,6 +319,7 @@
SUBDIR += gstreamer-plugins-libcaca
SUBDIR += gstreamer-plugins-libpng
SUBDIR += gstreamer-plugins-libvisual
+ SUBDIR += gstreamer-plugins-opencv
SUBDIR += gthumb
SUBDIR += gtkam
SUBDIR += gtkdps
diff --git a/graphics/gstreamer-plugins-opencv/Makefile b/graphics/gstreamer-plugins-opencv/Makefile
new file mode 100644
index 000000000000..89d31d466806
--- /dev/null
+++ b/graphics/gstreamer-plugins-opencv/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: gstreamer-plugins-opencv
+# Date created: 27 Jan 2011
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= graphics
+
+COMMENT= Gstreamer opencv real time computer vision plugin
+
+GST_PLUGIN= opencv
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 1a0e69ba12e2..01b609f2da3f 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -109,6 +109,7 @@
SUBDIR += gstreamer-plugins-theora
SUBDIR += gstreamer-plugins-ugly
SUBDIR += gstreamer-plugins-v4l2
+ SUBDIR += gstreamer-plugins-vdpau
SUBDIR += gstreamer-plugins-vp8
SUBDIR += gstreamer-plugins-x264
SUBDIR += gstreamer-plugins-xvid
diff --git a/multimedia/gstreamer-plugins-bad/files/patch-sys_dvb_gstdvbsrc.c b/multimedia/gstreamer-plugins-bad/files/patch-sys_dvb_gstdvbsrc.c
index a6352fff5a0f..e69de29bb2d1 100644
--- a/multimedia/gstreamer-plugins-bad/files/patch-sys_dvb_gstdvbsrc.c
+++ b/multimedia/gstreamer-plugins-bad/files/patch-sys_dvb_gstdvbsrc.c
@@ -1,10 +0,0 @@
---- ./sys/dvb/gstdvbsrc.c.orig 2010-09-07 18:04:03.000000000 +0200
-+++ ./sys/dvb/gstdvbsrc.c 2010-09-07 18:04:12.000000000 +0200
-@@ -45,7 +45,6 @@
- #include <sys/ioctl.h>
- #include <sys/poll.h>
- #include <fcntl.h>
--#include <error.h>
- #include <errno.h>
- #include <stdio.h>
- #include <stdlib.h>
diff --git a/multimedia/gstreamer-plugins-bad/pkg-plist b/multimedia/gstreamer-plugins-bad/pkg-plist
index c24c5e5d77de..171177d5a7ef 100644
--- a/multimedia/gstreamer-plugins-bad/pkg-plist
+++ b/multimedia/gstreamer-plugins-bad/pkg-plist
@@ -26,6 +26,8 @@ lib/gstreamer-%%VERSION%%/libgstcdxaparse.la
lib/gstreamer-%%VERSION%%/libgstcdxaparse.so
lib/gstreamer-%%VERSION%%/libgstcoloreffects.la
lib/gstreamer-%%VERSION%%/libgstcoloreffects.so
+lib/gstreamer-%%VERSION%%/libgstcolorspace.la
+lib/gstreamer-%%VERSION%%/libgstcolorspace.so
lib/gstreamer-%%VERSION%%/libgstdataurisrc.la
lib/gstreamer-%%VERSION%%/libgstdataurisrc.so
lib/gstreamer-%%VERSION%%/libgstdccp.la
@@ -38,6 +40,8 @@ lib/gstreamer-%%VERSION%%/libgstdvb.la
lib/gstreamer-%%VERSION%%/libgstdvb.so
lib/gstreamer-%%VERSION%%/libgstdvdspu.la
lib/gstreamer-%%VERSION%%/libgstdvdspu.so
+lib/gstreamer-%%VERSION%%/libgstdvbsuboverlay.la
+lib/gstreamer-%%VERSION%%/libgstdvbsuboverlay.so
lib/gstreamer-%%VERSION%%/libgstfestival.la
lib/gstreamer-%%VERSION%%/libgstfestival.so
lib/gstreamer-%%VERSION%%/libgstfreeze.la
@@ -56,8 +60,12 @@ lib/gstreamer-%%VERSION%%/libgstid3tag.la
lib/gstreamer-%%VERSION%%/libgstid3tag.so
lib/gstreamer-%%VERSION%%/libgstinvtelecine.la
lib/gstreamer-%%VERSION%%/libgstinvtelecine.so
+lib/gstreamer-%%VERSION%%/libgstinterlace.la
+lib/gstreamer-%%VERSION%%/libgstinterlace.so
lib/gstreamer-%%VERSION%%/libgstivfparse.la
lib/gstreamer-%%VERSION%%/libgstivfparse.so
+lib/gstreamer-%%VERSION%%/libgstjp2kdecimator.la
+lib/gstreamer-%%VERSION%%/libgstjp2kdecimator.so
lib/gstreamer-%%VERSION%%/libgstjpegformat.la
lib/gstreamer-%%VERSION%%/libgstjpegformat.so
lib/gstreamer-%%VERSION%%/libgstlegacyresample.la
@@ -103,8 +111,6 @@ lib/gstreamer-%%VERSION%%/libgstsdpelem.la
lib/gstreamer-%%VERSION%%/libgstsdpelem.so
lib/gstreamer-%%VERSION%%/libgstsegmentclip.la
lib/gstreamer-%%VERSION%%/libgstsegmentclip.so
-lib/gstreamer-%%VERSION%%/libgstselector.la
-lib/gstreamer-%%VERSION%%/libgstselector.so
lib/gstreamer-%%VERSION%%/libgstshm.la
lib/gstreamer-%%VERSION%%/libgstshm.so
lib/gstreamer-%%VERSION%%/libgstsiren.la
@@ -117,8 +123,6 @@ lib/gstreamer-%%VERSION%%/libgstsubenc.la
lib/gstreamer-%%VERSION%%/libgstsubenc.so
lib/gstreamer-%%VERSION%%/libgsttta.la
lib/gstreamer-%%VERSION%%/libgsttta.so
-lib/gstreamer-%%VERSION%%/libgstvalve.la
-lib/gstreamer-%%VERSION%%/libgstvalve.so
lib/gstreamer-%%VERSION%%/libgstvideomaxrate.la
lib/gstreamer-%%VERSION%%/libgstvideomaxrate.so
lib/gstreamer-%%VERSION%%/libgstvideomeasure.la
@@ -127,6 +131,8 @@ lib/gstreamer-%%VERSION%%/libgstvideosignal.la
lib/gstreamer-%%VERSION%%/libgstvideosignal.so
lib/gstreamer-%%VERSION%%/libgstvmnc.la
lib/gstreamer-%%VERSION%%/libgstvmnc.so
+lib/gstreamer-%%VERSION%%/libgsty4mdec.la
+lib/gstreamer-%%VERSION%%/libgsty4mdec.so
lib/libgstbasevideo-%%VERSION%%.a
lib/libgstbasevideo-%%VERSION%%.la
lib/libgstbasevideo-%%VERSION%%.so
diff --git a/multimedia/gstreamer-plugins-good/files/patch-configure b/multimedia/gstreamer-plugins-good/files/patch-configure
index df21950fb4a3..d893a20c2a56 100644
--- a/multimedia/gstreamer-plugins-good/files/patch-configure
+++ b/multimedia/gstreamer-plugins-good/files/patch-configure
@@ -1,14 +1,5 @@
--- configure.orig 2010-12-01 19:16:00.000000000 +0100
+++ configure 2010-12-02 15:39:17.000000000 +0100
-@@ -23961,7 +23961,7 @@ $as_echo "$as_me: Using $PLUGINDIR as th
- if ( echo yes | grep -e '^201-90-9-0-10-9-0-30-9' >/dev/null ) ; then
- GST_PACKAGE_RELEASE_DATETIME=yes
- else
-- YYYY_MM_DD=`. "${srcdir}/common/extract-release-date-from-doap-file" $PACKAGE_VERSION_MAJOR.$PACKAGE_VERSION_MINOR.$PACKAGE_VERSION_MICRO "${srcdir}/gst-plugins-good.doap" `;
-+ YYYY_MM_DD=`./"${srcdir}/common/extract-release-date-from-doap-file" $PACKAGE_VERSION_MAJOR.$PACKAGE_VERSION_MINOR.$PACKAGE_VERSION_MICRO "${srcdir}/gst-plugins-good.doap" `;
- if test "x$YYYY_MM_DD" != "x"; then
- GST_PACKAGE_RELEASE_DATETIME=$YYYY_MM_DD
- else
@@ -24955,7 +24955,7 @@ if test "${with_default_audiosink+set}"
else
diff --git a/x11/gstreamer-plugins-vdpau/Makefile b/multimedia/gstreamer-plugins-vdpau/Makefile
index 70ebcbd128e6..8454806312a3 100644
--- a/x11/gstreamer-plugins-vdpau/Makefile
+++ b/multimedia/gstreamer-plugins-vdpau/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= x11
COMMENT= Gstreamer nvidia vdpau plugin
diff --git a/multimedia/gstreamer-plugins-x264/Makefile b/multimedia/gstreamer-plugins-x264/Makefile
index 9ff5576ca6e0..9c355de0326d 100644
--- a/multimedia/gstreamer-plugins-x264/Makefile
+++ b/multimedia/gstreamer-plugins-x264/Makefile
@@ -6,7 +6,7 @@
# $MCom: ports/multimedia/gstreamer-plugins-x264/Makefile,v 1.3 2008/03/19 14:05:37 ahze Exp $
#
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= multimedia
COMMENT= Gstreamer x264 plugin
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 98422797e6af..2c8e03bf0ac1 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -14,33 +14,30 @@ CATEGORIES?= multimedia audio
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-plugins-base/:base \
http://gstreamer.freedesktop.org/src/gst-plugins-bad/:bad \
http://gstreamer.freedesktop.org/src/gst-plugins-good/:good \
- http://gstreamer.freedesktop.org/src/gst-plugins-ugly/:ugly \
- ${MASTER_SITE_LOCAL:S|$|ahze/:base|} \
- ${MASTER_SITE_LOCAL:S|$|ahze/:good|} \
- ${MASTER_SITE_LOCAL:S|$|ahze/:bad|} \
- ${MASTER_SITE_LOCAL:S|$|ahze/:ugly|}
+ http://gstreamer.freedesktop.org/src/gst-plugins-ugly/:ugly
PKGNAMESUFFIX?= -plugins${GST_PLUGIN_SUFFIX}
MAINTAINER= multimedia@FreeBSD.org
COMMENT?= GStreamer written collection of plugins handling several media types
BUILD_DEPENDS+= v4l_compat>=1.0.20100321:${PORTSDIR}/multimedia/v4l_compat \
+ gstreamer>=0.10.32:${PORTSDIR}/multimedia/gstreamer \
orc>=0.4.11:${PORTSDIR}/devel/orc
LIB_DEPENDS+= gstreamer-0.10.0:${PORTSDIR}/multimedia/gstreamer \
orc-0.4.0:${PORTSDIR}/devel/orc
CFLAGS:= ${CFLAGS} -O2 -Wno-format
-BASE_PORTVERSION= 0.10.31
+BASE_PORTVERSION= 0.10.32
BASE_DISTNAME= gst-plugins-base-${BASE_PORTVERSION}
BASE_DISTFILE= ${BASE_DISTNAME}${EXTRACT_SUFX}
-BAD_PORTVERSION= 0.10.20
+BAD_PORTVERSION= 0.10.21
BAD_DISTNAME= gst-plugins-bad-${BAD_PORTVERSION}
BAD_DISTFILE= ${BAD_DISTNAME}${EXTRACT_SUFX}
-GOOD_PORTVERSION= 0.10.26
+GOOD_PORTVERSION= 0.10.27
GOOD_DISTNAME= gst-plugins-good-${GOOD_PORTVERSION}
GOOD_DISTFILE= ${GOOD_DISTNAME}${EXTRACT_SUFX}
-UGLY_PORTVERSION= 0.10.16
+UGLY_PORTVERSION= 0.10.17
UGLY_DISTNAME= gst-plugins-ugly-${UGLY_PORTVERSION}
UGLY_DISTFILE= ${UGLY_DISTNAME}${EXTRACT_SUFX}
DIST?= good
@@ -96,9 +93,6 @@ WRKSRC=${WRKDIR}/${BAD_DISTNAME}
PORTVERSION= ${BAD_PORTVERSION}
DISTFILES+= ${BAD_DISTFILE}:bad
PATCHDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins-bad/files
-.if ${OSVERSION} < 700000
-BROKEN= does not configure properly on 6.X (shm plugin)
-.endif
.elif ${DIST}=="ugly"
EXTRACT_ONLY=${UGLY_DISTFILE}
WRKSRC=${WRKDIR}/${UGLY_DISTNAME}
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 8f2a038a2fdc..f9bc7528fd02 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -49,6 +49,7 @@ BAD_GST_ALL_PLUGINS+= \
nas \
neon \
ofa \
+ opencv \
resindvd \
rsvg \
schro \
@@ -336,7 +337,7 @@ gst_hal_PLIST_FILES= ${GST_LIB_DIR}/libgsthalelements.la \
gst_jack_LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
gst_jack_PLIST_FILES= ${GST_LIB_DIR}/libgstjack.la \
${GST_LIB_DIR}/libgstjack.so
-gst_jack_DIST= bad
+gst_jack_DIST= good
# jpeg
gst_jpeg_LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
@@ -429,6 +430,14 @@ gst_ogg_PLIST_FILES= ${GST_LIB_DIR}/libgstogg.la \
${GST_LIB_DIR}/libgstogg.so
gst_ogg_DIST= base
+# opencv
+gst_opencv_BUILD_DEPENDS+=opencv<=2.1:${PORTSDIR}/graphics/opencv
+gst_opencv_RUN_DEPENDS+=opencv<=2.1:${PORTSDIR}/graphics/opencv
+gst_opencv_PLIST_FILES= ${GST_LIB_DIR}/libgstopencv.la \
+ ${GST_LIB_DIR}/libgstopencv.a \
+ ${GST_LIB_DIR}/libgstopencv.so
+gst_opencv_DIST= bad
+
# pango
gst_pango_USE_GNOME+= pango
gst_pango_PLIST_FILES= ${GST_LIB_DIR}/libgstpango.la \
diff --git a/multimedia/gstreamer-plugins/distinfo b/multimedia/gstreamer-plugins/distinfo
index fb6ead000936..6dd702478bd3 100644
--- a/multimedia/gstreamer-plugins/distinfo
+++ b/multimedia/gstreamer-plugins/distinfo
@@ -1,10 +1,8 @@
-SHA256 (gst-plugins-base-0.10.31.tar.bz2) = abb006c78222cfb69d31e983268d1d5219e9d4e0da24c6c4cd687968af7a33bd
-SIZE (gst-plugins-base-0.10.31.tar.bz2) = 2644897
-SHA256 (gst-plugins-base-0.10.30.tar.bz2) = 63938641380be9935c804ae8d55acdcfd93920ed2deb72dcf70f027a78b085d7
-SIZE (gst-plugins-base-0.10.30.tar.bz2) = 2455042
-SHA256 (gst-plugins-bad-0.10.20.tar.bz2) = 1031dff866df976a957f34039addbab4c0753406299a275f4cf1780e1dbe2a90
-SIZE (gst-plugins-bad-0.10.20.tar.bz2) = 3209622
-SHA256 (gst-plugins-ugly-0.10.16.tar.bz2) = d7fc7636001e78736540c628ad889888cb85ea722f08d1c6813b16682dd9c09c
-SIZE (gst-plugins-ugly-0.10.16.tar.bz2) = 1041297
-SHA256 (gst-plugins-good-0.10.26.tar.bz2) = ceb3bbea5ce18463b8fe470d34786bc846469e800305c436d799af9fe22bdcc4
-SIZE (gst-plugins-good-0.10.26.tar.bz2) = 3011746
+SHA256 (gst-plugins-base-0.10.32.tar.bz2) = e9aabfac83f6480896da0686e9c911989f896fbad634821b7771ed84a446172b
+SIZE (gst-plugins-base-0.10.32.tar.bz2) = 2720103
+SHA256 (gst-plugins-bad-0.10.21.tar.bz2) = 422badacbda37ac33cb446c6751dabcd0b223c308dbb01024a34ded682fa47e3
+SIZE (gst-plugins-bad-0.10.21.tar.bz2) = 3429224
+SHA256 (gst-plugins-ugly-0.10.17.tar.bz2) = 0cbd4aa8dceafea21ddd547dfde686a8836f68ba547afa5575a52b64cfa0b369
+SIZE (gst-plugins-ugly-0.10.17.tar.bz2) = 1050400
+SHA256 (gst-plugins-good-0.10.27.tar.bz2) = a9d801c3d42b456a6ebc0b95f68c44f153f756ec0fbd4877197c469cc67771fa
+SIZE (gst-plugins-good-0.10.27.tar.bz2) = 3096221
diff --git a/multimedia/gstreamer-plugins/files/patch-configure b/multimedia/gstreamer-plugins/files/patch-configure
index b5956d04069a..e69de29bb2d1 100644
--- a/multimedia/gstreamer-plugins/files/patch-configure
+++ b/multimedia/gstreamer-plugins/files/patch-configure
@@ -1,11 +0,0 @@
---- configure.orig 2010-12-02 10:39:38.000000000 +0100
-+++ configure 2010-12-02 10:40:28.000000000 +0100
-@@ -23508,7 +23508,7 @@
- if ( echo yes | grep -e '^201-90-9-0-10-9-0-30-9' >/dev/null ) ; then
- GST_PACKAGE_RELEASE_DATETIME=yes
- else
-- YYYY_MM_DD=`. "${srcdir}/common/extract-release-date-from-doap-file" $PACKAGE_VERSION_MAJOR.$PACKAGE_VERSION_MINOR.$PACKAGE_VERSION_MICRO "${srcdir}/gst-plugins-base.doap" `;
-+ YYYY_MM_DD=`./"${srcdir}/common/extract-release-date-from-doap-file" $PACKAGE_VERSION_MAJOR.$PACKAGE_VERSION_MINOR.$PACKAGE_VERSION_MICRO "${srcdir}/gst-plugins-base.doap" `;
- if test "x$YYYY_MM_DD" != "x"; then
- GST_PACKAGE_RELEASE_DATETIME=$YYYY_MM_DD
- else
diff --git a/multimedia/gstreamer-plugins/pkg-plist b/multimedia/gstreamer-plugins/pkg-plist
index d1cfc9c1f3af..444dc999c3ba 100644
--- a/multimedia/gstreamer-plugins/pkg-plist
+++ b/multimedia/gstreamer-plugins/pkg-plist
@@ -38,6 +38,8 @@ include/gstreamer-%%VERSION%%/gst/interfaces/xoverlay.h
include/gstreamer-%%VERSION%%/gst/netbuffer/gstnetbuffer.h
include/gstreamer-%%VERSION%%/gst/pbutils/codec-utils.h
include/gstreamer-%%VERSION%%/gst/pbutils/descriptions.h
+include/gstreamer-%%VERSION%%/gst/pbutils/encoding-profile.h
+include/gstreamer-%%VERSION%%/gst/pbutils/encoding-target.h
include/gstreamer-%%VERSION%%/gst/pbutils/gstdiscoverer.h
include/gstreamer-%%VERSION%%/gst/pbutils/gstpluginsbaseversion.h
include/gstreamer-%%VERSION%%/gst/pbutils/install-plugins.h
@@ -98,6 +100,8 @@ lib/gstreamer-%%VERSION%%/libgstdecodebin.la
lib/gstreamer-%%VERSION%%/libgstdecodebin.so
lib/gstreamer-%%VERSION%%/libgstdecodebin2.la
lib/gstreamer-%%VERSION%%/libgstdecodebin2.so
+lib/gstreamer-%%VERSION%%/libgstencodebin.la
+lib/gstreamer-%%VERSION%%/libgstencodebin.so
lib/gstreamer-%%VERSION%%/libgstffmpegcolorspace.la
lib/gstreamer-%%VERSION%%/libgstffmpegcolorspace.so
lib/gstreamer-%%VERSION%%/libgstgdp.la
diff --git a/www/gstreamer-plugins-neon/Makefile b/www/gstreamer-plugins-neon/Makefile
index c9231a032ae4..d8345817b277 100644
--- a/www/gstreamer-plugins-neon/Makefile
+++ b/www/gstreamer-plugins-neon/Makefile
@@ -6,7 +6,7 @@
# $MCom: ports/www/gstreamer-plugins-neon/Makefile,v 1.5 2008/03/19 14:05:38 ahze Exp $
#
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= www
COMMENT= Gstreamer neon plugin
diff --git a/x11/Makefile b/x11/Makefile
index 897bcc6b4ea8..4525a4d9f57d 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -105,7 +105,6 @@
SUBDIR += grabc
SUBDIR += gromit
SUBDIR += gskrab
- SUBDIR += gstreamer-plugins-vdpau
SUBDIR += gsynaptics
SUBDIR += gtk-launch
SUBDIR += gtk-theme-switch