aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.gcc.mk9
-rw-r--r--Mk/bsd.options.desc.mk1
-rw-r--r--Mk/bsd.port.mk59
-rw-r--r--Mk/bsd.python.mk4
4 files changed, 72 insertions, 1 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 9cb9bec5441c..9338b0af975d 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -16,6 +16,8 @@
# USE_GCC= 4.2+ # port requires GCC 4.2 or later.
# USE_GCC= 4.7 # port requires GCC 4.7.
#
+# USE_GCC_RELEASE=yes # use lang/gcc if its version satisfies USE_GCC
+#
# If your port needs a Fortran compiler, please specify that with the
# USE_FORTRAN= knob. Here is the list of options for that knob:
#
@@ -36,7 +38,7 @@ GCC_Include_MAINTAINER= gerald@FreeBSD.org
# All GCC versions supported by the ports framework. Keep them in
# ascending order and in sync with the table below.
-GCCVERSIONS= 030402 040200 040400 040600 040700
+GCCVERSIONS= 030402 040200 040400 040600 040700 RELEASE
# The first field if the OSVERSION in which it appeared in the base.
# The second field is the OSVERSION in which it disappeared from the base.
@@ -46,6 +48,7 @@ GCCVERSION_040200= 700042 9999999 4.2
GCCVERSION_040400= 0 0 4.4
GCCVERSION_040600= 0 0 4.6
GCCVERSION_040700= 0 0 4.7
+GCCVERSION_RELEASE= 0 0 ${GCC_DEFAULT_VERSION}
GCC_DEFAULT_VERSION= 4.6
GCC_DEFAULT_V= ${GCC_DEFAULT_VERSION:S/.//}
@@ -177,7 +180,11 @@ _USE_GCC:= ${GCC_DEFAULT_VERSION}
.for v in ${GCCVERSIONS}
. if ${_USE_GCC} == ${_GCCVERSION_${v}_V}
. if ${OSVERSION} < ${_GCCVERSION_${v}_L} || ${OSVERSION} > ${_GCCVERSION_${v}_R}
+.if defined(USE_GCC_RELEASE) && ${_USE_GCC:S/.//} <= ${_GCCVERSION_${v}_V:S/.//}
+V:= # empty
+.else
V:= ${_GCCVERSION_${v}_V:S/.//}
+.endif
_GCC_BUILD_DEPENDS:= gcc${V}
_GCC_PORT_DEPENDS:= gcc${V}
CC:= gcc${V}
diff --git a/Mk/bsd.options.desc.mk b/Mk/bsd.options.desc.mk
index daef231d65fa..d1527fd1f261 100644
--- a/Mk/bsd.options.desc.mk
+++ b/Mk/bsd.options.desc.mk
@@ -212,6 +212,7 @@ TIDY_DESC?= tidy html cleaner support
TIFF_DESC?= TIFF support
TINYXML_DESC?= XML Parser support via TinyXML
TK_DESC?= TK toolkit support
+TLS_DESC?= TLS support
TOMCAT5_DESC?= Tomcat 5.x support
TOMCAT6_DESC?= Tomcat 6.x support
TOMCAT7_DESC?= Tomcat 7.x support
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a974d9999074..f660fc2d7bc5 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6249,6 +6249,42 @@ pretty-print-config:
@${ECHO_MSG} ""
.endif # pretty-print-config
+#.if !target(collect-ports-conf)
+#collect-ports-conf:
+#.for opt in ${ALL_OPTIONS}
+#. if ${PORT_OPTIONS:M${opt}}
+#opts_set+= ${opt}
+#. else
+#opts_unset+=${opt}
+#. endif
+#.endfor
+#.for opts in ${OPTIONS_MULTI}
+#. for opt in ${OPTIONS_MULTI_${opts}}
+#. if ${PORT_OPTIONS:M${opt}}
+#opts_set+= ${opt}
+#. else
+#opts_unset+=${opt}
+#. endif
+#. endfor
+#.endfor
+#.for opts in ${OPTIONS_SINGLE}
+#. for opt in ${OPTIONS_SINGLE_${opts}}
+#. if ${PORT_OPTIONS:M${opt}}
+#opts_set+= ${opt}
+#. else
+#opts_unset+=${opt}
+#. endif
+#. endfor
+#.endfor
+#.undef opt
+#.undef opts
+#.endif # collect-ports-conf
+#
+#.if !target(pretty-print-ports-conf)
+#pretty-print-ports-conf: collect-ports-conf
+# @${ECHO_MSG} "${.CURDIR:C/${PORTSDIR}\///} : OPTIONS_SET=${opts_set:O} | OPTIONS_UNSET=${opts_unset:O}"
+#.endif # pretty-print-ports-conf
+
desktop-categories:
@categories=""; \
for native_category in ${CATEGORIES}; do \
@@ -6445,6 +6481,29 @@ install-license:
@${DO_NADA}
.endif
+.if !defined(TEST_ARGS)
+TEST_ARGS= ${MAKE_ARGS}
+.else
+TEST_ARGS+= ${MAKE_ARGS}
+.endif
+.if !defined(TEST_ENV)
+TEST_ENV= ${MAKE_ENV}
+.else
+TEST_ENV+= ${MAKE_ENV}
+.endif
+TEST_TARGET?= test
+TEST_WRKSRC?= ${BUILD_WRKSRC}
+
+#.if !target(regression-test) && defined(PERL_CONFIGURE) && defined(PKGNAMEPREFIX) && ${PKGNAMEPREFIX} == p5-
+.if !target(regression-test) && defined(PERL_CONFIGURE)
+regression-test: build
+.if defined(PERL_MODBUILD)
+ cd ${TEST_WRKSRC}/ && ${SETENV} ${TEST_ENV} ${PERL5} ${PL_BUILD} ${TEST_ARGS} ${TEST_TARGET} || ${TRUE}
+.else
+ cd ${TEST_WRKSRC}/ && ${SETENV} ${TEST_ENV} ${MAKE} ${TEST_ARGS} ${TEST_TARGET} || ${TRUE}
+.endif
+.endif
+
.endif
# End of post-makefile section.
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 72d50ba2506d..fb40795bcba9 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -99,6 +99,9 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# PYTHONPREFIX_LIBDIR default: ${PREFIX}/lib/${PYTHON_VERSION}
# PYTHONPREFIX_SITELIBDIR default: ${PYTHONPREFIX_LIBDIR}/site-packages
#
+# PYTHON_SHEBANG_FILES
+# - Specify the files which shebang lines you want to fix.
+#
# PYDISTUTILS - Dependency line for the distutils extension. As of
# Python-2.0, the distutils are in the base distribution.
#
@@ -594,6 +597,7 @@ PLIST_SUB+= PYTHON_INCLUDEDIR=${PYTHONPREFIX_INCLUDEDIR:S;${PREFIX}/;;} \
PYTHON_LIBDIR=${PYTHONPREFIX_LIBDIR:S;${PREFIX}/;;} \
PYTHON_PLATFORM=${PYTHON_PLATFORM} \
PYTHON_SITELIBDIR=${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;} \
+ PYTHON_VER=${PYTHON_VER} \
PYTHON_VERSION=${PYTHON_VERSION}
# Zope specific substitutions