aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/stonesoup/Makefile6
-rw-r--r--games/stonesoup/distinfo6
-rw-r--r--games/stonesoup/files/patch-AppHdr.h26
-rw-r--r--games/stonesoup/files/patch-tilesdl.cc11
-rw-r--r--games/stonesoup/pkg-plist5
5 files changed, 24 insertions, 30 deletions
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index a78248eb5047..1889cfe01292 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= stonesoup
-PORTVERSION= 0.5
+PORTVERSION= 0.5.1
CATEGORIES= games
MASTER_SITES= SF/crawl-ref
DISTNAME= stone_soup-${PORTVERSION}-src
@@ -24,6 +24,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/source/
SUB_FILES= README.FreeBSD
PLIST_SUB= SAVEDIR="${SAVEDIR}"
+FETCH_ARGS?= -pRr
+
OPTIONS= SDL "SDL support (tiles interface)" off \
SOUND "Sound support" off \
LUA_BINDINGS "LUA bindings for user scripts" on \
@@ -49,7 +51,7 @@ RUN_DEPENDS+= sox:${PORTSDIR}/audio/sox
.endif #WITH_SOUND
post-patch:
- @${REINPLACE_CMD} -e "s,%%DATADIR%%,${DATADIR}," ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e "s,%%DATADIR%%,${DATADIR}/," ${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e "s,%%SAVEDIR%%,${SAVEDIR}," ${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," ${WRKSRC}/${MAKEFILE}
.if defined(WITHOUT_LUA_BINDINGS)
diff --git a/games/stonesoup/distinfo b/games/stonesoup/distinfo
index 8a83f937db1c..0a4e0d2e4c97 100644
--- a/games/stonesoup/distinfo
+++ b/games/stonesoup/distinfo
@@ -1,3 +1,3 @@
-MD5 (stone_soup-0.5-src.tbz2) = ee43ae01f6900a88727aa4299f0f41d7
-SHA256 (stone_soup-0.5-src.tbz2) = 34a96d3b7d4ad91d3e0f548c9134d7df3afe7131fd858d0adf60a3ca604a7ec8
-SIZE (stone_soup-0.5-src.tbz2) = 5884852
+MD5 (stone_soup-0.5.1-src.tbz2) = e1feb17d161311825e5eb676c14be44a
+SHA256 (stone_soup-0.5.1-src.tbz2) = 156b8766ca39f7446d0a0846c178e3c178050eaf1627fbb9f828f659d13f853e
+SIZE (stone_soup-0.5.1-src.tbz2) = 4758603
diff --git a/games/stonesoup/files/patch-AppHdr.h b/games/stonesoup/files/patch-AppHdr.h
index 895c836b0537..271c7e74f731 100644
--- a/games/stonesoup/files/patch-AppHdr.h
+++ b/games/stonesoup/files/patch-AppHdr.h
@@ -1,6 +1,6 @@
---- ./AppHdr.h.orig 2009-06-12 12:32:16.000000000 +0200
-+++ ./AppHdr.h 2009-06-19 13:54:51.000000000 +0200
-@@ -124,7 +124,7 @@
+--- ./AppHdr.h.orig 2009-07-29 01:31:27.000000000 +0200
++++ ./AppHdr.h 2009-08-03 10:10:09.000000000 +0200
+@@ -126,7 +126,7 @@
// setuid or setgid. Filenames passed to this command *are not
// validated in any way*.
//
@@ -9,14 +9,12 @@
// For cases when the game will be played on terms that don't support the
// curses "bold == lighter" 16 colour mode. -- bwr
-@@ -401,8 +401,8 @@
- // PACKAGE_SUFFIX is used when the package file name is needed
- //
- // Comment these lines out if you want to leave the save files uncompressed.
-- #define SAVE_PACKAGE_CMD "/usr/bin/zip -m -q -j -1 %s.zip %s.*"
-- #define LOAD_UNPACKAGE_CMD "/usr/bin/unzip -q -o %s.zip -d %s"
-+ // #define SAVE_PACKAGE_CMD "/usr/bin/zip -m -q -j -1 %s.zip %s.*"
-+ // #define LOAD_UNPACKAGE_CMD "/usr/bin/unzip -q -o %s.zip -d %s"
-
- #ifdef SAVE_PACKAGE_CMD
- // This is used to unpack specific files from the archive.
+@@ -413,6 +413,8 @@
+ // The default behaviour is to compress with zip.
+ // To use GNU tar instead, define SAVE_PACKAGE_TAR.
+ // To avoid compression entirely, define SAVE_PACKAGE_NONE.
++ #define SAVE_PACKAGE_NONE
++
+ #ifndef SAVE_PACKAGE_NONE
+ #ifdef SAVE_PACKAGE_TAR
+ // The --absolute-names switch is only there to suppress noise on stdout.
diff --git a/games/stonesoup/files/patch-tilesdl.cc b/games/stonesoup/files/patch-tilesdl.cc
deleted file mode 100644
index a9997c5b9338..000000000000
--- a/games/stonesoup/files/patch-tilesdl.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./tilesdl.cc.orig 2009-06-19 13:55:52.000000000 +0200
-+++ ./tilesdl.cc 2009-06-19 13:56:17.000000000 +0200
-@@ -234,7 +234,7 @@
- #ifdef WIN32TILES
- const char *icon_name = "dat/tiles/stone_soup_icon-win32.png";
- #else
-- const char *icon_name = "dat/tiles/stone_soup_icon-32x32.png";
-+ const char *icon_name = "%%DATADIR%%/dat/tiles/stone_soup_icon-32x32.png";
- #endif
- SDL_Surface *icon = IMG_Load(icon_name);
- if (!icon)
diff --git a/games/stonesoup/pkg-plist b/games/stonesoup/pkg-plist
index 7e8693fc8092..47102dc4d975 100644
--- a/games/stonesoup/pkg-plist
+++ b/games/stonesoup/pkg-plist
@@ -89,6 +89,7 @@ bin/stonesoup
%%DATADIR%%/settings/menu_colours.txt
%%DATADIR%%/settings/init.txt
%%DATADIR%%/settings/food_colouring.txt
+%%DATADIR%%/settings/dolls.txt
%%DATADIR%%/settings/autopickup_exceptions.txt
%%DATADIR%%/settings/034_monster_glyphs.txt
%%DATADIR%%/settings/travel_stoppers.txt
@@ -96,6 +97,7 @@ bin/stonesoup
%%DATADIR%%/docs/ssh_guide.txt
%%DATADIR%%/docs/quickstart.txt
%%DATADIR%%/docs/pcre_license.txt
+%%DATADIR%%/docs/patch_guide.txt
%%DATADIR%%/docs/options_guide.txt
%%DATADIR%%/docs/mt19937.txt
%%DATADIR%%/docs/monster_speech.txt
@@ -106,8 +108,11 @@ bin/stonesoup
%%DATADIR%%/docs/keybind.txt
%%DATADIR%%/docs/key_changes.txt
%%DATADIR%%/docs/crawl_manual.txt
+%%DATADIR%%/docs/crawl-0.5.1-options.txt
+%%DATADIR%%/docs/crawl-0.5.0-options.txt
%%DATADIR%%/docs/coding_conventions.txt
%%DATADIR%%/docs/arena.txt
+%%DATADIR%%/docs/changelog.txt
%%DATADIR%%/docs/aptitudes.txt
%%DATADIR%%/docs/tiles_help.txt
@exec chown -R root:games %D/%%DATADIR%%