aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/midori/Makefile15
-rw-r--r--www/midori/distinfo4
-rw-r--r--www/midori/files/patch-data__midori.desktop.in26
-rw-r--r--www/midori/files/patch-extensions__delayed-load.vala46
-rw-r--r--www/midori/files/patch-extensions__external-download-manager.vala60
-rw-r--r--www/midori/files/patch-katze__gtk3-compat.h16
-rw-r--r--www/midori/files/patch-midori__main.c24
-rw-r--r--www/midori/files/patch-midori__midori-download.vala40
-rw-r--r--www/midori/files/patch-midori__midori-session.c12
-rw-r--r--www/midori/files/patch-midori__midori-stock.h11
-rw-r--r--www/midori/files/patch-midori__midori-view.c64
-rw-r--r--www/midori/files/patch-midori__midori-view.h16
-rw-r--r--www/midori/files/patch-midori__midori.vapi24
-rw-r--r--www/midori/files/patch-wscript38
-rw-r--r--www/midori/pkg-descr8
-rw-r--r--www/midori/pkg-plist9
16 files changed, 160 insertions, 253 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index 179d6115b495..2fc8029615c5 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -3,7 +3,7 @@
#
PORTNAME= midori
-PORTVERSION= 0.4.7
+PORTVERSION= 0.4.8
CATEGORIES= www xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}
@@ -46,14 +46,14 @@ INSTALLS_ICONS= yes
USE_LDCONFIG= yes
USE_PKGCONFIG= build
-PLIST_SUB= VERSION="${PORTVERSION:R}" \
- PORTVERSION="${PORTVERSION}"
+PLIST_SUB= VERSION="${PORTVERSION:R}"
-OPTIONS_DEFINE= APIDOCS NLS UNIQUE
+OPTIONS_DEFINE= APIDOCS NLS UNIQUE ZEITGEIST
OPTIONS_DEFAULT= NLS UNIQUE
APIDOCS_DESC= Build API documentation
UNIQUE_DESC= Single instance support
+ZEITGEIST_DESC= User logs activities
.include <bsd.port.options.mk>
@@ -84,6 +84,13 @@ CONFIGURE_ARGS+=--enable-unique
CONFIGURE_ARGS+=--disable-unique
.endif
+.if ${PORT_OPTIONS:MZEITGEIST}
+LIB_DEPENDS+= zeitgeist-1:${PORTSDIR}/sysutils/libzeitgeist
+CONFIGURE_ARGS+=--enable-zeitgeist
+.else
+CONFIGURE_ARGS+=--disable-zeitgeist
+.endif
+
pre-patch:
# Disable HTTP Strict Transport Security (hsts)
@cd ${WRKSRC}/katze && ${RM} midori-hsts.vala
diff --git a/www/midori/distinfo b/www/midori/distinfo
index e4318c25bc07..3e9e7e37ddd1 100644
--- a/www/midori/distinfo
+++ b/www/midori/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/midori-0.4.7.tar.bz2) = 65bf9976733597c405492ce91aa664fd10547cb7df16e0a70f260c7a3e97ea5d
-SIZE (xfce4/midori-0.4.7.tar.bz2) = 1015921
+SHA256 (xfce4/midori-0.4.8.tar.bz2) = 40bf23f84a3537f54d7eb45df1da40ebef54c321b1b34d0d0c8e45bb0cce5e9f
+SIZE (xfce4/midori-0.4.8.tar.bz2) = 1047789
diff --git a/www/midori/files/patch-data__midori.desktop.in b/www/midori/files/patch-data__midori.desktop.in
new file mode 100644
index 000000000000..9ff13a0bce17
--- /dev/null
+++ b/www/midori/files/patch-data__midori.desktop.in
@@ -0,0 +1,26 @@
+--- ./data/midori.desktop.in.orig 2013-02-05 23:28:05.000000000 +0000
++++ ./data/midori.desktop.in 2013-02-07 06:50:36.000000000 +0000
+@@ -15,19 +15,19 @@
+ StartupNotify=true
+ X-Osso-Type=application/x-executable
+ X-Osso-Service=midori
+-X-Ayatana-Desktop-Shortcuts=TabNew;WindowNew;Private
++Actions=TabNew;WindowNew;Private
+
+-[TabNew Shortcut Group]
++[Desktop Action TabNew]
+ _Name=New Tab
+ Exec=midori -e TabNew
+ TargetEnvironment=Unity
+
+-[WindowNew Shortcut Group]
++[Desktop Action WindowNew]
+ _Name=New Window
+ Exec=midori -e WindowNew
+ TargetEnvironment=Unity
+
+-[Private Shortcut Group]
++[Desktop Action Private]
+ _Name=New Private Browsing Window
+ Exec=midori --private
+ TargetEnvironment=Unity
diff --git a/www/midori/files/patch-extensions__delayed-load.vala b/www/midori/files/patch-extensions__delayed-load.vala
index 4e704f6f2acf..be4892621b15 100644
--- a/www/midori/files/patch-extensions__delayed-load.vala
+++ b/www/midori/files/patch-extensions__delayed-load.vala
@@ -1,44 +1,26 @@
---- ./extensions/delayed-load.vala.orig 2012-09-19 21:17:43.000000000 +0000
-+++ ./extensions/delayed-load.vala 2012-09-21 16:51:55.000000000 +0000
-@@ -86,7 +86,7 @@
- item.ref();
-
- int64 delay = item.get_meta_integer ("delay");
-- if (delay == -2) {
-+ if (delay == Midori.Delay.PENDING_UNDELAY) {
- view.reload (true);
- }
- }
-@@ -124,7 +124,7 @@
+--- ./extensions/delayed-load.vala.orig 2013-02-05 23:28:05.000000000 +0000
++++ ./extensions/delayed-load.vala 2013-02-07 06:05:11.000000000 +0000
+@@ -123,7 +123,11 @@
if (this.timeout == 0)
view.reload (true);
else {
-- unowned TabShaker shaker = tasks.get (browser);
++#if !HAVE_GLIB_2_30
+ unowned TabShaker shaker = tasks.lookup (browser);
++#else
+ unowned TabShaker shaker = tasks.get (browser);
++#endif
if (shaker != null) {
shaker.tasks.add (view);
- Timeout.add (this.timeout, shaker.reload_tab);
-@@ -141,7 +141,7 @@
- item.ref();
-
- int64 delay = item.get_meta_integer ("delay");
-- if (delay == -2 && new_view.progress < 1.0) {
-+ if (delay == Midori.Delay.PENDING_UNDELAY && new_view.progress < 1.0) {
- this.schedule_reload (browser, new_view);
- }
- }
-@@ -157,12 +157,12 @@
- item.ref();
-
- int64 delay = item.get_meta_integer ("delay");
-- if (delay != 1) {
-+ if (delay != Midori.Delay.DELAYED) {
- unowned WebKit.WebView web_view = view.get_web_view ();
- WebKit.LoadStatus load_status = web_view.load_status;
+ Midori.Timeout.add (this.timeout, shaker.reload_tab);
+@@ -160,7 +164,11 @@
+ WebKit.LoadStatus load_status = view.web_view.load_status;
if (load_status == WebKit.LoadStatus.FINISHED) {
if (this.timeout != 0)
-- this.tasks.set (browser, new TabShaker (browser));
++#if !HAVE_GLIB_2_30
+ this.tasks.replace (browser, new TabShaker (browser));
++#else
+ this.tasks.set (browser, new TabShaker (browser));
++#endif
if (view.progress < 1.0)
this.schedule_reload (browser, view);
diff --git a/www/midori/files/patch-extensions__external-download-manager.vala b/www/midori/files/patch-extensions__external-download-manager.vala
index ccba813638c9..1c5fefc3943c 100644
--- a/www/midori/files/patch-extensions__external-download-manager.vala
+++ b/www/midori/files/patch-extensions__external-download-manager.vala
@@ -1,50 +1,60 @@
---- ./extensions/external-download-manager.vala.orig 2012-09-19 21:17:43.000000000 +0000
-+++ ./extensions/external-download-manager.vala 2012-09-21 16:54:03.000000000 +0000
-@@ -134,17 +134,23 @@
-
+--- ./extensions/external-download-manager.vala.orig 2013-02-05 23:28:05.000000000 +0000
++++ ./extensions/external-download-manager.vala 2013-02-07 06:20:07.000000000 +0000
+@@ -137,18 +137,34 @@
+ #if !HAVE_WIN32
private class Aria2 : ExternalDownloadManager {
public override bool download (DownloadRequest dlReq) {
-- var url = value_array_new ();
-- value_array_insert (url, 0, typeof (string), dlReq.uri);
++#if !HAVE_GLIB_2_30
+ var url = new GLib.ValueArray (2);
-+
+ var uri = new GLib.Value (typeof (string));
+ uri.set_string (dlReq.uri);
-+
+ url.insert (0, uri);
++#else
+ var url = value_array_new ();
+ value_array_insert (url, 0, typeof (string), dlReq.uri);
++#endif
GLib.HashTable<string, GLib.Value?> options = value_hash_new ();
var referer = new GLib.Value (typeof (string));
referer.set_string (dlReq.referer);
options.insert ("referer", referer);
-- var headers = value_array_new ();
++#if !HAVE_GLIB_2_30
+ var headers = new GLib.ValueArray (2);
- if (dlReq.cookie_header != null) {
-- value_array_insert (headers, 0, typeof (string), "Cookie: %s".printf(dlReq.cookie_header));
-+ var cookie = new GLib.Value (typeof (string));
++ if (dlReq.cookie_header != null) {
++ var cookie = new GLib.Value (typeof (string));
+ cookie.set_string ("Cookie: %s".printf(dlReq.cookie_header));
+ headers.insert (0, cookie);
++ }
++#else
+ var headers = value_array_new ();
+ if (dlReq.cookie_header != null) {
+ value_array_insert (headers, 0, typeof (string), "Cookie: %s".printf(dlReq.cookie_header));
}
++#endif
if (headers.n_values > 0)
-@@ -158,8 +164,8 @@
+ options.insert ("header", headers);
+@@ -161,8 +177,13 @@
session.send_message (message);
try {
-- Value v;
-- XMLRPC.parse_method_response ((string) message.response_body.flatten ().data, -1, out v);
-+ var v = new GLib.Value (typeof(string));
++#if !HAVE_GLIB_2_30
++ var v = new GLib.Value (typeof (string));
+ XMLRPC.parse_method_response ((string) message.response_body.flatten ().data, -1, v);
++#else
+ Value v;
+ XMLRPC.parse_method_response ((string) message.response_body.flatten ().data, -1, out v);
++#endif
return true;
} catch (Error e) {
this.handle_exception (e);
-@@ -293,7 +299,7 @@
- authors: "André Stösel <andre@stoesel.de>",
- key: "commandline");
-
-- this.install_string ("commandline", "wget --no-check-certificate --referer={REFERER} --header={COOKIES} {URL}");
-+ this.install_string ("commandline", "fetch {URL}");
-
- this.activate.connect (activated);
- this.deactivate.connect (deactivated);
+@@ -311,6 +332,8 @@
+ internal CommandLine () {
+ #if HAVE_WIN32
+ string default_commandline = "\"%s\\FlashGet\\flashget.exe\" {URL}".printf (Environment.get_variable ("ProgramFiles"));
++#elif HAVE_FREEBSD
++ string default_commandline = "fetch {URL}";
+ #else
+ string default_commandline = "wget --no-check-certificate --referer={REFERER} --header={COOKIES} {URL}";
+ #endif
diff --git a/www/midori/files/patch-katze__gtk3-compat.h b/www/midori/files/patch-katze__gtk3-compat.h
deleted file mode 100644
index 36810eca69dd..000000000000
--- a/www/midori/files/patch-katze__gtk3-compat.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- ./katze/gtk3-compat.h.orig 2012-09-19 21:17:43.000000000 +0000
-+++ ./katze/gtk3-compat.h 2012-09-21 14:13:13.000000000 +0000
-@@ -116,8 +116,11 @@
- #define GDK_KEY_Return GDK_Return
- #endif
-
--#ifndef GDK_IS_X11_DISPLAY
-- #define GDK_IS_X11_DISPLAY(display) TRUE
-+#ifdef GDK_WINDOWING_X11
-+ #include <gdk/gdkx.h>
-+ #ifndef GDK_IS_X11_DISPLAY
-+ #define GDK_IS_X11_DISPLAY(display) TRUE
-+ #endif
- #endif
-
- G_END_DECLS
diff --git a/www/midori/files/patch-midori__main.c b/www/midori/files/patch-midori__main.c
deleted file mode 100644
index 725a5d706a90..000000000000
--- a/www/midori/files/patch-midori__main.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- ./midori/main.c.orig 2012-09-19 21:17:43.000000000 +0000
-+++ ./midori/main.c 2012-09-21 19:10:59.000000000 +0000
-@@ -1027,9 +1027,6 @@
- g_signal_connect (session, "request-queued",
- G_CALLBACK (midori_soup_session_settings_accept_language_cb), settings);
-
-- soup_session_add_feature (session, SOUP_SESSION_FEATURE (
-- midori_hsts_new (midori_paths_get_readonly_config_filename ("hsts"))));
--
- midori_soup_session_debug (session);
-
- g_object_set_data (G_OBJECT (session), "midori-session-initialized", (void*)1);
-@@ -1430,8 +1427,9 @@
- {
- katze_item_set_meta_integer (item, "append", 1);
- katze_item_set_meta_integer (item, "dont-write-history", 1);
-- if (load_on_startup == MIDORI_STARTUP_DELAYED_PAGES)
-- katze_item_set_meta_integer (item, "delay", 1);
-+ if (load_on_startup == MIDORI_STARTUP_DELAYED_PAGES
-+ || katze_item_get_meta_integer (item, "delay") == MIDORI_DELAY_PENDING_UNDELAY)
-+ katze_item_set_meta_integer (item, "delay", MIDORI_DELAY_DELAYED);
- midori_browser_add_item (browser, item);
- }
- current = katze_item_get_meta_integer (KATZE_ITEM (_session), "current");
diff --git a/www/midori/files/patch-midori__midori-download.vala b/www/midori/files/patch-midori__midori-download.vala
deleted file mode 100644
index 0a5358a30504..000000000000
--- a/www/midori/files/patch-midori__midori-download.vala
+++ /dev/null
@@ -1,40 +0,0 @@
---- ./midori/midori-download.vala.orig 2012-09-19 21:17:43.000000000 +0000
-+++ ./midori/midori-download.vala 2012-09-21 14:29:25.000000000 +0000
-@@ -46,8 +46,8 @@
- string filename = Path.get_basename (download.destination_uri);
- /* i18n: Download tooltip (size): 4KB of 43MB */
- string size = _("%s of %s").printf (
-- format_size (download.current_size),
-- format_size (download.total_size));
-+ format_size_for_display ((int64) download.current_size),
-+ format_size_for_display ((int64) download.total_size));
-
- /* Finished, no speed or remaining time */
- if (is_finished (download) || download.status == WebKit.DownloadStatus.CREATED)
-@@ -84,7 +84,7 @@
-
- string speed;
- if (elapsed != last_time) {
-- speed = format_size ((uint64)(
-+ speed = format_size_for_display ((int64)(
- (current_size - last_size) / (elapsed - last_time)));
- }
- else
-@@ -172,6 +172,8 @@
- return Gtk.Stock.OPEN;
- case WebKit.DownloadStatus.CANCELLED:
- return Gtk.Stock.CLEAR;
-+ case WebKit.DownloadStatus.ERROR:
-+ return Gtk.Stock.DIALOG_ERROR;
- default:
- critical ("action_stock_id: %d", download.status);
- warn_if_reached ();
-@@ -307,7 +309,7 @@
- message = _("There is not enough free space to download \"%s\".").printf (
- Path.get_basename (uri));
- detailed_message = _("The file needs %s but only %s are left.").printf (
-- format_size (download.total_size), format_size (free_space));
-+ format_size_for_display ((int64) download.total_size), format_size_for_display ((int64) free_space));
- }
- else
- assert_not_reached ();
diff --git a/www/midori/files/patch-midori__midori-session.c b/www/midori/files/patch-midori__midori-session.c
new file mode 100644
index 000000000000..d641fbf2167d
--- /dev/null
+++ b/www/midori/files/patch-midori__midori-session.c
@@ -0,0 +1,12 @@
+--- ./midori/midori-session.c.orig 2013-02-05 23:28:05.000000000 +0000
++++ ./midori/midori-session.c 2013-02-07 06:47:23.000000000 +0000
+@@ -226,7 +226,8 @@
+ g_signal_connect (session, "request-queued",
+ G_CALLBACK (midori_soup_session_settings_accept_language_cb), settings);
+
+- soup_session_add_feature (session, SOUP_SESSION_FEATURE (midori_hsts_new ()));
++ /* katze/midori-hsts.vala file is currently removed
++ soup_session_add_feature (session, SOUP_SESSION_FEATURE (midori_hsts_new ()));*/
+
+ if (midori_debug ("headers"))
+ {
diff --git a/www/midori/files/patch-midori__midori-stock.h b/www/midori/files/patch-midori__midori-stock.h
new file mode 100644
index 000000000000..4452e6489b2f
--- /dev/null
+++ b/www/midori/files/patch-midori__midori-stock.h
@@ -0,0 +1,11 @@
+--- ./midori/midori-stock.h.orig 2013-02-05 23:28:05.000000000 +0000
++++ ./midori/midori-stock.h 2013-02-08 09:07:30.000000000 +0000
+@@ -25,7 +25,7 @@
+ #define STOCK_BOOKMARK_ADD "bookmark-new"
+ #define STOCK_IMAGE "image-x-generic"
+ #define STOCK_NETWORK_OFFLINE "network-offline"
+-#define STOCK_SCRIPT "text-x-javascript"
++#define STOCK_SCRIPT "text-x-script"
+ #define STOCK_SEND "mail-send"
+ #define STOCK_TAB_NEW "tab-new"
+ #define STOCK_USER_TRASH "user-trash"
diff --git a/www/midori/files/patch-midori__midori-view.c b/www/midori/files/patch-midori__midori-view.c
index 45b013257fbe..9be9777f9679 100644
--- a/www/midori/files/patch-midori__midori-view.c
+++ b/www/midori/files/patch-midori__midori-view.c
@@ -1,62 +1,16 @@
---- ./midori/midori-view.c.orig 2012-09-19 21:17:43.000000000 +0000
-+++ ./midori/midori-view.c 2012-09-21 14:22:48.000000000 +0000
-@@ -1025,6 +1025,9 @@
- #endif
- view->special = FALSE;
-
-+ if (katze_item_get_meta_integer (view->item, "delay") == MIDORI_DELAY_PENDING_UNDELAY)
-+ katze_item_set_meta_integer (view->item, "delay", MIDORI_DELAY_UNDELAYED);
-+
- /* Remove link labels */
- js_context = webkit_web_frame_get_global_context (web_frame);
- result = sokoke_js_script_eval (js_context,
-@@ -4205,7 +4208,7 @@
- katze_assign (view->uri, NULL);
- katze_assign (view->mime_type, NULL);
- katze_item_set_meta_string (view->item, "mime-type", NULL);
-- katze_item_set_meta_integer (view->item, "delay", -1);
-+ katze_item_set_meta_integer (view->item, "delay", MIDORI_DELAY_UNDELAYED);
-
- html = midori_speed_dial_get_html (dial, NULL);
- midori_view_load_alternate_string (view, html, "about:blank", NULL);
-@@ -4365,10 +4368,12 @@
+--- ./midori/midori-view.c.orig 2013-02-05 23:28:05.000000000 +0000
++++ ./midori/midori-view.c 2013-02-06 22:29:13.000000000 +0000
+@@ -3981,10 +3981,12 @@
gchar const* version_strings[] = {
LIBSOUP_VERSION,
CAIRO_VERSION_STRING, cairo_version_string (),
-+ #ifdef HAVE_GCR
++ #if HAVE_GCR
GCR_VERSION,
+ #elif HAVE_GRANITE
GRANITE_VERSION,
LIBNOTIFY_VERSION,
-- #ifdef HAVE_HILDON_2_2
-+ #elif HAVE_HILDON_2_2
- "Hildon 2.2",
- #elif HAVE_HILDON
- "Hildon",
-@@ -4437,15 +4442,15 @@
- webkit_web_view_load_html_string (
- WEBKIT_WEB_VIEW (view->web_view), data, view->uri);
- g_free (data);
-- katze_item_set_meta_integer (view->item, "delay", -1);
-+ katze_item_set_meta_integer (view->item, "delay", MIDORI_DELAY_UNDELAYED);
- if (g_strcmp0 (view->item->uri, view->uri))
- katze_item_set_uri (view->item, view->uri);
- g_object_notify (G_OBJECT (view), "uri");
- }
-- else if (katze_item_get_meta_boolean (view->item, "delay"))
-+ else if (katze_item_get_meta_integer (view->item, "delay") == MIDORI_DELAY_DELAYED)
- {
- katze_assign (view->uri, g_strdup (uri));
-- katze_item_set_meta_integer (view->item, "delay", -2);
-+ katze_item_set_meta_integer (view->item, "delay", MIDORI_DELAY_PENDING_UNDELAY);
- midori_view_display_error (
- view, view->uri, view->title ? view->title : view->uri,
- _("Page loading delayed"),
-@@ -5479,7 +5484,6 @@
- webkit_web_view_reload (WEBKIT_WEB_VIEW (view->web_view));
- else
- webkit_web_view_reload_bypass_cache (WEBKIT_WEB_VIEW (view->web_view));
-- katze_item_set_meta_integer (view->item, "delay", -1);
- }
-
- /**
+- #if HAVE_UNIQUE
++ #elif HAVE_UNIQUE
+ "libunique " UNIQUE_VERSION,
+ #else
+ "Sockets",
diff --git a/www/midori/files/patch-midori__midori-view.h b/www/midori/files/patch-midori__midori-view.h
deleted file mode 100644
index a3e376966acc..000000000000
--- a/www/midori/files/patch-midori__midori-view.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- ./midori/midori-view.h.orig 2012-09-19 21:17:43.000000000 +0000
-+++ ./midori/midori-view.h 2012-09-21 14:17:03.000000000 +0000
-@@ -35,6 +35,13 @@
- MIDORI_NEW_VIEW_WINDOW
- } MidoriNewView;
-
-+typedef enum
-+{
-+ MIDORI_DELAY_UNDELAYED = -1, /* The view is in a regular undelayed state */
-+ MIDORI_DELAY_DELAYED = 1, /* The view is delayed but has not displayed any indication of such */
-+ MIDORI_DELAY_PENDING_UNDELAY = -2 /* The view is delayed and showing a message asking to be undelayed */
-+} MidoriDelay;
-+
- GType
- midori_new_view_get_type (void) G_GNUC_CONST;
-
diff --git a/www/midori/files/patch-midori__midori.vapi b/www/midori/files/patch-midori__midori.vapi
deleted file mode 100644
index 7f385d422f29..000000000000
--- a/www/midori/files/patch-midori__midori.vapi
+++ /dev/null
@@ -1,24 +0,0 @@
---- ./midori/midori.vapi.orig 2012-09-19 21:17:43.000000000 +0000
-+++ ./midori/midori.vapi 2012-09-21 14:15:47.000000000 +0000
-@@ -124,6 +124,7 @@
- public string key { get; set; }
-
- public signal void activate (Midori.App app);
-+ public signal bool is_prepared ();
- public signal void deactivate ();
- public signal void open_preferences ();
- }
-@@ -190,6 +191,13 @@
- OPEN_IN_VIEWER
- }
-
-+ [CCode (cheader_filename = "midori/midori-view.h", cprefix = "MIDORI_DELAY_")]
-+ public enum Delay {
-+ UNDELAYED,
-+ DELAYED,
-+ PENDING_UNDELAY,
-+ }
-+
- public class WebSettings : WebKit.WebSettings {
- public WebSettings ();
- [NoAccessorMethod]
diff --git a/www/midori/files/patch-wscript b/www/midori/files/patch-wscript
index 48f69e64cae8..038d372cc8bf 100644
--- a/www/midori/files/patch-wscript
+++ b/www/midori/files/patch-wscript
@@ -1,6 +1,6 @@
---- ./wscript.orig 2012-09-19 21:17:43.000000000 +0000
-+++ ./wscript 2012-09-20 06:32:04.000000000 +0000
-@@ -106,8 +106,8 @@
+--- ./wscript.orig 2013-02-05 23:28:05.000000000 +0000
++++ ./wscript 2013-02-07 21:21:09.000000000 +0000
+@@ -117,8 +117,8 @@
conf.check_tool ('compiler_cc')
conf.check_tool ('vala')
conf.check_tool ('glib2')
@@ -11,17 +11,33 @@
sys.exit (1)
if option_enabled ('nls'):
-@@ -184,11 +184,8 @@
- return conf.env['HAVE_' + var]
+@@ -199,8 +199,6 @@
if option_enabled ('gtk3'):
-- gcr_pkg = 'gcr-3'
+ check_pkg ('gcr-3', '2.32', mandatory=False)
- else:
-- gcr_pkg = 'gcr-3-gtk2'
-- check_pkg (gcr_pkg, '2.32', mandatory=False)
-- conf.define ('GCR_VERSION', ['No',conf.check_cfg(modversion=gcr_pkg)][conf.env['HAVE_GCR'] == 1])
-+ check_pkg ('gcr-3', '2.32', mandatory=False)
-+ conf.define ('GCR_VERSION', ['No',conf.check_cfg(modversion='gcr-3')][conf.env['HAVE_GCR'] == 1])
+- check_pkg ('gcr-3-gtk2', '2.32', mandatory=False)
if option_enabled ('unique'):
if option_enabled('gtk3'): unique_pkg = 'unique-3.0'
+@@ -257,7 +255,10 @@
+ if Options.platform == 'win32':
+ args = '--define-variable=target=win32'
+ conf.env.append_value ('VALAFLAGS', '-D HAVE_WIN32')
+- elif sys.platform != 'darwin':
++ elif sys.platform.startswith('freebsd'):
++ conf.env.append_value ('VALAFLAGS', '-D HAVE_FREEBSD')
++
++ if sys.platform != 'darwin':
+ check_pkg ('x11')
+ # Pass /usr/X11R6/include for OpenBSD
+ conf.check (header_name='X11/extensions/scrnsaver.h',
+@@ -371,8 +372,6 @@
+ '-Winit-self -Wundef -Wdeclaration-after-statement '
+ '-Wmissing-format-attribute -Wnested-externs'.split ())
+ conf.env.append_value ('CCFLAGS', '-Wno-unused-variable -Wno-comment'.split ())
+- if compiler == 'gcc':
+- conf.env.append_value ('CCFLAGS', '-Wno-unused-but-set-variable'.split ())
+
+ if conf.env['UNIQUE_VERSION'] == '1.0.4':
+ Utils.pprint ('RED', 'unique 1.0.4 found, this version is erroneous.')
diff --git a/www/midori/pkg-descr b/www/midori/pkg-descr
index fa4e7314b85f..2c4b2a16ed7b 100644
--- a/www/midori/pkg-descr
+++ b/www/midori/pkg-descr
@@ -1,12 +1,12 @@
Midori is a lightweight web browser.
-* Full integration with GTK+2.
+* Full integration with GTK+2/GTK+3.
* Fast rendering with WebKit.
* Tabs, windows and session management.
* Bookmarks are stored with XBEL.
* Searchbox based on OpenSearch.
* Custom context menu actions.
-* User scripts and user styles support.
-* Extensible via Lua scripts.
+* User scripts and customized keyboard support.
+* Extensible via Vala scripts.
-WWW: http://software.twotoasts.de/?page=midori
+WWW: http://twotoasts.de/index.php/midori/
diff --git a/www/midori/pkg-plist b/www/midori/pkg-plist
index f1b28b524c7b..3bddb3a31fd5 100644
--- a/www/midori/pkg-plist
+++ b/www/midori/pkg-plist
@@ -4,6 +4,7 @@ etc/xdg/midori/search
include/midori-%%VERSION%%/extensions/delayed-load.h
include/midori-%%VERSION%%/extensions/external-download-manager.h
include/midori-%%VERSION%%/extensions/history-list.h
+include/midori-%%VERSION%%/extensions/nsplugin-manager.h
lib/midori/libadblock.so
lib/midori/libaddons.so
lib/midori/libcolorful-tabs.so
@@ -15,6 +16,7 @@ lib/midori/libfeed-panel.so
lib/midori/libformhistory.so
lib/midori/libhistory-list.so
lib/midori/libmouse-gestures.so
+lib/midori/libnsplugin-manager.so
lib/midori/libshortcuts.so
lib/midori/libstatus-clock.so
lib/midori/libstatusbar-features.so
@@ -66,10 +68,14 @@ share/applications/midori-private.desktop
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-app.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-array.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-bookmarks.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-frontend.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-history.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-locationaction.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-panel.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-platform.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-privatedata.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-searchaction.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-session.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-stock.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-view.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori-websettings.html
@@ -104,6 +110,7 @@ share/icons/hicolor/scalable/status/internet-news-reader.svg
%%NLS%%share/locale/ast/LC_MESSAGES/midori.mo
%%NLS%%share/locale/ar/LC_MESSAGES/midori.mo
%%NLS%%share/locale/be/LC_MESSAGES/midori.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/midori.mo
%%NLS%%share/locale/ca/LC_MESSAGES/midori.mo
%%NLS%%share/locale/cs/LC_MESSAGES/midori.mo
%%NLS%%share/locale/da/LC_MESSAGES/midori.mo
@@ -156,6 +163,8 @@ share/vala/vapi/external-download-manager.deps
share/vala/vapi/external-download-manager.vapi
share/vala/vapi/history-list.deps
share/vala/vapi/history-list.vapi
+share/vala/vapi/nsplugin-manager.deps
+share/vala/vapi/nsplugin-manager.vapi
@dirrmtry share/vala/vapi
@dirrmtry share/vala
@dirrm %%DATADIR%%/res