aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--cad/librecad/Makefile4
-rw-r--r--math/qtiplot/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/cad/librecad/Makefile b/cad/librecad/Makefile
index 709096c48adf..7442963362a6 100644
--- a/cad/librecad/Makefile
+++ b/cad/librecad/Makefile
@@ -8,8 +8,8 @@ MASTER_SITES= GITHUB
MAINTAINER= makc@FreeBSD.org
COMMENT= 2D CAD system
-BUILD_DEPENDS= ${LOCALBASE}/lib/libmuparser.a:${PORTSDIR}/math/muparser \
- ${LOCALBASE}/include/boost/version.hpp:${PORTSDIR}/devel/boost-libs
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libmuparser.so:${PORTSDIR}/math/muparser
USE_QT4= help qt3support help-tools_build linguist_build moc_build \
rcc_build uic_build uic3_build
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 9ba459fe37bc..017c473b9acf 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= BERLIOS http://soft.proindependent.com/src/
MAINTAINER= makc@FreeBSD.org
COMMENT= Data analysis and scientific plotting
-BUILD_DEPENDS= ${LOCALBASE}/lib/libmuparser.a:${PORTSDIR}/math/muparser
LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl \
+ libmuparser.so:${PORTSDIR}/math/muparser \
libpng15.so:${PORTSDIR}/graphics/png
# use bundled modified libraries
# qwt.5:${PORTSDIR}/x11-toolkits/qwt5 \