aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--chinese/tcl83/Makefile1
-rw-r--r--devel/cdk/Makefile1
-rw-r--r--graphics/EZWGL/Makefile1
-rw-r--r--lang/tcl82/Makefile1
-rw-r--r--lang/tcl83/Makefile1
-rw-r--r--x11-toolkits/tk84/Makefile1
6 files changed, 6 insertions, 0 deletions
diff --git a/chinese/tcl83/Makefile b/chinese/tcl83/Makefile
index 7e2fc9cadbca..4dede5aa5de5 100644
--- a/chinese/tcl83/Makefile
+++ b/chinese/tcl83/Makefile
@@ -19,6 +19,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
CONFIGURE_ARGS= --enable-shared --enable-i18nImprove
INSTALLS_SHLIB= yes
+NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
MAKE_ENV= SHORT_TCL_VER=83
PKGINSTALL= ${PKGDIR}/INSTALL.tclsh
diff --git a/devel/cdk/Makefile b/devel/cdk/Makefile
index 33eef958c38b..e4a88c936040 100644
--- a/devel/cdk/Makefile
+++ b/devel/cdk/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= alane@FreeBSD.org
USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
+NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
.include <bsd.port.pre.mk>
diff --git a/graphics/EZWGL/Makefile b/graphics/EZWGL/Makefile
index 5ed236a73984..e4cba76e6a5d 100644
--- a/graphics/EZWGL/Makefile
+++ b/graphics/EZWGL/Makefile
@@ -21,6 +21,7 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
.include <bsd.port.pre.mk>
diff --git a/lang/tcl82/Makefile b/lang/tcl82/Makefile
index 5fb81d01de13..9c4379109838 100644
--- a/lang/tcl82/Makefile
+++ b/lang/tcl82/Makefile
@@ -24,6 +24,7 @@ CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
MAKE_ENV= SHORT_TCL_VER=82
PKGINSTALL= ${PKGDIR}/pkg-install.tclsh
PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.tclsh
+NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
PLIST_SUB= TCL_VER=8.2 SHORT_TCL_VER=82
diff --git a/lang/tcl83/Makefile b/lang/tcl83/Makefile
index f339a91baef4..87bc44ceef97 100644
--- a/lang/tcl83/Makefile
+++ b/lang/tcl83/Makefile
@@ -25,6 +25,7 @@ MAKE_ENV= SHORT_TCL_VER=83
PKGINSTALL= ${PKGDIR}/pkg-install.tclsh
PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.tclsh
TCL_VER= 8.3
+NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
PLIST_SUB= TCL_VER=${TCL_VER} SHORT_TCL_VER=83
diff --git a/x11-toolkits/tk84/Makefile b/x11-toolkits/tk84/Makefile
index 4dd09f93fce6..49f392b7dd62 100644
--- a/x11-toolkits/tk84/Makefile
+++ b/x11-toolkits/tk84/Makefile
@@ -31,6 +31,7 @@ MAKE_ENV= SHORT_TK_VER=${SHORT_TK_VER}
PLIST_SUB= TK_VER=${TK_VER} SHORT_TK_VER=${SHORT_TK_VER}
PKGINSTALL= ${PKGDIR}/pkg-install.wish
PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.wish
+NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
MANCOMPRESSED= no