aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/jpatch/Makefile32
-rw-r--r--graphics/jpatch/distinfo2
-rw-r--r--graphics/jpatch/files/jpatch3
-rw-r--r--graphics/jpatch/pkg-descr4
5 files changed, 42 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 6cfa79033cf5..5b148b41dcfb 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -178,6 +178,7 @@
SUBDIR += jgraph
SUBDIR += jgv
SUBDIR += jhead
+ SUBDIR += jpatch
SUBDIR += jpeg
SUBDIR += jpeg2ps-a4
SUBDIR += jpeg2ps-letter
diff --git a/graphics/jpatch/Makefile b/graphics/jpatch/Makefile
new file mode 100644
index 000000000000..a8df05bdea27
--- /dev/null
+++ b/graphics/jpatch/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: jpatch
+# Date created: Jun 30, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= jpatch
+PORTVERSION= 0.3.b1
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.b/beta/}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A spline based 3D modeling tool
+
+USE_JAVA= 1.4+
+NO_BUILD= yes
+
+PLIST_FILES= ${JAVAJARDIR:S,^${PREFIX}/,,}/jpatch.jar \
+ bin/jpatch
+
+post-patch:
+ @${SED} 's,%%JAVAJARDIR%%,${JAVAJARDIR},' ${FILESDIR}/jpatch > ${WRKSRC}/jpatch
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/jpatch.jar ${JAVAJARDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/jpatch ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/jpatch/distinfo b/graphics/jpatch/distinfo
new file mode 100644
index 000000000000..7e42412daad1
--- /dev/null
+++ b/graphics/jpatch/distinfo
@@ -0,0 +1,2 @@
+MD5 (jpatch0.3beta1.tar.gz) = a440e93e0aeb142217c9ec86547142b9
+SIZE (jpatch0.3beta1.tar.gz) = 1995660
diff --git a/graphics/jpatch/files/jpatch b/graphics/jpatch/files/jpatch
new file mode 100644
index 000000000000..03697eee8700
--- /dev/null
+++ b/graphics/jpatch/files/jpatch
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+java -jar %%JAVAJARDIR%%/jpatch.jar
diff --git a/graphics/jpatch/pkg-descr b/graphics/jpatch/pkg-descr
new file mode 100644
index 000000000000..f0fa6117f04f
--- /dev/null
+++ b/graphics/jpatch/pkg-descr
@@ -0,0 +1,4 @@
+Patch is a spline based 3D modeling tool. It allows to create 3D models which
+can be rendered with POV-Ray or RenderMan compatible renderers (e.g. Aqsis).
+
+WWW: http://jpatch.sourceforge.net/