aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/horde-turba/Makefile11
-rw-r--r--mail/horde4-turba/Makefile11
-rw-r--r--mail/turba/Makefile11
3 files changed, 3 insertions, 30 deletions
diff --git a/mail/horde-turba/Makefile b/mail/horde-turba/Makefile
index 7c1cfbc99ab4..26a92d571d2d 100644
--- a/mail/horde-turba/Makefile
+++ b/mail/horde-turba/Makefile
@@ -70,21 +70,12 @@ post-patch:
pre-install:
.if !defined(WITHOUT_LDAP)
-.if exists(${LOCALBASE}/lib/libldap.so.1)
- @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap.so.1"; then \
+ @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap"; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with OpenLDAP support." ; \
${ECHO_MSG} "" ; \
${FALSE} ; \
fi
-.else
- @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap.so.2"; then \
- ${ECHO_MSG} "" ; \
- ${ECHO_MSG} "Please configure PHP with OpenLDAP2 support." ; \
- ${ECHO_MSG} "" ; \
- ${FALSE} ; \
- fi
-.endif
.endif
do-install:
diff --git a/mail/horde4-turba/Makefile b/mail/horde4-turba/Makefile
index 7c1cfbc99ab4..26a92d571d2d 100644
--- a/mail/horde4-turba/Makefile
+++ b/mail/horde4-turba/Makefile
@@ -70,21 +70,12 @@ post-patch:
pre-install:
.if !defined(WITHOUT_LDAP)
-.if exists(${LOCALBASE}/lib/libldap.so.1)
- @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap.so.1"; then \
+ @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap"; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with OpenLDAP support." ; \
${ECHO_MSG} "" ; \
${FALSE} ; \
fi
-.else
- @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap.so.2"; then \
- ${ECHO_MSG} "" ; \
- ${ECHO_MSG} "Please configure PHP with OpenLDAP2 support." ; \
- ${ECHO_MSG} "" ; \
- ${FALSE} ; \
- fi
-.endif
.endif
do-install:
diff --git a/mail/turba/Makefile b/mail/turba/Makefile
index 7c1cfbc99ab4..26a92d571d2d 100644
--- a/mail/turba/Makefile
+++ b/mail/turba/Makefile
@@ -70,21 +70,12 @@ post-patch:
pre-install:
.if !defined(WITHOUT_LDAP)
-.if exists(${LOCALBASE}/lib/libldap.so.1)
- @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap.so.1"; then \
+ @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap"; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with OpenLDAP support." ; \
${ECHO_MSG} "" ; \
${FALSE} ; \
fi
-.else
- @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap.so.2"; then \
- ${ECHO_MSG} "" ; \
- ${ECHO_MSG} "Please configure PHP with OpenLDAP2 support." ; \
- ${ECHO_MSG} "" ; \
- ${FALSE} ; \
- fi
-.endif
.endif
do-install: