aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/nvi-perl/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/editors/nvi-perl/Makefile b/editors/nvi-perl/Makefile
index 697baafb846b..b77388553e2a 100644
--- a/editors/nvi-perl/Makefile
+++ b/editors/nvi-perl/Makefile
@@ -29,7 +29,17 @@ CFLAGS+= -DPERL_POLLUTE
MAN1= pnvi.1
MLINKS= pnvi.1 pnex.1 pnvi.1 pnview.1
+.include <bsd.port.pre.mk>
+
+post-depends:
+.if exists(${PERL})
+PERL_THREADED!= ${PERL} -V | ${GREP} -- -Dusethreads=y || ${TRUE}
+. if ${PERL_THREADED} != ""
+IGNORE= must be built with a NON-threaded Perl
+. endif
+.endif
+
post-patch:
${LN} -s /usr/include/sys/queue.h ${WRKSRC}/../include/sys/queue_dist.h
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>