aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/leafpad/Makefile1
-rw-r--r--editors/leafpad/files/patch-src_undo.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/editors/leafpad/Makefile b/editors/leafpad/Makefile
index dc7006d0f0c4..3f451ade42fa 100644
--- a/editors/leafpad/Makefile
+++ b/editors/leafpad/Makefile
@@ -7,6 +7,7 @@
PORTNAME= leafpad
PORTVERSION= 0.7.7
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/editors/leafpad/files/patch-src_undo.c b/editors/leafpad/files/patch-src_undo.c
new file mode 100644
index 000000000000..bd1917654196
--- /dev/null
+++ b/editors/leafpad/files/patch-src_undo.c
@@ -0,0 +1,12 @@
+--- src/undo.c.orig Thu Nov 18 17:04:27 2004
++++ src/undo.c Sun Nov 21 12:21:08 2004
+@@ -159,7 +159,8 @@
+ ui_tmp->command = command;
+ ui_tmp->start = start;
+ ui_tmp->end = end;
+- g_string_printf(undo_gstr, str);
++ undo_gstr = g_string_erase(undo_gstr, 0, -1);
++ g_string_append(undo_gstr, str);
+ } else
+ undo_append_undo_info(buffer, command, start, end, g_strdup(str));
+