aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES11
-rw-r--r--Mk/bsd.options.mk18
2 files changed, 28 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 7f9489395a00..d189c11c57db 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,17 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20140127:
+AUTHOR: mat@FreeBSD.org
+
+ Add two new options helpers:
+
+ ${OPT}_${TYPE}_DEPENDS_OFF=<something> will automatically add:
+ ${TYPE_DEPENDS}+=<something> in case OPT is 'off'
+
+ ${OPT}_${FLAG}_OFF=<something> will automatically add:
+ ${FLAG}+=<something> in case OPT is 'off'
+
20140111:
AUTHOR: mva@FreeBSD.org
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 45b53c8d8d18..deb3d1fd126d 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -107,10 +107,14 @@
# ALL_TARGET INSTALL_TARGET USES DISTFILES PLIST_FILES PLIST_DIRS PLIST_DIRSTRY
# EXTRA_PATCHES PATCHFILES PATCH_SITES CATEGORIES, defining ${opt}_${variable}
# will add its content to the actual variable when the option is enabled.
+# Defining ${opt}_${variable}_OFF will add its content to the actual variable
+# when the option is disabled.
#
# For each of the depends target PKG EXTRACT PATCH FETCH BUILD LIB RUN,
# defining ${opt}_${deptype}_DEPENDS will add its content to the actual
-# dependency when the option is enabled.
+# dependency when the option is enabled. Defining
+# ${opt}_${deptype}_DEPENDS_OFF will add its content to the actual dependency
+# when the option is enabled.
##
# Set all the options available for the ports, beginning with the
@@ -418,6 +422,18 @@ CONFIGURE_ARGS+= --without-${iopt}
${configure}_ARGS+= ${${opt}_${configure}_OFF}
. endif
. endfor
+. for flags in CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CONFIGURE_ENV MAKE_ARGS \
+ MAKE_ENV ALL_TARGET INSTALL_TARGET USES DISTFILES PLIST_FILES \
+ PLIST_DIRS PLIST_DIRSTRY EXTRA_PATCHES PATCHFILES PATCH_SITES CATEGORIES
+. if defined(${opt}_${flags}_OFF)
+${flags}+= ${${opt}_${flags}_OFF}
+. endif
+. endfor
+. for deptype in PKG EXTRACT PATCH FETCH BUILD LIB RUN
+. if defined(${opt}_${deptype}_DEPENDS_OFF)
+${deptype}_DEPENDS+= ${${opt}_${deptype}_DEPENDS_OFF}
+. endif
+. endfor
. endif
.endfor