aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gstreamer-plugins-fluendo-mp3/Makefile23
-rw-r--r--audio/gstreamer-plugins-fluendo-mp3/distinfo3
-rw-r--r--audio/gstreamer-plugins-fluendo-mp3/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 7e784ce07b20..20b03e333351 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -228,6 +228,7 @@
SUBDIR += gstreamer-plugins-faad80
SUBDIR += gstreamer-plugins-flac
SUBDIR += gstreamer-plugins-flac80
+ SUBDIR += gstreamer-plugins-fluendo-mp3
SUBDIR += gstreamer-plugins-gsm
SUBDIR += gstreamer-plugins-gsm80
SUBDIR += gstreamer-plugins-ivorbis
diff --git a/audio/gstreamer-plugins-fluendo-mp3/Makefile b/audio/gstreamer-plugins-fluendo-mp3/Makefile
new file mode 100644
index 000000000000..1a0c327f92da
--- /dev/null
+++ b/audio/gstreamer-plugins-fluendo-mp3/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: gstreamer-plugins-fluendo-mp3
+# Date created: 2007-02-25
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gstreamer-plugins-fluendo-mp3
+PORTVERSION= 0.10.5
+CATEGORIES= audio
+MASTER_SITES= http://core.fluendo.com/gstreamer/src/gst-fluendo-mp3/
+DISTNAME= gst-fluendo-mp3-${PORTVERSION}
+
+MAINTAINER= multimedia@FreeBSD.org
+COMMENT= Mp3 gstreamer plugin from fluendo
+
+USE_GSTREAMER= yes
+GNU_CONFIGURE= yes
+PLIST_FILES= lib/gstreamer-0.10/libgstflump3dec.a \
+ lib/gstreamer-0.10/libgstflump3dec.la \
+ lib/gstreamer-0.10/libgstflump3dec.so
+
+.include <bsd.port.mk>
diff --git a/audio/gstreamer-plugins-fluendo-mp3/distinfo b/audio/gstreamer-plugins-fluendo-mp3/distinfo
new file mode 100644
index 000000000000..53ce386d53eb
--- /dev/null
+++ b/audio/gstreamer-plugins-fluendo-mp3/distinfo
@@ -0,0 +1,3 @@
+MD5 (gst-fluendo-mp3-0.10.5.tar.gz) = abca035b55f6d13321227192cd6bc0eb
+SHA256 (gst-fluendo-mp3-0.10.5.tar.gz) = aee08bf01614f777161d60232c544a77a58094ebb14f905092befe1fe35df2de
+SIZE (gst-fluendo-mp3-0.10.5.tar.gz) = 375373
diff --git a/audio/gstreamer-plugins-fluendo-mp3/pkg-descr b/audio/gstreamer-plugins-fluendo-mp3/pkg-descr
new file mode 100644
index 000000000000..9c4d1ebea628
--- /dev/null
+++ b/audio/gstreamer-plugins-fluendo-mp3/pkg-descr
@@ -0,0 +1,3 @@
+Mp3 gstreamer plugin from fluendo
+
+WWW: http://www.fluendo.com/resources/source-plugins.php