aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--shells/bash/Makefile8
-rw-r--r--shells/bash/options6
2 files changed, 12 insertions, 2 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 79351c9d7634..77a527e92ce8 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -31,6 +31,12 @@ COMMENT= The GNU Project's Bourne Again SHell
IGNOREFILES= FAQ
+.if defined(WITH_OPTIONS) || defined(WITH_BASH_OPTIONS)
+.include "${.CURDIR}/../bash/options"
+.endif
+
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_IMPLICITCD)
EXTRA_PATCHES+= ${PATCHDIR}/xpatch-implicitcd
.endif
@@ -96,8 +102,6 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
YACC="bison -y"
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/doc/bash.1
.if defined(WITHOUT_NLS)
diff --git a/shells/bash/options b/shells/bash/options
new file mode 100644
index 000000000000..5fb109a83dd5
--- /dev/null
+++ b/shells/bash/options
@@ -0,0 +1,6 @@
+OPTIONS= IMPLICITCD "Use directory name alone to cd into it" on \
+ COLONBREAKSWORDS "Colons break words" on \
+ HELP "Install the help files" on \
+ INST_READL "Use readline from base, otherwise bash's" on \
+ NLS "National Language Support" on \
+ STATIC_BASH "Compile without shared libs" off