aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--japanese/rxvt/Makefile8
-rw-r--r--www/kannel/Makefile4
2 files changed, 9 insertions, 3 deletions
diff --git a/japanese/rxvt/Makefile b/japanese/rxvt/Makefile
index e0a9d29d1687..d26ff8600792 100644
--- a/japanese/rxvt/Makefile
+++ b/japanese/rxvt/Makefile
@@ -27,6 +27,12 @@ CONFIGURE_ARGS= --enable-xpm-background --enable-transparency \
DOCDIR= ${PREFIX}/share/doc/ja/rxvt
RXVTLIB= ${PREFIX}/lib/X11/rxvt
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
pre-install:
@${MKDIR} ${DOCDIR}
@${INSTALL_DATA} ${FILESDIR}/README.ja ${DOCDIR}
@@ -37,4 +43,4 @@ pre-install:
post-install:
@${CHMOD} 4711 ${PREFIX}/bin/rxvt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/kannel/Makefile b/www/kannel/Makefile
index a0b157562528..b0c10acaa7cc 100644
--- a/www/kannel/Makefile
+++ b/www/kannel/Makefile
@@ -44,8 +44,8 @@ LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha"
-BROKEN= "Does not compile on alpha"
+.if ${ARCH} == "alpha" || ${ARCH} == "sparc64"
+BROKEN= "Does not compile on alpha or sparc64"
.endif
post-patch: