aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/wwwoffle/Makefile3
-rw-r--r--www/wwwoffle/distinfo6
-rw-r--r--www/wwwoffle/files/patch-src::proto.h29
-rw-r--r--www/wwwoffle/files/patch-src::wwwoffles.c11
4 files changed, 4 insertions, 45 deletions
diff --git a/www/wwwoffle/Makefile b/www/wwwoffle/Makefile
index 7ad088e66119..084c2fdc7347 100644
--- a/www/wwwoffle/Makefile
+++ b/www/wwwoffle/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= wwwoffle
-PORTVERSION= 2.9
-PORTREVISION= 1
+PORTVERSION= 2.9a
CATEGORIES= www ipv6
MASTER_SITES= http://www.gedanken.freeserve.co.uk/download-wwwoffle/
EXTRACT_SUFX= .tgz
diff --git a/www/wwwoffle/distinfo b/www/wwwoffle/distinfo
index c81133203f57..aa5a51815898 100644
--- a/www/wwwoffle/distinfo
+++ b/www/wwwoffle/distinfo
@@ -1,3 +1,3 @@
-MD5 (wwwoffle-2.9.tgz) = e8e7f3bdf1ff0a9baa26e5aebd6ad396
-SHA256 (wwwoffle-2.9.tgz) = ac5e779beae963cf2f3b0dd44f7ed64114a1c15aa2fb6f41ad7db9bc0f096df3
-SIZE (wwwoffle-2.9.tgz) = 1074108
+MD5 (wwwoffle-2.9a.tgz) = 3ba32fc842a6af96b28cd3c7ff8f6f56
+SHA256 (wwwoffle-2.9a.tgz) = 23a469f6b4be39333fdbafb750dff890c0c6e9000144ad98d27c5461dddf9de1
+SIZE (wwwoffle-2.9a.tgz) = 1071362
diff --git a/www/wwwoffle/files/patch-src::proto.h b/www/wwwoffle/files/patch-src::proto.h
deleted file mode 100644
index 70b2c5836575..000000000000
--- a/www/wwwoffle/files/patch-src::proto.h
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/proto.h~ Thu Dec 15 04:27:22 2005
-+++ src/proto.h Fri Apr 7 14:55:06 2006
-@@ -62,7 +62,7 @@
- char /*@null@*/ /*@only@*/ *HTTP_Open(URL *Url);
- char /*@null@*/ /*@only@*/ *HTTP_Request(URL *Url,Header *request_head,Body *request_body);
- int HTTP_ReadHead(/*@out@*/ Header **reply_head);
--int HTTP_ReadBody(char *s,size_t n);
-+ssize_t HTTP_ReadBody(char *s,size_t n);
- int HTTP_Close(void);
-
- #if USE_GNUTLS
-@@ -82,7 +82,7 @@
- char /*@null@*/ /*@only@*/ *FTP_Open(URL *Url);
- char /*@null@*/ /*@only@*/ *FTP_Request(URL *Url,Header *request_head,Body *request_body);
- int FTP_ReadHead(/*@out@*/ Header **reply_head);
--int FTP_ReadBody(char *s,size_t n);
-+ssize_t FTP_ReadBody(char *s,size_t n);
- int FTP_Close(void);
-
- /* In finger.c */
-@@ -90,7 +90,7 @@
- char /*@null@*/ /*@only@*/ *Finger_Open(URL *Url);
- char /*@null@*/ /*@only@*/ *Finger_Request(URL *Url,Header *request_head,Body *request_body);
- int Finger_ReadHead(/*@out@*/ Header **reply_head);
--int Finger_ReadBody(char *s,size_t n);
-+ssize_t Finger_ReadBody(char *s,size_t n);
- int Finger_Close(void);
-
- /* In ssl.c */
diff --git a/www/wwwoffle/files/patch-src::wwwoffles.c b/www/wwwoffle/files/patch-src::wwwoffles.c
deleted file mode 100644
index 761ca5f9865e..000000000000
--- a/www/wwwoffle/files/patch-src::wwwoffles.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/wwwoffles.c~ Tue Feb 21 04:27:48 2006
-+++ src/wwwoffles.c Fri Apr 7 14:11:43 2006
-@@ -3026,7 +3026,7 @@
- This function is used as a callback from gifmodify.c and htmlmodify.l
- ++++++++++++++++++++++++++++++++++++++*/
-
--int wwwoffles_read_data(char *data,size_t len)
-+ssize_t wwwoffles_read_data(char *data,size_t len)
- {
- if(modify_err==-1)
- return(0);