aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-level-set/Makefile28
-rw-r--r--math/octave-forge-level-set/distinfo2
-rw-r--r--math/octave-forge-level-set/files/patch-FastMarching.cpp10
-rw-r--r--math/octave-forge-level-set/pkg-descr11
-rw-r--r--math/octave-forge-level-set/pkg-plist1
6 files changed, 53 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 0004460db881..0debfc96650f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -306,6 +306,7 @@
SUBDIR += octave-forge-interval
SUBDIR += octave-forge-io
SUBDIR += octave-forge-irsa
+ SUBDIR += octave-forge-level-set
SUBDIR += octave-forge-linear-algebra
SUBDIR += octave-forge-lssa
SUBDIR += octave-forge-ltfat
diff --git a/math/octave-forge-level-set/Makefile b/math/octave-forge-level-set/Makefile
new file mode 100644
index 000000000000..c344733963cd
--- /dev/null
+++ b/math/octave-forge-level-set/Makefile
@@ -0,0 +1,28 @@
+# Created by: Stephen Montgomery-Smith <stephen@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= octave-forge-level-set
+PORTVERSION= 0.2.0
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv3
+
+ALL_TARGET= oct
+USES= compiler:c++0x
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-level-set/distinfo b/math/octave-forge-level-set/distinfo
new file mode 100644
index 000000000000..24d58c2a2ccb
--- /dev/null
+++ b/math/octave-forge-level-set/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/level-set-0.2.0.tar.gz) = 1152e20bd84d12b031dab80320965d490289b25a9a9a0589ba171e8b1bea00b9
+SIZE (octave-forge/level-set-0.2.0.tar.gz) = 136521
diff --git a/math/octave-forge-level-set/files/patch-FastMarching.cpp b/math/octave-forge-level-set/files/patch-FastMarching.cpp
new file mode 100644
index 000000000000..cc177c28b612
--- /dev/null
+++ b/math/octave-forge-level-set/files/patch-FastMarching.cpp
@@ -0,0 +1,10 @@
+--- FastMarching.cpp-orig 2015-02-20 03:51:59.000000000 +0000
++++ FastMarching.cpp 2015-02-20 03:52:16.000000000 +0000
+@@ -22,6 +22,7 @@
+ #include <cmath>
+ #include <memory>
+ #include <stdexcept>
++#include <string>
+
+ namespace fastMarching
+ {
diff --git a/math/octave-forge-level-set/pkg-descr b/math/octave-forge-level-set/pkg-descr
new file mode 100644
index 000000000000..8f08841c880b
--- /dev/null
+++ b/math/octave-forge-level-set/pkg-descr
@@ -0,0 +1,11 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is level-set.
+
+ Routines for calculating the time-evolution of the level-set equation and
+ extracting geometric information from the level-set function.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-level-set/pkg-plist b/math/octave-forge-level-set/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-level-set/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty