aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cppcheck/Makefile31
-rw-r--r--devel/cppcheck/distinfo3
-rw-r--r--devel/cppcheck/files/patch-Makefile15
-rw-r--r--devel/cppcheck/pkg-descr10
5 files changed, 60 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 69d0a3edf6b0..3f1447619365 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -188,6 +188,7 @@
SUBDIR += cook
SUBDIR += cpan-upload
SUBDIR += cppadvio
+ SUBDIR += cppcheck
SUBDIR += cppi
SUBDIR += cppunit
SUBDIR += cproto
diff --git a/devel/cppcheck/Makefile b/devel/cppcheck/Makefile
new file mode 100644
index 000000000000..340af4c75e62
--- /dev/null
+++ b/devel/cppcheck/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: cppcheck
+# Date created: March 3, 2009
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cppcheck
+PORTVERSION= 1.29
+CATEGORIES= devel
+MASTER_SITES= SF
+
+MAINTAINER= pgj@FreeBSD.org
+COMMENT= Static analysis of C/C++ code
+
+BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl
+
+MANCOMPRESSED= no
+MAN1= cppcheck.1
+
+USE_GMAKE= yes
+ALL_TARGET= cppcheck cppcheck.1
+
+PLIST_FILES= bin/cppcheck
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/cppcheck ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/cppcheck.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/devel/cppcheck/distinfo b/devel/cppcheck/distinfo
new file mode 100644
index 000000000000..02cd7257abd4
--- /dev/null
+++ b/devel/cppcheck/distinfo
@@ -0,0 +1,3 @@
+MD5 (cppcheck-1.29.tar.gz) = 8566c66e2ae37bbcfc2c4eb4b4d799fc
+SHA256 (cppcheck-1.29.tar.gz) = 99924ffb2e77d50ff21f68549312b63a26d5183b7cb93a0cd4ec1a0f0ae9d302
+SIZE (cppcheck-1.29.tar.gz) = 126310
diff --git a/devel/cppcheck/files/patch-Makefile b/devel/cppcheck/files/patch-Makefile
new file mode 100644
index 000000000000..8a03a798430a
--- /dev/null
+++ b/devel/cppcheck/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile.orig 2009-03-02 20:22:53.000000000 +0100
++++ Makefile 2009-03-03 22:49:59.000000000 +0100
+@@ -92,6 +92,12 @@
+ clean:
+ rm -f src/*.o test/*.o testrunner cppcheck tools/dmake tools/errmsg
+
++DB2MAN= ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl
++XP= xsltproc -''-nonet -''-param man.charmap.use.subset "0"
++
++cppcheck.1: man/cppcheck.1.xml
++ $(XP) $(DB2MAN) $<
++
+ install: cppcheck
+ install -d ${BIN}
+ install cppcheck ${BIN}
diff --git a/devel/cppcheck/pkg-descr b/devel/cppcheck/pkg-descr
new file mode 100644
index 000000000000..ac3d69538a05
--- /dev/null
+++ b/devel/cppcheck/pkg-descr
@@ -0,0 +1,10 @@
+Cppcheck is a tool for static C/C++ code analysis, and it tries to
+detect bugs that your compiler do not see. Checks for: memory leaks,
+mismatching allocation-deallocation, buffer overrun, and many more.
+
+Cppcheck is versatile. You can check non-standard code that includes
+various compiler extensions, inline assembly code, etc.
+
+The goal is no false positives.
+
+WWW: http://sourceforge.net/projects/cppcheck