aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-Session-State-Cookie/Makefile29
-rw-r--r--www/p5-Catalyst-Plugin-Session-State-Cookie/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Session-State-Cookie/pkg-descr8
-rw-r--r--www/p5-Catalyst-Plugin-Session-State-Cookie/pkg-plist6
5 files changed, 47 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b831c4ba9706..693fdbd3e436 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -498,6 +498,7 @@
SUBDIR += p5-Catalyst-Plugin-Prototype
SUBDIR += p5-Catalyst-Plugin-Session
SUBDIR += p5-Catalyst-Plugin-Session-FastMmap
+ SUBDIR += p5-Catalyst-Plugin-Session-State-Cookie
SUBDIR += p5-Catalyst-Plugin-Singleton
SUBDIR += p5-Catalyst-Plugin-Static
SUBDIR += p5-Catalyst-Plugin-SubRequest
diff --git a/www/p5-Catalyst-Plugin-Session-State-Cookie/Makefile b/www/p5-Catalyst-Plugin-Session-State-Cookie/Makefile
new file mode 100644
index 000000000000..ce28467a6ca9
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-State-Cookie/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Session-State-Cookie
+# Date created: Nov 16, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Session-State-Cookie
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/N/NU/NUFFIN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Stores a Catalyst Session in a Cookie
+
+BUILD_DEPENDS= p5-Catalyst-Plugin-Session>=0.01:${PORTSDIR}/www/p5-Catalyst-Plugin-Session
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Session::State::Cookie.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Session-State-Cookie/distinfo b/www/p5-Catalyst-Plugin-Session-State-Cookie/distinfo
new file mode 100644
index 000000000000..3e07b9443d6b
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-State-Cookie/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Session-State-Cookie-0.01.tar.gz) = dc64032b8fadf009fc5ecf86b0dfe50b
+SHA256 (Catalyst-Plugin-Session-State-Cookie-0.01.tar.gz) = 09e40afc945e0a38afb16d65a76c10b06bb890d102519f8870789a3433082c95
+SIZE (Catalyst-Plugin-Session-State-Cookie-0.01.tar.gz) = 4946
diff --git a/www/p5-Catalyst-Plugin-Session-State-Cookie/pkg-descr b/www/p5-Catalyst-Plugin-Session-State-Cookie/pkg-descr
new file mode 100644
index 000000000000..f62454f6d67b
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-State-Cookie/pkg-descr
@@ -0,0 +1,8 @@
+In order for Catalyst::Plugin::Session to work the session ID needs to
+be stored on the client, and the session data needs to be stored on the
+server.
+
+This plugin stores the session ID on the client using the cookie
+mechanism.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Session-State-Cookie/
diff --git a/www/p5-Catalyst-Plugin-Session-State-Cookie/pkg-plist b/www/p5-Catalyst-Plugin-Session-State-Cookie/pkg-plist
new file mode 100644
index 000000000000..6d4f211a584d
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-State-Cookie/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Catalyst/Plugin/Session/State/Cookie.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session/State/Cookie 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session/State 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true