aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/gcc/Makefile4
-rw-r--r--lang/gcc40/Makefile4
-rw-r--r--lang/gcc41/Makefile4
-rw-r--r--lang/gcc42/Makefile4
-rw-r--r--lang/gcc43/Makefile4
-rw-r--r--lang/gcc44/Makefile4
-rw-r--r--lang/gcc45/Makefile4
-rw-r--r--lang/gcc46/Makefile4
-rw-r--r--lang/gcc47/Makefile4
-rw-r--r--lang/gcc48/Makefile4
10 files changed, 40 insertions, 0 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 56ef7f2fba29..45a1a5cb4e29 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -44,6 +44,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+.endif
+
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.else
diff --git a/lang/gcc40/Makefile b/lang/gcc40/Makefile
index 56ef7f2fba29..45a1a5cb4e29 100644
--- a/lang/gcc40/Makefile
+++ b/lang/gcc40/Makefile
@@ -44,6 +44,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+.endif
+
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.else
diff --git a/lang/gcc41/Makefile b/lang/gcc41/Makefile
index 56ef7f2fba29..45a1a5cb4e29 100644
--- a/lang/gcc41/Makefile
+++ b/lang/gcc41/Makefile
@@ -44,6 +44,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+.endif
+
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.else
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index 56ef7f2fba29..45a1a5cb4e29 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -44,6 +44,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+.endif
+
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.else
diff --git a/lang/gcc43/Makefile b/lang/gcc43/Makefile
index 56ef7f2fba29..45a1a5cb4e29 100644
--- a/lang/gcc43/Makefile
+++ b/lang/gcc43/Makefile
@@ -44,6 +44,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+.endif
+
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.else
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index 56ef7f2fba29..45a1a5cb4e29 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -44,6 +44,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+.endif
+
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.else
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index 56ef7f2fba29..45a1a5cb4e29 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -44,6 +44,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+.endif
+
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.else
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index 56ef7f2fba29..45a1a5cb4e29 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -44,6 +44,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+.endif
+
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.else
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 56ef7f2fba29..45a1a5cb4e29 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -44,6 +44,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+.endif
+
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.else
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 56ef7f2fba29..45a1a5cb4e29 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -44,6 +44,10 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+.endif
+
.if ${ARCH} == "amd64"
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.else