aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/doctorj/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/devel/doctorj/Makefile b/devel/doctorj/Makefile
index 8b4fa223ee15..4406f45bc274 100644
--- a/devel/doctorj/Makefile
+++ b/devel/doctorj/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= devel java
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= A tool for analyzing Java code and documentation
+COMMENT= Tool for analyzing Java code and documentation
USE_JAVA= yes
JAVA_VERSION= 1.6+
@@ -16,16 +16,11 @@ USE_ANT= yes
ALL_TARGET= jarfile
-MAN1= doctorj.1
-PLIST_FILES= %%JAVAJARDIR%%/doctorj.jar
+PLIST_FILES= %%JAVAJARDIR%%/doctorj.jar man/man1/doctorj.1.gz
-NO_STAGE= yes
do-install:
- @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/doctorj.jar..."
- @${MKDIR} ${JAVAJARDIR}
- @${INSTALL_DATA} ${WRKSRC}/share/doctorj/doctorj.jar ${JAVAJARDIR}/
- @${ECHO_MSG} -n ">> Installing MANPAGE ..."
- @${INSTALL_MAN} ${WRKSRC}/doc/doctorj.1 ${MAN1PREFIX}/man/man1
- @${ECHO_MSG} " [ DONE ]"
+ @${MKDIR} ${STAGEDIR}${JAVAJARDIR}
+ ${INSTALL_DATA} ${WRKSRC}/share/doctorj/doctorj.jar ${STAGEDIR}${JAVAJARDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/doctorj.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>