aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/libid3tag/Makefile1
-rw-r--r--audio/portaudio2/Makefile1
-rw-r--r--devel/ORBit/Makefile1
-rw-r--r--devel/eina/Makefile1
-rw-r--r--math/mpc/Makefile1
-rw-r--r--print/pdflib/Makefile1
-rw-r--r--science/libint/Makefile1
-rw-r--r--security/gnutls/Makefile1
-rw-r--r--sysutils/sg3_utils/Makefile1
-rw-r--r--textproc/raptor2/Makefile1
10 files changed, 10 insertions, 0 deletions
diff --git a/audio/libid3tag/Makefile b/audio/libid3tag/Makefile
index 4a697ad667f6..2d42af4a354c 100644
--- a/audio/libid3tag/Makefile
+++ b/audio/libid3tag/Makefile
@@ -17,6 +17,7 @@ COMMENT= ID3 tags library (part of MAD project)
LICENSE= GPLv2
+WITH_FBSD10_FIX=yes
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/audio/portaudio2/Makefile b/audio/portaudio2/Makefile
index a99747650b1f..5634cd8e4753 100644
--- a/audio/portaudio2/Makefile
+++ b/audio/portaudio2/Makefile
@@ -14,6 +14,7 @@ DISTNAME= pa_stable_v${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Portable cross-platform Audio API
+WITH_FBSD10_FIX=yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-alsa \
diff --git a/devel/ORBit/Makefile b/devel/ORBit/Makefile
index a55537f7f8d0..21d02d8f5665 100644
--- a/devel/ORBit/Makefile
+++ b/devel/ORBit/Makefile
@@ -15,6 +15,7 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= High-performance CORBA ORB with support for the C language
+WITH_FBSD10_FIX=yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GNOME= glib12
diff --git a/devel/eina/Makefile b/devel/eina/Makefile
index fac9f59acaf7..a43e18edde45 100644
--- a/devel/eina/Makefile
+++ b/devel/eina/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= http://download.enlightenment.org/releases/ \
MAINTAINER= magik@roorback.net
COMMENT= Enlightenment API for data types
+WITH_FBSD10_FIX=yes
LICENSE= LGPL21
DIST_SUBDIR= e17
USE_BZIP2= yes
diff --git a/math/mpc/Makefile b/math/mpc/Makefile
index 0022e795a57e..89ab899ab909 100644
--- a/math/mpc/Makefile
+++ b/math/mpc/Makefile
@@ -21,6 +21,7 @@ CONFIGURE_ARGS= --with-gmp=${LOCALBASE} \
--with-mpfr=${LOCALBASE}
USE_LDCONFIG= yes
+WITH_FBSD10_FIX=yes
INFO= mpc
PLIST_FILES= include/mpc.h \
lib/libmpc.a lib/libmpc.la lib/libmpc.so lib/libmpc.so.2
diff --git a/print/pdflib/Makefile b/print/pdflib/Makefile
index 6b1e8105cb3f..9ecbdfd99999 100644
--- a/print/pdflib/Makefile
+++ b/print/pdflib/Makefile
@@ -16,6 +16,7 @@ COMMENT= A C library for dynamically generating PDF
RESTRICTED= many odd restrictions on usage and distribution
+WITH_FBSD10_FIX=yes
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
diff --git a/science/libint/Makefile b/science/libint/Makefile
index 2b7319f49e3b..21aa568fd074 100644
--- a/science/libint/Makefile
+++ b/science/libint/Makefile
@@ -18,6 +18,7 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
ALL_TARGET= # empty
+WITH_FBSD10_FIX=yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index fe3701afc204..fc65e46211cb 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= nettle.4:${PORTSDIR}/security/nettle \
CONFLICTS= gnutls-devel-[0-9]*
+WITH_FBSD10_FIX=yes
USE_BZIP2= yes
USE_ICONV= yes
USE_GNOME= pkgconfig ltverhack gnomehack
diff --git a/sysutils/sg3_utils/Makefile b/sysutils/sg3_utils/Makefile
index d5c806a782fe..f3aa9b717e59 100644
--- a/sysutils/sg3_utils/Makefile
+++ b/sysutils/sg3_utils/Makefile
@@ -17,6 +17,7 @@ COMMENT= Set of utilities that send SCSI commands to devices
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+WITH_FBSD10_FIX=yes
MAN8= scsi_readcap.8 scsi_ready.8 scsi_start.8 scsi_stop.8 \
sg3_utils.8 sg_format.8 sg_get_config.8 sg_get_lba_status.8 \
diff --git a/textproc/raptor2/Makefile b/textproc/raptor2/Makefile
index 9509d75ffcbf..f0b84800c374 100644
--- a/textproc/raptor2/Makefile
+++ b/textproc/raptor2/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
CONFLICTS= raptor-1.4.1[0-9]* raptor-1.4.21
+WITH_FBSD10_FIX=yes
USE_GNOME= gnomehack libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-xml2-config=${LOCALBASE}/bin/xml2-config \