aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--UIDs1
-rw-r--r--net-mgmt/cricket/Makefile23
2 files changed, 14 insertions, 10 deletions
diff --git a/UIDs b/UIDs
index 947911cb3f67..7d6b45d76b4d 100644
--- a/UIDs
+++ b/UIDs
@@ -71,6 +71,7 @@ vchat:*:128:128:VChat Conferencing System:/nonexistent:/usr/sbin/nologin
_bgpd:*:130:130:BGP Daemon:/var/empty:/usr/sbin/nologin
_ospfd:*:131:131:OSPF Daemon:/var/empty:/usr/sbin/nologin
_spamd:*:132:132:Spam Daemon:/var/empty:/usr/sbin/nologin
+cricket:*:141:80:Cricket Monitoring User:/nonexistent:/usr/sbin/nologin
dovecot:*:143:143:Dovecot User:/var/empty:/usr/sbin/nologin
rbldns:*:153:153:rbldnsd pseudo-user:/nonexistent:/usr/sbin/nologin
sfs:*:171:171:Self-Certifying File System:/nonexistent:/usr/sbin/nologin
diff --git a/net-mgmt/cricket/Makefile b/net-mgmt/cricket/Makefile
index 1e251f1de635..80c01f992953 100644
--- a/net-mgmt/cricket/Makefile
+++ b/net-mgmt/cricket/Makefile
@@ -16,16 +16,18 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A high performance, extremely flexible monitoring system
-RUN_DEPENDS= ${SITE_PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
- ${SITE_PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/SNMP_Session.pm:${PORTSDIR}/net-mgmt/p5-SNMP_Session \
${SITE_PERL}/Time/Zone.pm:${PORTSDIR}/devel/p5-TimeDate
-IGNORE= uses a UID registered to another port
+.include <bsd.port.pre.mk>
-SITE_PERL_ARCH= ${SITE_PERL}/${PERL_ARCH}
+# A reliable version of Time::HiRes is included with perl 5.8.7 and later.
+.if ${PERL_LEVEL} < 500807
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
HAS_CONFIGURE= yes
USE_PERL5= yes
@@ -33,10 +35,11 @@ NO_BUILD= yes
PLIST_SUB+= VERSION=${PORTVERSION}
SUB_FILES= pkg-message pkg-install
SUB_LIST= USER="${CRICKET_USER}" GROUP="${CRICKET_GROUP}" UID="${CRICKET_UID}" GID="${CRICKET_GID}"
-CRICKET_USER?= wwwadm
-CRICKET_UID?= 81
-CRICKET_GROUP?= www
-CRICKET_GID?= 80
+# UID and username comes from ports/UIDs.
+CRICKET_USER= cricket
+CRICKET_UID= 141
+CRICKET_GROUP= www
+CRICKET_GID= 80
post-patch:
@${REINPLACE_CMD} -e 's,/home/cricket,${PREFIX},g' \
@@ -66,4 +69,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>