aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-fonts/fontconfig/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/x11-fonts/fontconfig/Makefile b/x11-fonts/fontconfig/Makefile
index 6ddb7d338c86..74e5019008f2 100644
--- a/x11-fonts/fontconfig/Makefile
+++ b/x11-fonts/fontconfig/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
USE_GMAKE= yes
-USE_X_PREFIX= yes
+PREFIX?= ${X11BASE}
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
@@ -30,6 +30,13 @@ CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc/fonts \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${DISTNAME}/fontconfig
+.include <bsd.port.pre.mk>
+.if ${XFREE86_VERSION} == 3
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+.else
+MTREE_FILE= /etc/mtree/BSD.x11-4.dist
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|[(]LIBDIR[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
@@ -38,4 +45,4 @@ post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>