aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--www/Makefile1
-rw-r--r--www/hs-yesod-core/Makefile29
-rw-r--r--www/hs-yesod-core/distinfo2
-rw-r--r--www/hs-yesod-core/pkg-descr6
5 files changed, 39 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index a9ee63ae4b50..9820918af5f1 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -291,6 +291,7 @@ xmonad_port= x11-wm/hs-xmonad # executable
xmonad-contrib_port= x11-wm/hs-xmonad-contrib
xss-sanitize_port= www/hs-xss-sanitize
yaml_port= textproc/hs-yaml
+yesod-core_port= www/hs-yesod-core
zip-archive_port= archivers/hs-zip-archive
zlib_port= archivers/hs-zlib
zlib-bindings_port= archivers/hs-zlib-bindings
diff --git a/www/Makefile b/www/Makefile
index e58ec836d3b5..b06e3611e504 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -316,6 +316,7 @@
SUBDIR += hs-warp
SUBDIR += hs-webkit
SUBDIR += hs-xss-sanitize
+ SUBDIR += hs-yesod-core
SUBDIR += htdump
SUBDIR += html2hdml
SUBDIR += html2wml
diff --git a/www/hs-yesod-core/Makefile b/www/hs-yesod-core/Makefile
new file mode 100644
index 000000000000..abd533880138
--- /dev/null
+++ b/www/hs-yesod-core/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: hs-yesod-core
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= yesod-core
+PORTVERSION= 0.9.4.1
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Creation of type-safe, RESTful web applications
+
+LICENSE= BSD
+
+USE_CABAL= aeson>=0.3 blaze-builder>=0.2.1.4 blaze-html>=0.4.1.3 \
+ case-insensitive>=0.2 cereal>=0.3 clientsession>=0.7.3.1 \
+ cookie>=0.3 data-object>=0.3 data-object-yaml>=0.3 \
+ enumerator>=0.4.8 failure>=0.1 fast-logger>=0.0.1 \
+ hamlet>=0.10.6 http-types>=0.6.5 monad-control>=0.2 \
+ parsec>=2 path-pieces>=0.0 shakespeare>=0.10 \
+ shakespeare-css>=0.10.5 shakespeare-i18n \
+ shakespeare-js>=0.10.4 text>=0.7 transformers>=0.2.2 \
+ transformers-base>=0.4 vector>=0.9 wai>=0.4 wai-extra>=0.4.1 \
+ wai-logger>=0.0.1
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-yesod-core/distinfo b/www/hs-yesod-core/distinfo
new file mode 100644
index 000000000000..796d234510d5
--- /dev/null
+++ b/www/hs-yesod-core/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/yesod-core-0.9.4.1.tar.gz) = e65b3731e2d3c4618f74b6901043e729690c541e7373f473ecea72a81b621d11
+SIZE (cabal/yesod-core-0.9.4.1.tar.gz) = 42308
diff --git a/www/hs-yesod-core/pkg-descr b/www/hs-yesod-core/pkg-descr
new file mode 100644
index 000000000000..38cc39b868bd
--- /dev/null
+++ b/www/hs-yesod-core/pkg-descr
@@ -0,0 +1,6 @@
+Yesod is a framework designed to foster creation of RESTful web
+application that have strong compile-time guarantees of correctness. It
+also affords space efficient code and portability to many deployment
+backends, from CGI to stand-alone serving.
+
+WWW: http://www.yesodweb.com/