aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/powerdns/Makefile6
-rw-r--r--dns/powerdns/files/patch-pdns_dnspacket.cc2
2 files changed, 3 insertions, 5 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 5529ce944002..b82e27497ecb 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -12,10 +12,10 @@ COMMENT= Advanced DNS server with multiple backends including SQL
LICENSE= GPLv2
-BROKEN_powerpc64= Does not build
-
LIB_DEPENDS= libboost_serialization.so:devel/boost-libs
+BROKEN_powerpc64= Does not build
+
USES= cpe gmake libtool lua pkgconfig tar:bzip2
USE_LDCONFIG= YES
USE_SUBMAKE= YES
@@ -122,8 +122,6 @@ TOOLS_DESC= Build extra tools
REMOTEOPT_DESC= Remote backend connectors
ZEROMQ_DESC= Enable ZeroMQ connector (Implies REMOTE enabled)
-.include <bsd.port.options.mk>
-
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for i in pdns.conf
diff --git a/dns/powerdns/files/patch-pdns_dnspacket.cc b/dns/powerdns/files/patch-pdns_dnspacket.cc
index 641cb4082a41..72eb0d94c59e 100644
--- a/dns/powerdns/files/patch-pdns_dnspacket.cc
+++ b/dns/powerdns/files/patch-pdns_dnspacket.cc
@@ -7,7 +7,7 @@
- uint64_t now = time(0);
- if(abs(trc->d_time - now) > trc->d_fudge) {
- L<<Logger::Error<<"Packet for '"<<q->qdomain<<"' denied: TSIG (key '"<<*keyname<<"') time delta "<< abs(trc->d_time - now)<<" > 'fudge' "<<trc->d_fudge<<endl;
-+ uint64_t delta = std::abs((int64_t)trc->d_time - (int64_t)time(0));
++ uint64_t delta = std::labs((int64_t)trc->d_time - (int64_t)time(0));
+ if(delta > trc->d_fudge) {
+ L<<Logger::Error<<"Packet for '"<<q->qdomain<<"' denied: TSIG (key '"<<*keyname<<"') time delta "<< delta <<" > 'fudge' "<<trc->d_fudge<<endl;
return false;