aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-im/centericq/Makefile2
-rw-r--r--net-im/centericq/files/patch-msnhook.cc16
-rw-r--r--net/centericq/Makefile2
-rw-r--r--net/centericq/files/patch-msnhook.cc16
4 files changed, 32 insertions, 4 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index 170a0f75b905..1279da3af02e 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -8,7 +8,7 @@
PORTNAME= centericq
PORTVERSION= 4.9.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://konst.org.ua/download/
diff --git a/net-im/centericq/files/patch-msnhook.cc b/net-im/centericq/files/patch-msnhook.cc
index 9d8a7559f832..653618e18ef5 100644
--- a/net-im/centericq/files/patch-msnhook.cc
+++ b/net-im/centericq/files/patch-msnhook.cc
@@ -1,5 +1,5 @@
--- src/hooks/msnhook.cc Fri Dec 13 00:17:12 2002
-+++ src/hooks/msnhook.cc Wed Dec 18 14:57:02 2002
++++ src/hooks/msnhook.cc Sun Jan 5 02:02:44 2003
@@ -29,6 +29,7 @@
#include "accountmanager.h"
#include "eventmanager.h"
@@ -18,6 +18,20 @@
if(c)
if(c->getstatus() != offline || !c->inlist()) {
+@@ -352,11 +354,11 @@
+
+ void msnhook::checkfriendly(icqcontact *c, const string friendlynick, bool forcefetch) {
+ string oldnick = c->getnick();
+- string newnick = unmime(friendlynick);
++ string newnick = Utf8ToStr(unmime(friendlynick));
+
+ c->setnick(newnick);
+
+- if(forcefetch || (oldnick != newnick && c->getdispnick() == oldnick) || oldnick.empty()) {
++ if(forcefetch || (oldnick != newnick && c->getdispnick() != newnick) || oldnick.empty()) {
+ c->setdispnick(newnick);
+ face.relaxedupdate();
+ }
@@ -556,7 +558,8 @@
mhook.checkinlist(ic);
diff --git a/net/centericq/Makefile b/net/centericq/Makefile
index 170a0f75b905..1279da3af02e 100644
--- a/net/centericq/Makefile
+++ b/net/centericq/Makefile
@@ -8,7 +8,7 @@
PORTNAME= centericq
PORTVERSION= 4.9.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://konst.org.ua/download/
diff --git a/net/centericq/files/patch-msnhook.cc b/net/centericq/files/patch-msnhook.cc
index 9d8a7559f832..653618e18ef5 100644
--- a/net/centericq/files/patch-msnhook.cc
+++ b/net/centericq/files/patch-msnhook.cc
@@ -1,5 +1,5 @@
--- src/hooks/msnhook.cc Fri Dec 13 00:17:12 2002
-+++ src/hooks/msnhook.cc Wed Dec 18 14:57:02 2002
++++ src/hooks/msnhook.cc Sun Jan 5 02:02:44 2003
@@ -29,6 +29,7 @@
#include "accountmanager.h"
#include "eventmanager.h"
@@ -18,6 +18,20 @@
if(c)
if(c->getstatus() != offline || !c->inlist()) {
+@@ -352,11 +354,11 @@
+
+ void msnhook::checkfriendly(icqcontact *c, const string friendlynick, bool forcefetch) {
+ string oldnick = c->getnick();
+- string newnick = unmime(friendlynick);
++ string newnick = Utf8ToStr(unmime(friendlynick));
+
+ c->setnick(newnick);
+
+- if(forcefetch || (oldnick != newnick && c->getdispnick() == oldnick) || oldnick.empty()) {
++ if(forcefetch || (oldnick != newnick && c->getdispnick() != newnick) || oldnick.empty()) {
+ c->setdispnick(newnick);
+ face.relaxedupdate();
+ }
@@ -556,7 +558,8 @@
mhook.checkinlist(ic);