aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/apache-xml-security-c/Makefile16
-rw-r--r--security/apache-xml-security-c/distinfo6
-rw-r--r--security/apache-xml-security-c/pkg-plist2
3 files changed, 16 insertions, 8 deletions
diff --git a/security/apache-xml-security-c/Makefile b/security/apache-xml-security-c/Makefile
index f0d2bd6024de..a184f730566c 100644
--- a/security/apache-xml-security-c/Makefile
+++ b/security/apache-xml-security-c/Makefile
@@ -6,15 +6,23 @@
#
PORTNAME= xml-security-c
-PORTVERSION= 1.3.1
+PORTVERSION= 1.4.0
CATEGORIES= security
MASTER_SITES= http://xml.apache.org/security/dist/c-library/
PKGNAMEPREFIX= apache-
-MAINTAINER= tonymaher@optusnet.com.au
+MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Apache XML security libraries C version
-LIB_DEPENDS= xerces-c.27:${PORTSDIR}/textproc/xerces-c2
+OPTIONS= XERCES_DEVEL "With Xerces vesion 2.8 (shibboleth2 requires)" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_XERCES_DEVEL)
+LIB_DEPENDS+= xerces-c.28:${PORTSDIR}/textproc/xerces-c2-devel
+.else
+LIB_DEPENDS+= xerces-c.27:${PORTSDIR}/textproc/xerces-c2
+.endif
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-xerces=${LOCALBASE}
@@ -22,4 +30,4 @@ USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_LDCONFIG= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/apache-xml-security-c/distinfo b/security/apache-xml-security-c/distinfo
index 30151055c8ee..1c0e3a46add1 100644
--- a/security/apache-xml-security-c/distinfo
+++ b/security/apache-xml-security-c/distinfo
@@ -1,3 +1,3 @@
-MD5 (xml-security-c-1.3.1.tar.gz) = 1da072b76eaa69241b1e56da61e2e182
-SHA256 (xml-security-c-1.3.1.tar.gz) = c99f81bc18fbfa8043832abde09a9a750b2eefa7a3a9f1ed442952bde26bf7d5
-SIZE (xml-security-c-1.3.1.tar.gz) = 3170378
+MD5 (xml-security-c-1.4.0.tar.gz) = dd9accf6727eb008dbf1dd674d5d4dcc
+SHA256 (xml-security-c-1.4.0.tar.gz) = 955c570a965ab58d021a797ad85ad052ec37d9b8739d9a926d1081fb96c6245f
+SIZE (xml-security-c-1.4.0.tar.gz) = 934876
diff --git a/security/apache-xml-security-c/pkg-plist b/security/apache-xml-security-c/pkg-plist
index 78f55d1c13b1..0395773384ad 100644
--- a/security/apache-xml-security-c/pkg-plist
+++ b/security/apache-xml-security-c/pkg-plist
@@ -155,7 +155,7 @@ include/xsec/xkms/XKMSValidityInterval.hpp
lib/libxml-security-c.a
lib/libxml-security-c.la
lib/libxml-security-c.so
-lib/libxml-security-c.so.13
+lib/libxml-security-c.so.14
@dirrm include/xsec/xkms
@dirrm include/xsec/xenc
@dirrm include/xsec/utils/unixutils