aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/arla/Makefile7
-rw-r--r--net/freeradius/Makefile3
-rw-r--r--net/freeradius2/Makefile3
-rw-r--r--security/pam_krb5/Makefile4
4 files changed, 9 insertions, 8 deletions
diff --git a/net/arla/Makefile b/net/arla/Makefile
index 906285f97635..7e3d7f657507 100644
--- a/net/arla/Makefile
+++ b/net/arla/Makefile
@@ -7,6 +7,7 @@
PORTNAME= arla
PORTVERSION= 0.40
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.stacken.kth.se/pub/arla/
@@ -20,9 +21,7 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "security/heimdal is broken"
-.elif ${OSVERSION} < 600007
+.if ${OSVERSION} < 600007
BROKEN= "compiles but overwrites files from a dependency (security/heimdal)"
.else
BROKEN= "does not compile"
@@ -39,7 +38,7 @@ CONFIGURE_ARGS= --with-roken=${LOCALBASE}
.if defined(WITHOUT_KRB5)
CONFIGURE_ARGS+=--without-krb5
.elif !defined(WITH_SYSTEM_HEIMDAL)
-LIB_DEPENDS+= krb5.20:${PORTSDIR}/security/heimdal
+LIB_DEPENDS+= krb5.21:${PORTSDIR}/security/heimdal
CONFIGURE_ARGS+=--with-krb5=${LOCALBASE}
.else
CONFIGURE_ARGS+=--with-krb5=/usr
diff --git a/net/freeradius/Makefile b/net/freeradius/Makefile
index a5e57a458830..4bd1ac0c0df9 100644
--- a/net/freeradius/Makefile
+++ b/net/freeradius/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freeradius
PORTVERSION= 1.1.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.freeradius.org/pub/radius/ \
http://freeradius.portal-to-web.de/
@@ -66,7 +67,7 @@ WITH_KERBEROS= yes
.ifdef(WITH_KERBEROS)
.ifdef(WITH_HEIMDAL)
-LIB_DEPENDS+= krb5.20:${PORTSDIR}/security/heimdal
+LIB_DEPENDS+= krb5.21:${PORTSDIR}/security/heimdal
CONFIGURE_ARGS+=--enable-heimdal-krb5
.else
LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index a5e57a458830..4bd1ac0c0df9 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freeradius
PORTVERSION= 1.1.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.freeradius.org/pub/radius/ \
http://freeradius.portal-to-web.de/
@@ -66,7 +67,7 @@ WITH_KERBEROS= yes
.ifdef(WITH_KERBEROS)
.ifdef(WITH_HEIMDAL)
-LIB_DEPENDS+= krb5.20:${PORTSDIR}/security/heimdal
+LIB_DEPENDS+= krb5.21:${PORTSDIR}/security/heimdal
CONFIGURE_ARGS+=--enable-heimdal-krb5
.else
LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
diff --git a/security/pam_krb5/Makefile b/security/pam_krb5/Makefile
index d5c8a791ade3..3f5c12b8f60b 100644
--- a/security/pam_krb5/Makefile
+++ b/security/pam_krb5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pam_krb5
PORTVERSION= 1.3.r7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
@@ -28,7 +28,7 @@ KRB5_IMPL= mit
.endif
.if defined(KRB5_IMPL) && ${KRB5_IMPL} == heimdal
-LIB_DEPENDS= krb5.20:${PORTSDIR}/security/heimdal
+LIB_DEPENDS= krb5.21:${PORTSDIR}/security/heimdal
.if defined(HEIMDAL_HOME)
KRB5_DIR?= ${HEIMDAL_HOME}
.endif