aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/nginx/Makefile6
-rw-r--r--www/nginx/distinfo6
-rw-r--r--www/nginx/files/extra-patch-ngx_http_redis_module.c20
3 files changed, 28 insertions, 4 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index de3c4cf4eaa9..a631dcd1f93c 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.7.63
+PORTVERSION= 0.7.64
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -352,6 +352,10 @@ post-patch:
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_notice_module.c
.endif
+.if defined(WITH_HTTP_REDIS_MODULE)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_redis_module.c
+.endif
.if defined(WITH_PASSENGER_MODULE)
@${REINPLACE_CMD} 's!g++!${CXX}!' \
${WRKDIR}/passenger-${PASSENGER_VERSION}/Rakefile
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index e1eb213620d2..82787acc4d45 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,6 +1,6 @@
-MD5 (nginx-0.7.63.tar.gz) = ddbdbeca5206dcc0cd7a4d9cbac00240
-SHA256 (nginx-0.7.63.tar.gz) = 06c1c61e1df3e4b56fbeab29eee66fe2b19bfe9eef20fdb484b2adfd8c1074c8
-SIZE (nginx-0.7.63.tar.gz) = 600683
+MD5 (nginx-0.7.64.tar.gz) = cfa97c0f784532820110b5eee57fef6d
+SHA256 (nginx-0.7.64.tar.gz) = 5705d08af78add2979f566981c86d59f854b0dd350ac09df87c1f55a6846fbcd
+SIZE (nginx-0.7.64.tar.gz) = 601601
MD5 (nginx-accesskey-2.0.3.tar.gz) = 9b5304346d5139b1841f5baa01ab0cbe
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
SIZE (nginx-accesskey-2.0.3.tar.gz) = 2632
diff --git a/www/nginx/files/extra-patch-ngx_http_redis_module.c b/www/nginx/files/extra-patch-ngx_http_redis_module.c
new file mode 100644
index 000000000000..102094fe8a20
--- /dev/null
+++ b/www/nginx/files/extra-patch-ngx_http_redis_module.c
@@ -0,0 +1,20 @@
+--- ../ngx_http_redis-0.2.0/ngx_http_redis_module.c.orig 2009-11-19 11:21:17.000000000 +0300
++++ ../ngx_http_redis-0.2.0/ngx_http_redis_module.c 2009-11-19 11:21:57.000000000 +0300
+@@ -244,7 +244,7 @@
+ vv[0] = ngx_http_get_indexed_variable(r, rlcf->db);
+
+ if (vv[0] == NULL || vv[0]->not_found || vv[0]->len == 0) {
+- ngx_log_debug1(NGX_LOG_DEBUG_HTTP, r->connection->log, 0,
++ ngx_log_debug0(NGX_LOG_DEBUG_HTTP, r->connection->log, 0,
+ "select 0 redis database" );
+ len = sizeof("select 0") - 1;
+ } else {
+@@ -287,7 +287,7 @@
+ ctx->key.data = b->last;
+
+ if (vv[0] == NULL || vv[0]->not_found || vv[0]->len == 0) {
+- ngx_log_debug1(NGX_LOG_DEBUG_HTTP, r->connection->log, 0,
++ ngx_log_debug0(NGX_LOG_DEBUG_HTTP, r->connection->log, 0,
+ "select 0 redis database" );
+ *b->last++ = '0';
+ } else {