aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/phpmyid/Makefile24
-rw-r--r--security/phpmyid/distinfo3
-rw-r--r--security/phpmyid/pkg-descr8
-rw-r--r--security/phpmyid/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3aebe4accc76..4934879287ad 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -537,6 +537,7 @@
SUBDIR += php5-mcrypt
SUBDIR += php5-mhash
SUBDIR += php5-openssl
+ SUBDIR += phpmyid
SUBDIR += pidentd
SUBDIR += pinentry
SUBDIR += pinentry-curses
diff --git a/security/phpmyid/Makefile b/security/phpmyid/Makefile
new file mode 100644
index 000000000000..988bcc64948f
--- /dev/null
+++ b/security/phpmyid/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: phpMyID
+# Date created: 2006-12-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpMyID
+PORTVERSION= 0.3
+CATEGORIES= security www
+MASTER_SITES= http://siege.org/projects/phpMyID/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A single user Identity Provider for the OpenID framework
+
+NO_BUILD= yes
+USE_PHP= session
+
+do-install:
+ ${MKDIR} ${PREFIX}/www/${PORTNAME}
+ ${CP} -R ${WRKSRC}/ ${PREFIX}/www/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/security/phpmyid/distinfo b/security/phpmyid/distinfo
new file mode 100644
index 000000000000..feb4b0651b07
--- /dev/null
+++ b/security/phpmyid/distinfo
@@ -0,0 +1,3 @@
+MD5 (phpMyID-0.3.tgz) = cf1d92a1ee59d3ee27e83db99c80cf88
+SHA256 (phpMyID-0.3.tgz) = dcdcd47245de43587e768b4a52957d804bc8e91774271eb1ea2511ac981f9a26
+SIZE (phpMyID-0.3.tgz) = 14905
diff --git a/security/phpmyid/pkg-descr b/security/phpmyid/pkg-descr
new file mode 100644
index 000000000000..f084d1b095be
--- /dev/null
+++ b/security/phpmyid/pkg-descr
@@ -0,0 +1,8 @@
+phpMyID is a single user (though, if you were so inclined, you could
+easily turn it into a multi-user setup) IdP, or "Identity Provider"
+for the OpenID framework. It's a single PHP script with minimal
+dependancies. You don't need a database, you don't need to make your
+filesystem writable, you don't need to download any libraries, and you
+don't need to recompile PHP.
+
+WWW: http://siege.org/projects/phpMyID/
diff --git a/security/phpmyid/pkg-plist b/security/phpmyid/pkg-plist
new file mode 100644
index 000000000000..190db1014a70
--- /dev/null
+++ b/security/phpmyid/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+www/phpMyID/CHANGELOG
+www/phpMyID/LICENSE
+www/phpMyID/MyID.php
+www/phpMyID/README
+@dirrmtry www/phpMyID