aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/gindent/Makefile9
-rw-r--r--devel/gindent/pkg-plist40
-rw-r--r--ftp/pavuk/Makefile9
3 files changed, 36 insertions, 22 deletions
diff --git a/devel/gindent/Makefile b/devel/gindent/Makefile
index ec3799f1feff..4cf6e8c1f5ac 100644
--- a/devel/gindent/Makefile
+++ b/devel/gindent/Makefile
@@ -16,7 +16,6 @@ DISTNAME= indent-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU indent
-USE_GETTEXT= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -24,6 +23,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DBERKELEY_DEFAULTS=1" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --program-prefix=g
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
MAN1= gindent.1
INFO= indent
diff --git a/devel/gindent/pkg-plist b/devel/gindent/pkg-plist
index 5394c149bf33..4f9606384db3 100644
--- a/devel/gindent/pkg-plist
+++ b/devel/gindent/pkg-plist
@@ -1,24 +1,24 @@
bin/gindent
bin/gtexinfo2man
%%PORTDOCS%%%%DOCSDIR%%/indent.html
-share/locale/ca/LC_MESSAGES/indent.mo
-share/locale/da/LC_MESSAGES/indent.mo
-share/locale/de/LC_MESSAGES/indent.mo
-share/locale/eo/LC_MESSAGES/indent.mo
-share/locale/et/LC_MESSAGES/indent.mo
-share/locale/fi/LC_MESSAGES/indent.mo
-share/locale/fr/LC_MESSAGES/indent.mo
-share/locale/gl/LC_MESSAGES/indent.mo
-share/locale/hu/LC_MESSAGES/indent.mo
-share/locale/it/LC_MESSAGES/indent.mo
-share/locale/ja/LC_MESSAGES/indent.mo
-share/locale/ko/LC_MESSAGES/indent.mo
-share/locale/nl/LC_MESSAGES/indent.mo
-share/locale/pl/LC_MESSAGES/indent.mo
-share/locale/pt_BR/LC_MESSAGES/indent.mo
-share/locale/ru/LC_MESSAGES/indent.mo
-share/locale/sk/LC_MESSAGES/indent.mo
-share/locale/sv/LC_MESSAGES/indent.mo
-share/locale/tr/LC_MESSAGES/indent.mo
-share/locale/zh_TW.Big5/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/da/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/de/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/et/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/it/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/indent.mo
+%%NLS%%share/locale/zh_TW.Big5/LC_MESSAGES/indent.mo
%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/ftp/pavuk/Makefile b/ftp/pavuk/Makefile
index 996e7fbf3e4e..71198e48d3ae 100644
--- a/ftp/pavuk/Makefile
+++ b/ftp/pavuk/Makefile
@@ -18,7 +18,6 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= HTTP, FTP and Gopher mirroring tool
-USE_GETTEXT= yes
USE_OPENSSL= yes
WANT_GNOME= yes
USE_REINPLACE= yes
@@ -27,6 +26,14 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-locale-dir=${LOCALBASE}/share/locale \
--disable-debug --disable-gnome --enable-threads
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
MAN1= pavuk.1
CPPFLAGS= -I${LOCALBASE}/include