aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/rsnapshot/Makefile31
-rw-r--r--sysutils/rsnapshot/distinfo1
-rw-r--r--sysutils/rsnapshot/pkg-descr12
-rw-r--r--sysutils/rsnapshot/pkg-plist8
5 files changed, 53 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 64e73b6a2d64..2f2b704abc1d 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -294,6 +294,7 @@
SUBDIR += rmonitor
SUBDIR += roottail
SUBDIR += rotate
+ SUBDIR += rsnapshot
SUBDIR += rtty
SUBDIR += ruby-log4r
SUBDIR += ruby-quota
diff --git a/sysutils/rsnapshot/Makefile b/sysutils/rsnapshot/Makefile
new file mode 100644
index 000000000000..d7ee5543f473
--- /dev/null
+++ b/sysutils/rsnapshot/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: rsnapshot
+# Date created: 2004-01-03
+# Whom: Ralf van Dooren <r.vdooren@snow.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rsnapshot
+PORTVERSION= 1.0.9
+CATEGORIES= sysutils
+MASTER_SITES= http://www.rsnapshot.org/downloads/
+
+MAINTAINER= r.vdooren@snow.nl
+COMMENT= Filesystem snapshot utility based on rsync(1)
+
+RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync
+
+USE_PERL5= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= rsnapshot.1
+DOCS= AUTHORS ChangeLog README TODO
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/rsnapshot/distinfo b/sysutils/rsnapshot/distinfo
new file mode 100644
index 000000000000..9f406947f5c6
--- /dev/null
+++ b/sysutils/rsnapshot/distinfo
@@ -0,0 +1 @@
+MD5 (rsnapshot-1.0.9.tar.gz) = 6005631fdd4fc7a760e755c737622708
diff --git a/sysutils/rsnapshot/pkg-descr b/sysutils/rsnapshot/pkg-descr
new file mode 100644
index 000000000000..a556f5e3aff0
--- /dev/null
+++ b/sysutils/rsnapshot/pkg-descr
@@ -0,0 +1,12 @@
+rsnapshot is a filesystem snapshot utility based on rsync(1).
+rsnapshot makes it easy to make periodic snapshots of local machines,
+and remote machines over ssh. The code makes extensive use of hard links
+whenever possible, to greatly reduce the disk space required.
+
+It is written entirely in perl with no module dependencies, and has been
+tested with versions 5.004 through 5.8.1.
+
+WWW: http://www.rsnapshot.org
+
+- Ralf van Dooren
+r.vdooren@snow.nl
diff --git a/sysutils/rsnapshot/pkg-plist b/sysutils/rsnapshot/pkg-plist
new file mode 100644
index 000000000000..8600d4dfcde0
--- /dev/null
+++ b/sysutils/rsnapshot/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+bin/rsnapshot
+etc/rsnapshot.conf.default
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%