aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.options.desc.mk2
-rw-r--r--audio/gmpc/Makefile8
2 files changed, 6 insertions, 4 deletions
diff --git a/Mk/bsd.options.desc.mk b/Mk/bsd.options.desc.mk
index d283f118fa9f..1d3bd02e1371 100644
--- a/Mk/bsd.options.desc.mk
+++ b/Mk/bsd.options.desc.mk
@@ -11,6 +11,7 @@ DOCS_DESC?= Build and install the documentation
FLAC_DESC?= Enable support for flac
ID3_DESC?= Enable support for id3 tags
LDAP_DESC?= Enable LDAP support
+MMKEYS_DESC?= Enable multimedia keys support
MP4_DESC?= Enable support for mp4
MULTIBYTE_DESC?= Enable multibyte character support
NLS_DESC?= Build and install the localisation data
@@ -20,3 +21,4 @@ SSL_DESC?= Enable SSL support
STATIC_DESC?= Build static executable/libraries
TIDY_DESC?= Enable tidy html cleaner support
VORBIS_DESC?= Enable support for ogg vorbis
+XSPF_DESC?= Enable support for XSPF
diff --git a/audio/gmpc/Makefile b/audio/gmpc/Makefile
index e4213fea1f78..30eff13fe0de 100644
--- a/audio/gmpc/Makefile
+++ b/audio/gmpc/Makefile
@@ -34,16 +34,16 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= gmpc-remote.1 gmpc.1 gmpc-remote-stream.1
-OPTIONS= MMKEYS "Enable multimedia keys support" on \
- XSPF "Enable support for XSPF playlists" off
+OPTIONS_DEFINE= MMKEYS XSPF
+OPTIONS_DEFAULT= MMKEYS
.include <bsd.port.options.mk>
-.if defined(WITHOUT_MMKEYS)
+.if ${PORT_OPTIONS:MMMKEYS}
CONFIGURE_ARGS+=--disable-mmkeys
.endif
-.if defined(WITH_XSPF)
+.if ${PORT_OPTIONS:MXSPF}
LIB_DEPENDS+= xspf.4:${PORTSDIR}/multimedia/libxspf
CONFIGURE_ARGS+=--enable-libxspf
.else