aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/cyrus-sasl2-saslauthd/Makefile7
-rw-r--r--security/cyrus-sasl2/Makefile7
2 files changed, 12 insertions, 2 deletions
diff --git a/security/cyrus-sasl2-saslauthd/Makefile b/security/cyrus-sasl2-saslauthd/Makefile
index 85bd9c9cc8ad..fb824465422a 100644
--- a/security/cyrus-sasl2-saslauthd/Makefile
+++ b/security/cyrus-sasl2-saslauthd/Makefile
@@ -40,7 +40,6 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--enable-static \
--enable-login \
--enable-auth-sasldb \
- --with-openssl=${OPENSSLBASE} \
--with-rc4=openssl \
--with-saslauthd=${SASLAUTHD_RUNPATH}
@@ -106,6 +105,12 @@ CONFIGURE_ARGS+=--enable-krb4=${LOCALBASE}/krb4
CONFIGURE_ARGS+=--disable-krb4
.endif
+.if ${OPENSSLBASE} == /usr
+CONFIGURE_ARGS+=--with-openssl=yes
+.else
+CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
+.endif
+
CONFIGURE_ENV+= LOCALBASE=${LOCALBASE} \
OPENSSLINC=${OPENSSLINC} \
OPENSSLLIB=${OPENSSLLIB} \
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index d8e5821e83bd..27c83af07acf 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -50,7 +50,6 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--mandir=${MANPREFIX}/man \
--enable-static \
--enable-auth-sasldb \
- --with-openssl=${OPENSSLBASE} \
--with-rc4=openssl \
--with-saslauthd=${SASLAUTHD_RUNPATH}
@@ -188,6 +187,12 @@ CONFIGURE_ARGS+=--disable-krb4
EBONES= "@comment "
.endif
+.if ${OPENSSLBASE} == /usr
+CONFIGURE_ARGS+=--with-openssl=yes
+.else
+CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
+.endif
+
CONFIGURE_ENV+= LOCALBASE=${LOCALBASE} \
OPENSSLINC=${OPENSSLINC} \
OPENSSLLIB=${OPENSSLLIB} \