aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/php52-sqlite/Makefile14
-rw-r--r--databases/php52-sqlite/files/patch-config.m444
-rw-r--r--databases/php52-sybase_ct/Makefile14
-rw-r--r--databases/php52-sybase_ct/files/patch-config.m411
-rw-r--r--devel/Makefile1
-rw-r--r--www/Makefile1
-rw-r--r--www/php52-tidy/Makefile14
8 files changed, 100 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index cd9454084c90..cc2975b6e1be 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -534,6 +534,7 @@
SUBDIR += php52-pdo_sqlite
SUBDIR += php52-pgsql
SUBDIR += php52-sqlite
+ SUBDIR += php52-sybase_ct
SUBDIR += phpminiadmin
SUBDIR += phpmyadmin
SUBDIR += phpmyadmin211
diff --git a/databases/php52-sqlite/Makefile b/databases/php52-sqlite/Makefile
new file mode 100644
index 000000000000..044c6bd3c69a
--- /dev/null
+++ b/databases/php52-sqlite/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-sqlite
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -sqlite
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php52-sqlite/files/patch-config.m4 b/databases/php52-sqlite/files/patch-config.m4
new file mode 100644
index 000000000000..c8cf2bc00557
--- /dev/null
+++ b/databases/php52-sqlite/files/patch-config.m4
@@ -0,0 +1,44 @@
+--- config.m4.orig Wed Nov 30 05:50:03 2005
++++ config.m4 Tue Jan 17 12:51:21 2006
+@@ -48,14 +48,6 @@
+
+
+ if test "$PHP_SQLITE" != "no"; then
+- if test "$PHP_PDO" != "no"; then
+- PHP_CHECK_PDO_INCLUDES([], [AC_MSG_WARN([Cannot find php_pdo_driver.h.])])
+- if test -n "$pdo_inc_path"; then
+- AC_DEFINE([PHP_SQLITE2_HAVE_PDO], [1], [Have PDO])
+- pdo_inc_path="-I$pdo_inc_path"
+- fi
+- fi
+-
+ if test "$PHP_SQLITE" != "yes"; then
+ SEARCH_PATH="/usr/local /usr"
+ SEARCH_FOR="/include/sqlite.h"
+@@ -85,13 +77,12 @@
+ -L$SQLITE_DIR/$PHP_LIBDIR -lm
+ ])
+ SQLITE_MODULE_TYPE=external
+- PHP_SQLITE_CFLAGS=$pdo_inc_path
+ sqlite_extra_sources="libsqlite/src/encode.c"
+ else
+ # use bundled library
+ PHP_PROG_LEMON
+ SQLITE_MODULE_TYPE=builtin
+- PHP_SQLITE_CFLAGS="-I@ext_srcdir@/libsqlite/src -I@ext_builddir@/libsqlite/src $pdo_inc_path"
++ PHP_SQLITE_CFLAGS="-I@ext_srcdir@/libsqlite/src -I@ext_builddir@/libsqlite/src"
+ sqlite_extra_sources="libsqlite/src/opcodes.c \
+ libsqlite/src/parse.c libsqlite/src/encode.c \
+ libsqlite/src/auth.c libsqlite/src/btree.c libsqlite/src/build.c \
+@@ -109,10 +100,9 @@
+ dnl
+ dnl Common for both bundled/external
+ dnl
+- sqlite_sources="sqlite.c sess_sqlite.c pdo_sqlite2.c $sqlite_extra_sources"
++ sqlite_sources="sqlite.c sess_sqlite.c $sqlite_extra_sources"
+ PHP_NEW_EXTENSION(sqlite, $sqlite_sources, $ext_shared,,$PHP_SQLITE_CFLAGS)
+ PHP_ADD_EXTENSION_DEP(sqlite, spl, true)
+- PHP_ADD_EXTENSION_DEP(sqlite, pdo, true)
+
+ PHP_ADD_MAKEFILE_FRAGMENT
+ PHP_SUBST(SQLITE_SHARED_LIBADD)
diff --git a/databases/php52-sybase_ct/Makefile b/databases/php52-sybase_ct/Makefile
new file mode 100644
index 000000000000..3abb177a61a0
--- /dev/null
+++ b/databases/php52-sybase_ct/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-sybase_ct
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -sybase_ct
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php52-sybase_ct/files/patch-config.m4 b/databases/php52-sybase_ct/files/patch-config.m4
new file mode 100644
index 000000000000..ef121d7c4730
--- /dev/null
+++ b/databases/php52-sybase_ct/files/patch-config.m4
@@ -0,0 +1,11 @@
+--- config.m4.orig 2009-03-26 09:53:49.000000000 +0100
++++ config.m4 2009-03-26 09:55:35.000000000 +0100
+@@ -31,7 +31,7 @@
+ fi
+
+ PHP_ADD_LIBPATH($SYBASE_CT_LIBDIR, SYBASE_CT_SHARED_LIBADD)
+- if test -f $SYBASE_CT_INCDIR/tds.h; then
++ if test -f $SYBASE_CT_INCDIR/tds_sysdep_public.h; then
+ PHP_ADD_LIBRARY(ct,, SYBASE_CT_SHARED_LIBADD)
+ SYBASE_CT_LIBS="-L$SYBASE_CT_LIBDIR -lct"
+ else
diff --git a/devel/Makefile b/devel/Makefile
index 2acb46b21272..e956b094b1fd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2477,6 +2477,7 @@
SUBDIR += php52-readline
SUBDIR += php52-shmop
SUBDIR += php52-spl
+ SUBDIR += php52-tokenizer
SUBDIR += phpbt
SUBDIR += phptags
SUBDIR += physfs
diff --git a/www/Makefile b/www/Makefile
index 3c5e3f9eb578..bd7eb2f2b283 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1340,6 +1340,7 @@
SUBDIR += php5-session
SUBDIR += php5-tidy
SUBDIR += php52-session
+ SUBDIR += php52-tidy
SUBDIR += phpbb
SUBDIR += phpbb-devel
SUBDIR += phpbb3
diff --git a/www/php52-tidy/Makefile b/www/php52-tidy/Makefile
new file mode 100644
index 000000000000..42021d565b9c
--- /dev/null
+++ b/www/php52-tidy/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-tidy
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= www
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -tidy
+
+.include "${MASTERDIR}/Makefile"