aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--biology/Makefile1
-rw-r--r--biology/phd2fasta/Makefile48
2 files changed, 49 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 3c4484cea3a9..a5d67b95304e 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -64,6 +64,7 @@
SUBDIR += p5-bioperl-run
SUBDIR += p5-bioperl-run-devel
SUBDIR += paml
+ SUBDIR += phd2fasta
SUBDIR += phylip
SUBDIR += platon
SUBDIR += povchem
diff --git a/biology/phd2fasta/Makefile b/biology/phd2fasta/Makefile
new file mode 100644
index 000000000000..ef0df20fa7dc
--- /dev/null
+++ b/biology/phd2fasta/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: phd2fasta
+# Date created: 6 December 2007
+# Whom: Motomichi Matsuzaki <mzaki@biol.s.u-tokyo.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phd2fasta
+PORTVERSION= 0.990622.f
+CATEGORIES= biology
+MASTER_SITES= # put the tarball manually
+DISTFILES= phd2fasta-acd-dist.tar.Z
+
+MAINTAINER= mzaki@biol.s.u-tokyo.ac.jp
+COMMENT= A converter from output files of Phred/Consed to FASTA files
+
+RESTRICTED= Redistribution is not permitted in any form. You must request the tarball via e-mail. Free for academic use.
+
+NO_WRKSUBDIR= yes
+
+ALL_TARGET= phd2fasta
+
+BINMODE= 0111 # avoid copying binaries as required by the agreement
+BINARIES= phd2fasta
+PLIST_FILES= bin/phd2fasta
+
+PORTDOCS= PHD2FASTA.DOC
+
+.include <bsd.port.pre.mk>
+
+.for f in ${DISTFILES}
+.if !exists(${DISTDIR}/${f})
+IGNORE= you must request the source code \(${f}\) via e-mail, place it manually in ${DISTDIR}, and then try it again
+.endif
+.endfor
+
+do-install:
+.for f in ${BINARIES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin/
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>